Bedienungsanleitung

jCAPT – Java Content Assembling and Packaging Tools

FIM Institut für Informationsverarbeitung und Mikroprozessortechnik

<jcapt@fim.uni-linz.ac.at>

Copyright © 2006 FIM Institut für Informationsverarbeitung und Mikroprozessortechnik

Zusammenfassung

Die Bedienungsanleitung bietet Endbenutzern umfassende Hilfe zur Bedienung des Lernpaket- und Metadateneditors jCAPT. In der Einleitung wird ein Überblick über die unterstützten Funktionen und ein schneller Einstieg in der grundlegenden Bedienung gegeben. Im Hauptteil bietet eine aufgabenorientierten Bedienanleitung mit vielen Bildschirmschnappschüssen und Animationen eine detaillierte und umfassende Beschreibung zur Anwendung von jCAPT. Der Referenzteil geht näher auf die Konfigurationsmöglichkeiten und für die Bedienungn relevante Interna von jCAPT ein.

Inhaltsverzeichnis

Einleitung
I. Bedienung
1. Einleitung
1.1. Funktionen
1.2. Schnellstart
2. Bedienung
2.1. Allgemeine Aktionen
2.2. CPS-Paket-Operationen
2.3. Material-Organisation
2.4. Lernpaket aufbauen und bearbeiten
2.5. Dateivorschau
2.6. Paketvorschau
2.7. Metadatenerstellung und -bearbeitung
2.8. Lernpaketexport
II. Referenz
1. Programmkonfiguration
1.1. Einstellungen-Dialog öffnen
1.2. Allgemeine Einstellungen
1.3. Einstellungen zu CPS-Paketen
1.4. Einstellungen für die Metadatenbearbeitung
2. Berechnung der Speicherposition von Ressourcen
3. Bestimmung der Abhängigkeiten von Ressourcen
Abbildungsverzeichnis
Copyright 2006, FIM Institut für Informationsverarbeitung und Mikroprozessortechnik


Einleitung

In dieser Anleitung wird die Bedienung des Lernpaket- und Metadateneditors jCAPT beschrieben. Im Teil I, „Bedienung“ wird nach einer anfänglichen Einführung eine aufgabenorientierte Bedienanleitung gegeben. Sie enthält eine schrittweise Einführung und die Erklärung typischer Aufgaben mit Anwendungsbeispielen. Angereichert mit Bildschirmschnappschüssen und Animationen der konkreten Bedienung ist sie zum schrittweisen Einstieg in die Bedienung von jCAPT gedacht.

Der Teil II, „Referenz“ ist als Nachschlagewerk für spezielle Aspekte Fragen gedacht. Hier werden die Konfigurationsmöglichkeiten sowie einige für die Bedienung relevante Interna von jCAPT beschrieben.

Beim Lesen der Bedienungsanleitung ist ein Vorwissen zum IMS CPS Standard und eines der unterstützten Metadaten Standards (IEEE LOM, IMS LRM bzw. Österreichischen Metadatenspezifikation für elektronische Lehr-/Lernressourcen) hilfreich. Eine Einführung hierzu findet sich in der Systembeschreibung, welche unter anderem auch die Möglichkeiten und Einschränkungen für diese unterstützten Standards beschreibt. Im Internet sind Beschreibungen zu den Standards unter folgenden Links zu finden:

  • IMS Content Packaging Specification Version 1.1.3

    • Information Model

      http://www.imsglobal.org/content/packaging/cpv1p1p3/imscp_infov1p1p3.html

    • XML Binding

      http://www.imsglobal.org/content/packaging/cpv1p1p3/imscp_bindv1p1p3.html

    • Best Practice Guide

      http://www.imsglobal.org/content/packaging/cpv1p1p3/imscp_bestv1p1p3.html

  • IEEE Learning Object Metadata

    http://ltsc.ieee.org/wg12/

  • IMS Learning Resource Meta-data

    http://www.imsglobal.org/metadata/

  • Österreichischen Metadatenspezifikation für elektronische Lehr-/Lernressourcen

    http://elearning.bildung.at/


Teil I. Bedienung

jCAPT Java Content Assembling and Packaging Tools

Bedienung

Inhaltsverzeichnis

1. Einleitung
1.1. Funktionen
1.2. Schnellstart
2. Bedienung
2.1. Allgemeine Aktionen
2.2. CPS-Paket-Operationen
2.3. Material-Organisation
2.4. Lernpaket aufbauen und bearbeiten
2.5. Dateivorschau
2.6. Paketvorschau
2.7. Metadatenerstellung und -bearbeitung
2.8. Lernpaketexport


Kapitel 1. Einleitung

Inhaltsverzeichnis

1.1. Funktionen
1.2. Schnellstart

Dieses Kapitel dient dem Einstieg in die Verwendung von jCAPT. Im ersten Teil erfolgt eine Beschreibung des Funktionsumfangs und der Möglichkeiten des Programms. Im zweiten Teil wird ein schneller Einstieg in die Bedienung von jCAPT geboten, auch um einen Gesamteindruck vom grundsätzlichen Arbeitsablauf für spätere detailliertere Ausführungen zu erzeugen.


1.1. Funktionen

jCAPT ist ein graphischer Editor für Lernpakete. Er lässt sich zur Bearbeitung und Unterstützung folgender im Arbeitsablauf von der Kurserstellung bis zur -veröffentlichung auftretenden Teilschritte einsetzen:

  1. Material-Organisation (physische Struktur festlegen)

  2. Lernpaket aufbauen und bearbeiten (logische Struktur festlegen)

  3. (automatische) Metadatenerstellung und -bearbeitung

  4. Export des Lernpakets: gepackt für Learning Managament System (LMS) bzw. als Offline-Version

jCAPT bietet die Möglichkeit zur Sammlung und Organisation von Lernmaterial zu einem Grundstock an Ressourcen. Mit diesen kann anschließend die logische Struktur des Lernpakets nach der IMS Content Packaging Specification aufgebaut werden. Um einen Überblick über die verwendeten Materialien zu behalten, können diese in einer Vorschau innerhalb von jCAPT betrachtet werden. Ebenso existiert eine Vorschau für das Lernpaket, um schon bei der Erstellung einen Eindruck vom Endprodukt zu erhalten.

jCAPT unterstützt die Erstellung und Bearbeitung von Metadaten für das Gesamtpaket, sowie auch für Teile des Pakets und – auf unterster Granularitätsebene – für die verwendeten Ressourcen. Unterstützt werden die Standards IMS Learning Resource Metadata, IEEE Learning Object Metadata und die Österreichische Metadatenspezifikation für elektronische Lehr-/Lernressourcen des BMBWK. Es werden hier sowohl die maskenbasierte Bearbeitung als auch das direkte Arbeiten mit der Baumstruktur der Metadaten ermöglicht. Zur Erleichterung einer aufwändigen Eingabe von Metadaten können diese aus den im Lernpaket verwendeten Ressourcen automatisch extrahiert werden.

Der Export eines Lernpakets kann durch jCAPT einerseits als ZIP-Archiv der Ressourcen und des Manifests (zur Verwendung in einem Learning Management System) und andererseits als Offline-Version erfolgen. Eine Offline-Version enhält sämtliche Ressourcen des Pakets, eine Navigationskomponente und eine Metadatenanzeige. Die Navigationskomponente spiegelt die erstellte logische Struktur des Lernpakets wider; die Metadatenanzeige stellt die eingegebenen Metadaten dar. Zur Wahrung der Plattformunabhängigkeit sind diese Teile als (dynamische) HTML-Seiten realisiert, die Anzeige des Lernpakets ist somit in einem Browser möglich.

Neben der Erstellung von neuen Lernpaketen unterstützt jCAPT auch das Bearbeiten von bereits bestehenden Lernpaketen, sofern diese auf Basis von unterstützten Standards angelegt sind.


1.2. Schnellstart

1.2.1. jCAPT starten
1.2.2. Neues CPS-Paket erstellen
1.2.3. Ressourcen importieren
1.2.4. Manifest aufbauen
1.2.5. Dateivorschau benutzen
1.2.6. Paketvorschau benutzen
1.2.7. Metadaten hinzufügen
1.2.8. CPS-Paket als ZIP-Archiv exportieren
1.2.9. CPS-Paket als Offline-Version exportieren

In diesem Kapitel wird ein Schnellstart für die Bedienung von jCAPT gegeben. Es wird ein kleines CPS-Paket erstellt, mit Metadaten versehen und sowohl als ZIP-Archiv wie auch als Offline-Version exportiert. Im Zuge dessen werden die wichtigsten Funktionen kurz angerissen um einen Gesamteindruck vom grundsätzlichen Arbeitsablauf für spätere detailliertere Ausführungen zu geben.


1.2.1. jCAPT starten

Starten Sie jCAPT durch Auswahl des Menüeintrags jCAPT in der Programmgruppe jCAPT im Startmenü.

Start von jCAPT über das Startmenü.

Abbildung 1.1. Start von jCAPT über das Startmenü.

Nach dem Start von jCAPT sehen Sie das Hauptfenster mit dem Schnellstartbereich in der Mitte.

Hauptfenster nach dem Start.

Abbildung 1.2. Hauptfenster nach dem Start.

Zur Illustration finden Sie im Folgenden eine Animation der zu tätigenden Aktionen.

Abbildung 1.3. Animation: Starten von jCAPT.


1.2.2. Neues CPS-Paket erstellen

Um ein neues CPS-Paket zu erstellen klicken Sie im Schnellstartbereich auf die Schaltfläche Neues CPS-Paket erstellen.

Neues CPS-Paket erstellen.

Abbildung 1.4. Neues CPS-Paket erstellen.

In beiden Fällen öffnet sich ein Ordnerwahl-Dialog, mit welchem der Basisordner des CPS-Pakets zu wählen ist. Dieser Basisordner wird die gesamten Ressourcen und das Manifest des CPS-Pakets enthalten. Sie können einen existierenden Ordner (eventuell mit schon vorhandenen Dateien) wählen, oder einen neuen erstellen und diesen wählen.

Basisordner für neues CPS-Paket wählen.

Abbildung 1.5. Basisordner für neues CPS-Paket wählen.

Markieren Sie den gewünschten Basisordner mit einem Mausklick und klicken Sie auf die Schaltfläche Auswählen. Nach der Wahl des Basisordners wird das Manifest in diesem angelegt und es öffnet sich die Arbeitsfläche zum Bearbeiten der Ressourcen und des Manifests in dem CPS-Paket. Wählen der Schaltfläche Abbrechen bricht den Vorgang zum Erstellen eines neuen CPS-Pakets ab und verändert keine Dateien.

Arbeitsfläche zum Bearbeiten der Ressourcen und des Manifests.

Abbildung 1.6. Arbeitsfläche zum Bearbeiten der Ressourcen und des Manifests.

Auf der linken Seite der Arbeitsfläche befindet sich die Ressourcensammlung, auf der rechten die Manifestansicht. Unterhalb der Manifeststruktur können Attribute einzelner Element des Manifests mit Werten versehen werden. Eine kontextsensitive Hilfe zum aktuell gewählten Element des Manifests findet sich im rechten unteren Bildschirmteil.

Zur Illustration finden Sie im Folgenden eine Animation der zu tätigenden Aktionen.

Abbildung 1.7. Animation: Neues CPS-Paket erstellen.


1.2.3. Ressourcen importieren

Wenn die benötigten Ressourcen nicht schon im gewählten Basisordner vorhanden waren, müssen sie nun importiert werden. Klicken Sie hierzu im Bereich der Ressourcensammlung auf die Schaltfläche Import.

Importieren von Ressourcen.

Abbildung 1.8. Importieren von Ressourcen.

Es öffnet sich ein Dialog, in dem Sie die/den zu importierenden Datei(en)/Ordner wählen können. Selektieren Sie das/die gewünschte(n) Dateisystemobjekt(e) mit der Maus bzw. der Tastatur. Durch Halten der Hochstelltaste und gleichzeitiges Wählen können Sie eine zusammenhängende Auswahl treffen. Mit der Strg-Taste können Sie auch nicht-zusammenhängende Teile der Datei-/Ordnerliste selektieren. Starten Sie den Import durch Betätigen der Schaltfläche Importieren.

Auswahl von zu importierenden Ressourcen.

Abbildung 1.9. Auswahl von zu importierenden Ressourcen.

Der Verlauf des Importvorgangs wird über eine Fortschrittsanzeige visualisiert. Es wird der Name der gerade importierten Datei angezeigt und die Möglichkeit zum Abbrechen des Import durch Betätigen der Schaltfläche Abbrechen gegeben.

Fortschrittsanzeige beim Importieren.

Abbildung 1.10. Fortschrittsanzeige beim Importieren.

Wenn der Import abgeschlossen ist, findet/n sich die/der gewählte(n) Datei(en)/Ordner im linken Teil des Arbeitsbereichs bei der Ressourcensammlung.

Importierte Ressourcen in der Ressourcensammlung.

Abbildung 1.11. Importierte Ressourcen in der Ressourcensammlung.

Zur Illustration finden Sie im Folgenden eine Animation der zu tätigenden Aktionen.

Abbildung 1.12. Animation: Ressourcen importieren.


1.2.4. Manifest aufbauen

Nach dem Import der benötigten Ressourcen kann man mit dem Aufbauen des Manifests beginnen. Als erstes benötigt man einen Organisation-Knoten. Fügen Sie diesen durch einen Rechtsklick auf den Knoten Organisationen und Wahl des Menüelements Erstelle Knoten 'Organisation' im sich öffnenden Kontextmenü hinzu.

Abbildung 1.13. Organisation-Knoten hinzufügen.

Sie werden gebeten, den Namen der neu zu erstellenden Organisation einzugeben. Wählen Sie einen aussagekräftigen Namen, der den Inhalt Ihres CPS-Pakets widerspiegelt, und bestätigen Sie durch Betätigen der Schaltfläche OK.

Neue Organisation benennen.

Abbildung 1.14. Neue Organisation benennen.

Der Organisation-Knoten scheint in der baumartigen Struktur des Manifests unter dem Organisationen-Knoten auf. Er ist das Ziel für die nun folgenden Drag-and-Drop-Operationen mit den Ressourcen.

Neu erstellter Organisation-Knoten.

Abbildung 1.15. Neu erstellter Organisation-Knoten.

Um Ressourcen in der Struktur des Manifests zu referenzieren, müssen diese mittels Drag-and-Drop an die jeweilige gewünschte Position gezogen werden, wodurch sogenannte Inhalt-Knoten entstehen. Anders als bei Drag-and-Drop-Operationen, wie man sie von der Dateiverwaltung kennt, wird die Ressource davon nicht beeinflusst. Es wird also nichts verschoben oder kopiert, sondern lediglich ein Verweis in der Struktur des Manifests auf die Ressource angelegt, ähnlich einer Seitenzahl in einem Inhaltsverzeichnis.

Ressource in Manifest einbinden.

Abbildung 1.16. Ressource in Manifest einbinden.

Um eine baumartige Struktur zu erhalten, kann eine Ressource nicht nur auf einen Organisation-Knoten gezogen werden, sondern auch auf schon bestehende Inhalt-Knoten innerhalb der Organisation. Der so neu entstehende Inhalt-Knoten wird in diesem Fall als Kindknoten zu dem schon bestehenden erzeugt.

Ressource als Kindknoten in Manifest einbinden.

Abbildung 1.17. Ressource als Kindknoten in Manifest einbinden.

Ebenso ist es möglich, innerhalb des Manifests Inhalt-Knoten durch Drag-and-Drop zu verschieben bzw. deren Reihenfolge innerhalb einer Hierarchieebene im Baum mit den Schaltflächen Aufwärts und Abwärts zu verändern.

Schaltflächen zum Ändern der Reihenfolge von Inhalt-Knoten.

Abbildung 1.18. Schaltflächen zum Ändern der Reihenfolge von Inhalt-Knoten.

Speichern Sie nun das CPS-Paket nach dem Aufbau des Manifests durch Betätigen der Schaltfläche Speichern.

Speichern des CPS-Pakets.

Abbildung 1.19. Speichern des CPS-Pakets.

Zur Illustration finden Sie im Folgenden eine Animation der zu tätigenden Aktionen.

Abbildung 1.20. Animation: Manifest aufbauen.


1.2.5. Dateivorschau benutzen

Um schnell eine Vorstellung vom Inhalt von Dateien zu gewinnen existiert in jCAPT eine integrierte Dateivorschau. Sie wird durch Betätigen der Schaltfläche Dateivorschau aktiviert.

Abbildung 1.21. Dateivorschau aktivieren.

Klickt man in der Folge in der Ressourcensammlung auf eine Ressource bzw. in der Manifeststruktur auf einen Inhalt-Knoten, welcher auf eine Ressource verweist, so erscheint eine Voransicht der dahinterliegenden Datei.

Dateivorschau für Ressource.

Abbildung 1.22. Dateivorschau für Ressource.

Dateivorschau für Inhalt-Knoten

Abbildung 1.23. Dateivorschau für Inhalt-Knoten

Durch erneutes Betätigen der Schaltfläche Dateivorschau bzw. Schließen des Vorschaufensters wird diese wieder deaktiviert.

Zur Illustration finden Sie im Folgenden eine Animation der zu tätigenden Aktionen.

Abbildung 1.24. Animation: Dateivorschau benutzen.


1.2.6. Paketvorschau benutzen

Um einen Eindruck vom fertigen CPS-Paket zu gewinnen, ohne dieses exportieren zu müssen, existiert in jCAPT eine integrierte Paketvorschau. Sie wird durch Betätigen der Schaltfläche Paketvorschau aktiviert.

Abbildung 1.25. Paketvorschau aktivieren.

Es folgt die interne Generierung der Vorschau, während derer ein Fortschrittsanzeige dargestellt wird. Hier wird die Möglichkeit zum Abbrechen der Erstellung durch Betätigen der Schaltfläche Abbrechen gegeben.

Fortschrittsanzeige beim Erstellen der Paketvorschau.

Abbildung 1.26. Fortschrittsanzeige beim Erstellen der Paketvorschau.

Nach einer erfolgreichen Erstellung öffnet sich das Vorschaufenster. Links finden Sie die Struktur des CPS-Pakets, rechts werden die Inhalte nach Anwählen von Inhalt-Knoten angezeigt. Es gibt außerdem die von Browsern bekannten Schaltflächen Vor, Zurück und Stop.

Vorschau für CPS-Paket.

Abbildung 1.27. Vorschau für CPS-Paket.

Beenden Sie die Vorschau durch Schließen des Vorschaufensters.

Zur Illustration finden Sie im Folgenden eine Animation der zu tätigenden Aktionen.

Abbildung 1.28. Animation: Paketvorschau benutzen.


1.2.7. Metadaten hinzufügen

Metadaten können zu diversen Knoten eines Manifests hinzugefügt werden, u.a. zu folgenden Typen:

  • Manifest-Knoten: die Wurzel; zur Beschreibung des Manifests als Ganzes.

  • Organisation-Knoten: ein Manifest kann mehrere inhaltsgleiche (aber unter Umständen in verschiedenen Sprachen bzw. Formaten vorliegende) Organisationen enthalten. Erst durch eine Auszeichnung mit Metadaten wird eine gegenseitige Abgrenzung ermöglicht.

  • Inhalt-Knoten: zur Beschreibung einzelner inhaltlicher Teile eines CPS-Pakets.

Fügen Sie Metadaten durch einen Rechtsklick auf den den jeweiligen Knoten und Wahl des Menüeintrags Erstelle Knoten 'Metadaten' im sich öffnenden Kontextmenü hinzu.

Metadaten für Manifest/Organisation/Inhalt-Knoten hinzufügen.
Metadaten für Manifest/Organisation/Inhalt-Knoten hinzufügen.
Metadaten für Manifest/Organisation/Inhalt-Knoten hinzufügen.

Abbildung 1.29. Metadaten für Manifest/Organisation/Inhalt-Knoten hinzufügen.

In allen drei Fällen öffnet sich anschließend ein Dialog, in dem das Schema der hinzuzufügenden Metadaten gewählt werden muss. Wählen Sie hier das für das jeweilige Umfeld des CPS-Pakets relevante Schema.

Auswahl des Metadatenschemas.

Abbildung 1.30. Auswahl des Metadatenschemas.

Es öffnet sich ein Dialog, in welchem die Metadaten eingegeben werden können. Dieser Dialog zeigt die zwei Registerkarten Formular-Ansicht und Baum-Ansicht.

Registerkarten im Metadaten-Dialog.

Abbildung 1.31. Registerkarten im Metadaten-Dialog.

Wählen Sie die Formular-Ansicht, um die wichtigsten Metadaten schnell und unkompliziert einzugeben. Im oberen Teil des Dialogs finden Sie die Formularfelder, im unteren wird Hilfetext zum aktuell gewählten Objekt angezeigt. Sie können das aktuelle Objekt über ein Anwählen eines Formularfelds bzw. dessen Beschriftung oder einer (grau hinterlegten) Abschnittsüberschrift bestimmen.

Formular-Ansicht im Metadaten-Dialog.

Abbildung 1.32. Formular-Ansicht im Metadaten-Dialog.

Wählen Sie die Baum-Ansicht, wenn sie mehr Kontrolle oder eine Gesamtsicht über die Metadaten benötigen und direkt mit deren Baumstruktur arbeiten müssen.

Baum-Ansicht im Metadaten-Dialog.

Abbildung 1.33. Baum-Ansicht im Metadaten-Dialog.

In der Formular-Ansicht befindet sich nur ein Feld zur Eingabe eines Schlüsselworts. Um beispielsweise mehrere Schlüsselwörter zu spezifizieren, müssen Sie in der Baum-Ansicht einen 'Schlüsselwort'-Knoten an der richtigen Stelle der Baumstruktur einfügen. Wählen Sie hiezu jenen Knoten, welcher dem einzufügenden Knoten übergeordnet ist (bei 'Schlüsselwort'-Knoten ist dies der 'Allgemeine Metadaten'-Knoten) und öffnen Sie mit einem Rechtsklick das Kontextmenü. Wählen Sie den Typ des zu erstellenden Knotens (in diesem Fall der Menüeintrag Erstelle Knoten 'Schlüsselwort').

[Anmerkung] Anmerkung

Wenn im Kontextmenü zum Erstellen eines Knotens dieser ausgegraut ist und nicht gewählt werden kann, so verbietet der jeweilige Metadaten-Standard, diesen Knoten einzufügen. Dies kann beispielsweise der Fall sein, wenn Sie einen Knoten, welcher nur einmal existieren darf (z.B. Titel), öfters erstellen wollen.

Metadaten-Knoten in der Baum-Ansicht hinzufügen.

Abbildung 1.34. Metadaten-Knoten in der Baum-Ansicht hinzufügen.

Der Knoten wird erzeugt und ausgewählt; Sie können nun seinen Wert in den am linken unteren Bildschirmrand liegenden Eingabefeldern festlegen. Hiezu existieren, abhängig vom Knotentyp, ein Texteingabefeld (einzeilig bzw. mehrzeilig), eine Liste von festgelegten Werten und die Möglichkeit Attribute zu setzen. Es gibt auch Knoten, welche nur zur Strukturierung untergeordneter Knoten dienen und selbst keinen Wert haben. In diesem Fall fehlen diese Eingabemöglichkeiten.

Eingabemöglichkeiten für den Wert von Metadaten-Knoten.
Eingabemöglichkeiten für den Wert von Metadaten-Knoten.
Eingabemöglichkeiten für den Wert von Metadaten-Knoten.

Abbildung 1.35. Eingabemöglichkeiten für den Wert von Metadaten-Knoten.

Beenden Sie das Bearbeiten der Metadaten durch Betätigen der Schaltfläche OK am rechten unteren Rand des Dialogs.

Speichern der Metadaten.

Abbildung 1.36. Speichern der Metadaten.

Der Dialog zum Bearbeiten der Metadaten wird geschlossen und Sie sehen im Manifest den erzeugten Metadaten-Knoten.

Metadaten-Knoten in der Manifeststruktur.

Abbildung 1.37. Metadaten-Knoten in der Manifeststruktur.

Speichern Sie das CPS-Paket durch Betätigen der Schaltfläche Speichern.

[Wichtig] Wichtig

Beim Hinzufügen von Metadaten wird im Basisordner die Schemadefinition des gewählten Metadaten-Schemas hinzugefügt. Diese befindet sich in Dateien mit der Endung .xsd. Es kann auch passieren, dass (mehrere) Ordner mit Teilen dieser Schemadefinition erzeugt werden. Diese Dateien dürfen nicht gelöscht werden, da sie anderen Systemen zur Überprüfung der Metadaten dienen. Sollte ein/e derartige/r Datei/Ordner einmal irrtümlicherweise gelöscht werden, so wird er/sie beim nächsten Speichern des CPS-Pakets wiederhergestellt.

Zur Illustration finden Sie im Folgenden eine Animation der zu tätigenden Aktionen.

Abbildung 1.38. Animation: Metadaten hinzufügen.


1.2.8. CPS-Paket als ZIP-Archiv exportieren

Um das CPS-Paket in ein Learning Management System (LMS) hochzuladen, muss es zuerst in ein Package Interchange File gepackt werden. jCAPT unterstützt zu diesem Zweck das Packen des Pakets in ein ZIP-Archiv. Starten Sie diesen Vorgang durch Betätigen der Schaltfläche Zippen.

CPS-Paket als ZIP-Archiv exportieren.

Abbildung 1.39. CPS-Paket als ZIP-Archiv exportieren.

Es öffnet sich ein Dialog, in welchem Sie den Pfad und Dateinamen des zu erstellenden ZIP-Archivs festlegen können. Wählen Sie den Zielpfad, vergeben Sie einen Dateinamen und betätigen Sie anschließend die Schaltfläche Speichern.

Name und Pfad des zu erstellenden ZIP-Archivs festlegen.

Abbildung 1.40. Name und Pfad des zu erstellenden ZIP-Archivs festlegen.

Es erscheint eine Anzeige, welche den Fortgang des Exportiervorgangs anzeigt und die Möglichkeit gibt, diesen abzubrechen.

Fortschrittsanzeige beim Erstellen des ZIP-Archivs.

Abbildung 1.41. Fortschrittsanzeige beim Erstellen des ZIP-Archivs.

Eine abschließende Meldung informiert über das erfolgreiche Abschließen des Exportiervorgangs.

Exportieren als ZIP-Archiv erfolgreich abgeschlossen.

Abbildung 1.42. Exportieren als ZIP-Archiv erfolgreich abgeschlossen.

Zur Illustration finden Sie im Folgenden eine Animation der zu tätigenden Aktionen.

Abbildung 1.43. Animation: CPS-Paket als ZIP-Archiv exportieren.


1.2.9. CPS-Paket als Offline-Version exportieren

Damit das CPS-Paket ohne spezielle Software nur mit einem Browser betrachtet werden kann, muss es als Offline-Version exportiert werden. Diese eignet sich besonders zum Erstellen von Lern-CDs. Klicken Sie hierzu auf die Schaltfläche CPS Paket exportieren.

CPS-Paket als Offline-Version exportieren.

Abbildung 1.44. CPS-Paket als Offline-Version exportieren.

Es öffnet sich ein Dialog, in welchem Sie eine Vielzahl von Einstellungen tätigen können. Wichtig sind hier vor allem der Titel (dieser wird später oberhalb des Inhalts angezeigt) und der Ausgabeordner. Wenn mehrere Organisationen in einem Manifest vorhanden sind, müssen Sie auch sicherstellen, dass die richtige zum Export ausgewählt ist. Ansonsten wird die im Manifest festgelegte Standard-Organisation exportiert.

Einstellungen für Export als Offline-Version vornehmen.

Abbildung 1.45. Einstellungen für Export als Offline-Version vornehmen.

Klicken Sie auf die Schaltfläche Exportieren..., um den Exportvorgang zu starten. Es erscheint ein Fenster, welches Statusmeldungen zum Export anzeigt, und bei Paketen mit vielen bzw. großen Ressourcen informiert eine Fortschrittsanzeige über den Verlauf des Kopierens der Ressourcen in den Ausgabeordner.

Statusmeldungen beim Export als Offline-Version.

Abbildung 1.46. Statusmeldungen beim Export als Offline-Version.

Klicken Sie auf die Schaltfläche Schließen, um das Fenster mit den Statusmeldungen zu schließen. Sie gelangen zurück zu jenem Dialog, in dem Sie die Export-Einstellungen vorgenommen haben. Die Schaltfläche Letztes Ergebnis anzeigen ist nun nicht mehr deaktiviert. Betätigen Sie sie, wenn Sie das Ergebnis des Exportvorgang betrachten wollen; dieses wird in ihrem standardmäßig im System eingestellten Browser geöffnet.

Ergebnis des Exports als Offline-Version betrachten.

Abbildung 1.47. Ergebnis des Exports als Offline-Version betrachten.

Zur Illustration finden Sie im Folgenden eine Animation der zu tätigenden Aktionen.

Abbildung 1.48. Animation: CPS-Paket als Offline-Version exportieren.


Kapitel 2. Bedienung

Inhaltsverzeichnis

2.1. Allgemeine Aktionen
2.2. CPS-Paket-Operationen
2.3. Material-Organisation
2.4. Lernpaket aufbauen und bearbeiten
2.5. Dateivorschau
2.6. Paketvorschau
2.7. Metadatenerstellung und -bearbeitung
2.8. Lernpaketexport

Dieses Kapitel enthält eine aufgabenorientierte Bedienanleitung. Sie dient der schrittweisen Einführung und Erklärung typischer Aufgaben mit Anwendungsbeispielen. Angereichert mit Bildschirmschnappschüssen und Animationen konkreten Bedienung ist sie zum schrittweisen Einstieg in die Bedienung von jCAPT gedacht.


2.1. Allgemeine Aktionen

2.1.1. jCAPT starten
2.1.2. Nächsten Tip des Tages anzeigen
2.1.3. Benutzerhilfe anzeigen
2.1.4. Programminformationen anzeigen
2.1.5. Statusfenster anzeigen/bedienen/schließen
2.1.6. Programmeinstellungen ändern
2.1.7. jCAPT beenden

In diesem Kapitel werden grundlegende Benutzeraktionen beschrieben. Hierbei handelt es sich um allgemeine Programmaktionen, Hilfe- und Informationsbeschaffung und Konfiguration von jCAPT.


2.1.1. jCAPT starten

Starten Sie jCAPT durch Auswahl des Menüeintrags jCAPT in der Programmgruppe jCAPT im Startmenü.

Start von jCAPT über das Startmenü.

Abbildung 2.1. Start von jCAPT über das Startmenü.

Nach dem Start von jCAPT sehen Sie das Hauptfenster mit dem Schnellstartbereich in der Mitte.

Hauptfenster nach dem Start.

Abbildung 2.2. Hauptfenster nach dem Start.

Zur Illustration finden Sie im Folgenden eine Animation der zu tätigenden Aktionen.

Abbildung 2.3. Animation: Starten von jCAPT.


2.1.2. Nächsten Tip des Tages anzeigen

Im Schnellstartbereich befindet sich ein Bereich, in dem der Tip des Tages angezeigt wird.

Tip des Tages

Abbildung 2.4. Tip des Tages

In der rechten oberen Ecke dieses Bereichs liegt eine Schaltfläche mit einem Pfeil nach Rechts als Symbol. Betätigen Sie sie, um den nächsten Tip des Tages anzuzeigen.

Schaltfläche zum Anzeigen des nächsten Tip des Tages.

Abbildung 2.5. Schaltfläche zum Anzeigen des nächsten Tip des Tages.

Zur Illustration finden Sie im Folgenden eine Animation der zu tätigenden Aktionen.

Abbildung 2.6. Animation: Nächsten Tip des Tages anzeigen.


2.1.3. Benutzerhilfe anzeigen

jCAPT verfügt über eine umfangreiche Benutzerhilfe. Sie können diese auf dreierlei Arten anzeigen:

  • Wahl der Schaltfläche Benutzerhilfe anzeigen im Schnellstartbereich

    Benutzerhilfe anzeigen über den Schnellstartbereich.

    Abbildung 2.7. Benutzerhilfe anzeigen über den Schnellstartbereich.

  • Öffnen des Menüs Hilfe und Wahl des Menüeintrags Benutzerhilfe

    Benutzerhilfe anzeigen über das Menü.

    Abbildung 2.8. Benutzerhilfe anzeigen über das Menü.

  • Betätigen der Funktionstaste F1

In allen drei Fällen wird die Benutzerhilfe im Standard-Browser (z.B. Internet Explorer, Firefox, Mozilla, Opera, ...) geöffnet.


2.1.4. Programminformationen anzeigen

Wie in den meisten Programmen gibt es auch in jCAPT die Möglichkeit, gewisse Programminformationen anzuzeigen. Öffnen Sie das Menü Hilfe und wählen Sie den Menüeintrag Über jCAPT....

Abbildung 2.9. Programminformationen anzeigen.

Es öffnet sich ein Dialog mit den folgende Informationen:

  • Version von jCAPT mit dem Datum des Erstellung

  • Copyright und andere rechtliche Informationen

  • Webseite mit Produktinformationen und Downloads

  • Kontaktadresse (E-Mail)

Dialog mit Programminformationen.

Abbildung 2.10. Dialog mit Programminformationen.

Ein Betätigen des Links zur Webseite öffnet diesen im Standard-Browser (z.B. Internet Explorer, Firefox, Mozilla, Opera, ...). Wenn Sie den Link mit der Kontaktadresse betätigen, öffnet sich der Dialog zum Verfassen von E-Mails des Standard-Email-Programms (z.B. Outlook (Express), Thunderbird, Eudora, ...). In diesem ist schon die Kontaktadresse als Empfänger bzw. ein Teil des Betreffs eingetragen. Sie müssen lediglich den Betreff ergänzen, die Nachricht schreiben und abschicken.

Sie können den Dialog mit Programminformationen durch Betätigen der Schaltfläche Schließen bzw. der Standard-Schaltfläche zum Schließen (Kreuz-Symbol am rechten oberen Rand des Dialogs) schließen.

Zur Illustration finden Sie im Folgenden eine Animation der zu tätigenden Aktionen.

Abbildung 2.11. Animation: Programminformationen anzeigen.


2.1.5. Statusfenster anzeigen/bedienen/schließen

Viele Teile von jCAPT geben detaillierte Meldungen (z.B. bearbeitete Dateien, Fehlermeldungen, ...) im Statusfenster aus. Dieses ist standardmäßig nach dem Start von jCAPT nicht sichtbar und kann durch Öffnen des Menüs Ansicht und Wahl des Menüeintrags Statusfenster angezeigt werden.

Abbildung 2.12. Statusfenster anzeigen.

Das Statusfenster öffnet sich und enthält mindestens folgende beim Start von jCAPT ausgegebene Informationen:

  • Version von jCAPT mit dem Datum der Erstellung

  • Startdatum und -uhrzeit

  • Speicherort des Benutzerprofils (dies ist gleichzeitig der Speicherort der Konfigurationsdatei von jCAPT)

  • Benutzername des angemeldeten Benutzers

  • Ordner, in dem jCAPT gestartet wurde (dies ist meist der Installationsordner)

Statusfenster mit Startmeldungen.

Abbildung 2.13. Statusfenster mit Startmeldungen.

Darüber hinaus können noch weitere Meldungen von Teilen von jCAPT im Statusfenster aufscheinen. Sie können die Meldungen im Statusfenster über das Menü Meldungen durch Wahl des Menüeintrags Löschen entfernen. Wählen Sie den Menüeintrag In Datei speichern... um sie beispielsweise für eine spätere Fehleranalyse zu speichern.

Operationen im Statusfenster.

Abbildung 2.14. Operationen im Statusfenster.

Sie können das Statusfenster durch Wahl des Menüeintrags Schließen bzw. Betätigen der Standard-Schaltfläche zum Schließen (Kreuz-Symbol am rechten oberen Rand des Fensters) schließen.

[Tipp] Tipp

Das Statusfenster kann immer geöffnet bleiben um beispielsweise bei Benutzeraktionen in jCAPT sofort etwaige Meldungen zu sehen. Dies macht es leichter, Fehlermeldungen einer bestimmten Aktion zuzuordnen.

Zur Illustration finden Sie im Folgenden eine Animation der zu tätigenden Aktionen bei einer beispielhaften Benützung des Statusfensters.

Abbildung 2.15. Animation: Statusfenster anzeigen/bedienen/schließen.


2.1.6. Programmeinstellungen ändern

jCAPT kann in vielen Belangen über die Programmeinstellungen an die Vorlieben des Benutzers angepasst werden. Der Konfigurationsdialog lässt sich auf zwei Arten aufrufen:

  • Wahl der Schaltfläche Programmeinstellungen ändern im Schnellstartbereich

    Programmeinstellungen ändern über den Schnellstartbereich.

    Abbildung 2.16. Programmeinstellungen ändern über den Schnellstartbereich.

  • Öffnen des Menüs Extras und Wahl des Menüeintrags Einstellungen...

    Benutzerhilfe anzeigen über das Menü.

    Abbildung 2.17. Benutzerhilfe anzeigen über das Menü.

In beiden Fällen öffnet sich der Konfigurationsdialog. Es wird hier nicht näher auf die einzelnen Möglichkeiten zur Konfiguration von jCAPT eingegangen. Für eine genaue Beschreibung siehe Kapitel 1, Programmkonfiguration.

Konfigurationsdialog für die Programmeinstellungen.

Abbildung 2.18. Konfigurationsdialog für die Programmeinstellungen.

Durch Betätigen der Schaltfläche OK wird der Dialog geschlossen und die Änderungen werden übernommen. Die Schaltfläche Abbrechen sowie die Standard-Schaltfläche zum Schließen (Kreuz-Symbol am rechten oberen Rand des Dialogs) bewirken ebenfalls ein Schließen, jedoch werden die Änderungen verworfen.


2.1.7. jCAPT beenden

jCAPT kann auf zwei Arten beendet werden:

  • Betätigen der Standard-Schaltfläche zum Schließen (Kreuz-Symbol am rechten oberen Rand des Fensters)

    Beenden von jCAPT über die Standard-Schaltfläche zum Schließen.

    Abbildung 2.19. Beenden von jCAPT über die Standard-Schaltfläche zum Schließen.

  • Öffnen des Menüs Datei und Wahl des Menüeintrags Beenden

    Beenden von jCAPT über das Menü.

    Abbildung 2.20. Beenden von jCAPT über das Menü.

In beiden Fällen wird jCAPT beendet. Sind noch ein oder mehrere CPS-Pakets geöffnet, die verändert und noch nicht gespeichert wurden, so wird für jedes ein Dialog mit einer entsprechenden Frage angezeigt.

Ungespeicherte Änderungen speichern.

Abbildung 2.21. Ungespeicherte Änderungen speichern.

Betätigen der Schaltfläche Ja speichert das CPS-Paket und fährt mit dem Beenden fort. Wird die Schaltfläche Nein betätigt, so wird das CPS-Paket nicht gespeichert, das Beenden aber trotzdem fortgesetzt. Mit der Schaltfläche Abbrechen können Sie das Beenden abbrechen.


2.2. CPS-Paket-Operationen

2.2.1. Neues CPS-Paket erstellen
2.2.2. Vorhandenes CPS-Paket öffnen
2.2.3. Kürzlich bearbeitetes CPS-Paket öffnen
2.2.4. Zwischen geöffneten CPS-Paketen wechseln
2.2.5. CPS-Paket speichern
2.2.6. CPS-Paket schließen

Dieses Kapitel behandelt die allgemeine Operationen auf CPS-Pakete in jCAPT. Es werden Aktionen auf hoher Ebene wie Erstellen, Öffnen, Speichern und Schließen von CPS-Paketen beschrieben.


2.2.1. Neues CPS-Paket erstellen

Um in jCAPT ein neues CPS-Paket erstellen müssen Sie folgende Aktionen ausführen:

  1. Starten Sie den Vorgang zum Erstellen eines neuen CPS-Pakets. Dies kann auf viererlei Arten geschehen:

    • Betätigen der Schaltfläche Neues CPS-Paket erstellen im Schnellstartbereich

      Neues CPS-Paket erstellen über den Schnellstartbereich.

      Abbildung 2.22. Neues CPS-Paket erstellen über den Schnellstartbereich.

    • Wahl der Schaltfläche Neu in der Symbolleiste

      Neues CPS-Paket erstellen über die Symbolleiste.

      Abbildung 2.23. Neues CPS-Paket erstellen über die Symbolleiste.

    • Öffnen des Menüs Datei und Wahl des Menüeintrags Neu

      Neues CPS-Paket erstellen über das Menü.

      Abbildung 2.24. Neues CPS-Paket erstellen über das Menü.

    • Betätigen der Tastenkombination Strg-N

    In allen vier Fällen öffnet sich ein Ordnerwahl-Dialog, mit welchem der Basisordner des CPS-Pakets zu wählen ist. Dieser Basisordner wird die gesamten Ressourcen und das Manifest des CPS-Pakets enthalten. Über die Schaltfläche Abbrechen können Sie den Vorgang zum Erstellen eines neuen CPS-Pakets jederzeit abbrechen.

    Basisordner für neues CPS-Paket wählen.

    Abbildung 2.25. Basisordner für neues CPS-Paket wählen.

  2. Wählen Sie den gewünschten Basisordner mit einem Mausklick. Sie können einen existierenden Ordner (eventuell mit schon vorhandenen Dateien) wählen, oder einen neuen erstellen und diesen wählen.

  3. Betätigen Sie die Schaltfläche Auswählen um das Manifest im gewählten Basisordner anzulegen.

Das Manifest wird im gewählten Basisordner angelegt und es öffnet sich die Arbeitsfläche zum Bearbeiten der Ressourcen und des Manifests in dem CPS-Paket.

Arbeitsfläche zum Bearbeiten der Ressourcen und des Manifests.

Abbildung 2.26. Arbeitsfläche zum Bearbeiten der Ressourcen und des Manifests.

Auf der linken Seite der Arbeitsfläche befindet sich die Ressourcensammlung, auf der rechten die Manifestansicht. Unterhalb der Manifestansicht können Attribute einzelner Element des Manifests mit Werten versehen werden. Eine kontextsensitive Hilfe zum aktuell gewählten Element des Manifests findet sich im rechten unteren Bildschirmteil.

Zur Illustration finden Sie im Folgenden eine Animation der zu tätigenden Aktionen.

Abbildung 2.27. Animation: Neues CPS-Paket erstellen.


2.2.2. Vorhandenes CPS-Paket öffnen

Um ein vorhandenes CPS-Paket in jCAPT zu öffnen müssen Sie folgende Aktionen ausführen:

  1. Öffnen Sie den Dialog zum Wählen des zu öffnenden CPS-Pakets. Sie können dies auf vier Arten erledigen:

    • Betätigen der Schaltfläche Vorhandenes CPS-Paket öffnen im Schnellstartbereich

      Vorhandenes CPS-Paket öffnen über den Schnellstartbereich.

      Abbildung 2.28. Vorhandenes CPS-Paket öffnen über den Schnellstartbereich.

    • Wahl der Schaltfläche Öffnen in der Symbolleiste

      Vorhandenes CPS-Paket öffnen über die Symbolleiste.

      Abbildung 2.29. Vorhandenes CPS-Paket öffnen über die Symbolleiste.

    • Öffnen des Menüs Datei und Wahl des Menüeintrags Öffnen

      Vorhandenes CPS-Paket öffnen über das Menü.

      Abbildung 2.30. Vorhandenes CPS-Paket öffnen über das Menü.

    • Betätigen der Tastenkombination Strg-O

    In allen vier Fällen öffnet sich ein Dateiwahl-Dialog zum Wählen des zu öffnenden CPS-Pakets. Betätigen der Schaltfläche Abbrechen bricht den Vorgang zum Öffnen eines vorhandenen CPS-Pakets ab.

    Wahl des vorhandenen CPS-Pakets zum Öffnen.

    Abbildung 2.31. Wahl des vorhandenen CPS-Pakets zum Öffnen.

  2. Wählen Sie das zu öffnende CPS-Paket. Dieses kann über zwei verschiedene Dateien gewählt werden:

    • Manifest-Datei imsmanifest.xml im Basisordner des CPS-Pakets

    • ZIP-Archiv eines gezippten CPS-Pakets

    Wählen Sie die jeweilige Datei mit einem Mausklick auf deren Namen bzw. Symbol.

  3. Betätigen Sie die Schaltfläche Öffnen.

    Wenn Sie ein gezipptes CPS-Paket gewählt haben, öffnet sich ein weiterer Ordnerwahl-Dialog zum Festlegen des Ordners, in dem der Inhalt des gezippten CPS-Pakets entpackt werden soll. Betätigen der Schaltfläche Abbrechen bricht den Vorgang zum Öffnen eines vorhandenen CPS-Pakets ab.

    Ordner zum Entpacken des gezippten CPS-Pakets.

    Abbildung 2.32. Ordner zum Entpacken des gezippten CPS-Pakets.

    1. Wählen Sie den Ordner, in den das gezippte CPS-Paket entpackt wird durch einen Mausklick auf dessen Namen bzw. Symbol.

    2. Starten Sie den Entpack-Vorgang durch Betätigen der Schaltfläche Wählen.

Sowohl beim Öffnen des CPS-Pakets über die Manifest-Datei als auch beim Öffnen eines gezippten CPS-Pakets wird dieses nun geöffnet.

Vorhandenes CPS-Paket geöffnet.

Abbildung 2.33. Vorhandenes CPS-Paket geöffnet.

In der Leiste unterhalb der Symbolleiste wird zur Orientierung der Pfad des Basisordners des geöffneten CPS-Pakets angezeigt.

Pfad des Basisordners des geöffneten CPS-Pakets.

Abbildung 2.34. Pfad des Basisordners des geöffneten CPS-Pakets.

Zur Illustration finden Sie im Folgenden eine Animation der zu tätigenden Aktionen.

Abbildung 2.35. Animation: Vorhandenes CPS-Paket öffnen.


2.2.3. Kürzlich bearbeitetes CPS-Paket öffnen

Oft besteht der Wunsch ein kürzlich bearbeitetes CPS-Paket erneut zu öffnen. In jCAPT gibt es zwei Möglichkeiten, die letzten vier bearbeiteten CPS-Pakete zu öffnen:

  • Wahl der gewünschten Datei (Manifest bzw. ZIP-Archiv) im Schnellstartbereich

    Kürzlich bearbeitetes CPS-Paket öffnen über den Schnellstartbereich.

    Abbildung 2.36. Kürzlich bearbeitetes CPS-Paket öffnen über den Schnellstartbereich.

  • Öffnen des Menüs Datei und Wahl des Menüeintrags der gewünschten Datei im Untermenü Letzte Dateien

    Kürzlich bearbeitetes CPS-Paket öffnen über das Menü.

    Abbildung 2.37. Kürzlich bearbeitetes CPS-Paket öffnen über das Menü.

In beiden Fällen wird das zur jeweiligen Datei gehörige CPS-Paket geöffnet, sofern diese noch existiert und lesbar ist.

Zur Illustration finden Sie im Folgenden eine Animation der zu tätigenden Aktionen.

Abbildung 2.38. Animation: Kürzlich bearbeitetes CPS-Paket öffnen.


2.2.4. Zwischen geöffneten CPS-Paketen wechseln

In jCAPT ist es möglich, mehrere CPS-Pakete gleichzeitig geöffnet zu haben. Um zwischen diesen zu wechseln gibt es eine entsprechende Auflistung der geöffneten CPS-Pakete im Menü Dokumente.

Liste der geöffneten CPS-Pakete.

Abbildung 2.39. Liste der geöffneten CPS-Pakete.

Durch Wahl eines Menüeintrags wird der Arbeitsbereich mit dem entsprechenden CPS-Paket in den Vordergrund geholt.

Zur Illustration finden Sie im Folgenden eine Animation der zu tätigenden Aktionen.

Abbildung 2.40. Animation: Zwischen geöffneten CPS-Paketen wechseln.


2.2.5. CPS-Paket speichern

Ein geöffnetes CPS-Paket kann man in jCAPT auf dreierlei Arten speichern:

  • Wahl der Schaltfläche Speichern in der Symbolleiste

    CPS-Paket speichern über die Symbolleiste.

    Abbildung 2.41. CPS-Paket speichern über die Symbolleiste.

  • Öffnen des Menüs Datei und Wahl des Menüeintrags Speichern

    CPS-Paket speichern über das Menü.

    Abbildung 2.42. CPS-Paket speichern über das Menü.

  • Betätigen der Tastenkombination Strg-S

In allen drei Fällen wird das CPS-Paket (im Konkreten das Manifest imsmanifest.xml) gespeichert. Man erkennt das auch an der "Verändert-Anzeige" am oberen Rand des Arbeitsbereichs.

Abbildung 2.43. Verändert-Anzeige

Neben dem Pfad zum Basisordner des gerade aktiven, geöffneten CPS-Pakets wird, wenn Änderungen noch nicht gespeichert wurden, der Text (verändert) angezeigt. Dieser verschwindet, sobald das CPS-Paket gespeichert wurde und erscheint bei neuerlicher Änderung.

[Tipp] Tipp

Speichern Sie regelmäßig Ihre Arbeit. So kann bei plötzlich auftretenden Ereignissen (Stromausfall, Defekt, ...) die Gefahr eines Datenverlusts minimiert werden. Die Möglichkeit Aktionen rückgängig zu machen (siehe Abschnitt 2.4.1.1, „Aktion(en) rückgängig machen“) wird übrigens durch das Speichern nicht beeinflusst.

Zur Illustration finden Sie im Folgenden eine Animation der zu tätigenden Aktionen.

Abbildung 2.44. Animation: CPS-Paket speichern.


2.2.6. CPS-Paket schließen

Zum Schließen des aktiven, geöffneten CPS-Pakets befindet sich im rechten oberen Eck des Arbeitsbereichs eine Schaltfläche mit einem Kreuz-Symbol.

Schaltfläche zum Schließen eines CPS-Pakets.

Abbildung 2.45. Schaltfläche zum Schließen eines CPS-Pakets.

Bei Betätigen der Schaltlfäche wird das aktive CPS-Paket geschlossen. Wurden an diesem Änderungen vorgenommen, welche noch nicht gespeichert sind, so erscheint ein Dialog mit mehreren Auswahlalternativen.

Speichern ungespeicherter Änderungen.

Abbildung 2.46. Speichern ungespeicherter Änderungen.

Wählen der Schaltfläche Ja speichert die Änderungen und schließt das CPS-Paket. Ein Betätigen der Schaltfläche Nein verwirft die Änderungen und schließt das CPS-Paket ebenfalls. Wählt man die Schaltfläche Abbrechen, wird der Schließ-Vorgang abgebrochen.

Zur Illustration finden Sie im Folgenden eine Animation der zu tätigenden Aktionen.

Abbildung 2.47. Animation: CPS-Paket schließen.


2.3. Material-Organisation

2.3.1. Dateien/Ordner als Ressourcen importieren
2.3.2. Abhängigkeiten beim Importieren berücksichtigen
2.3.3. Neuen Ordner in der Ressourcensammlung erstellen
2.3.4. Ressourcen löschen
2.3.5. Ansicht in der Ressourcensammlung aktualisieren
2.3.6. Ressourcen verschieben
2.3.7. Ressourcen kopieren

In diesem Teil der Bedienungsanleitung wird beschrieben, wie man die Ressourcen für ein CPS-Paket organisiert und auf dem Datenträger physisch strukturiert. Hierbei ist zu beachten, dass jCAPT nicht als Ersatz für einen vollwertigen Dateimanager gedacht ist. Für weitergehende Operationen mit den Ressourcen muss unter Umständen auf einen solchen zurückgegriffen werden. Für die Material-Organisation wird vorausgesetzt, dass ein CPS-Paket geöffnet ist.


2.3.1. Dateien/Ordner als Ressourcen importieren

Für den Fall, dass die Ressourcen nicht schon im Basisordner des CPS-Pakets vorhanden sind oder mit einem externen Programm dorthin gespeichert werden, gibt es zwei Möglichkeiten, Dateien bzw. Ordner als Ressourcen in jCAPT zu importieren:

  • Über den Import-Dialog (siehe Abschnitt 2.3.1.1, „Dateien/Ordner über den Import-Dialog importieren“)

  • Mittels Drag-and-Drop aus einer anderen Anwendung (siehe Abschnitt 2.3.1.2, „Dateien/Ordner mittels Drag-and-Drop importieren“)

[Tipp] Tipp

Die Methode mittels Import-Dialog eignet sich für kleine Mengen von Dateien/Ordern bzw. wenn abhängige Dateien ebenfalls importiert werden sollen (siehe Abschnitt 2.3.2, „Abhängigkeiten beim Importieren berücksichtigen“). Mit Drag-and-Drop lassen sich größere Mengen von Dateien/Ordnern schneller und bequemer beispielsweise aus dem Explorer von Microsoft Windows™ importieren.

In beiden Fällen wird der Verlauf des Importvorgangs wird über eine Fortschrittsanzeige visualisiert. Es wird der Name der gerade bearbeiteten Datei angezeigt und die Möglichkeit zum Abbrechen des Import durch Betätigen der Schaltfläche Abbrechen gegeben.

Fortschrittsanzeige beim Importieren.

Abbildung 2.48. Fortschrittsanzeige beim Importieren.

Wenn beim Import eine namensgleiche Ressource schon vorhanden ist, so wird gefragt, ob diese überschrieben werden soll.

Vorhandene Ressource(n) beim Import überschreiben.

Abbildung 2.49. Vorhandene Ressource(n) beim Import überschreiben.

Betätigen der Schaltfläche Ja überschreibt diese eine Datei. Bei der Wahl von Ja, alle wird bei diesem Import bei allen Namensgleichheiten die schon vorhandene Ressource überschrieben. Ein Wählen von Nein überschreibt diese eine Datei nicht. In allen drei Fällen wird anschließend der Import fortgesetzt. Bei Betätigen der Schaltfläche Abbrechen hingegen wird die Datei nicht überschrieben und der gesamte Import abgebrochen. Alle bis dahin importierten Dateien bleiben jedoch erhalten.

Wenn der Import abgeschlossen ist, finden sich die importierten Ressourcen im linken Teil des Arbeitsbereichs bei der Ressourcensammlung.

Importierte Ressourcen in der Ressourcensammlung.

Abbildung 2.50. Importierte Ressourcen in der Ressourcensammlung.


2.3.1.1. Dateien/Ordner über den Import-Dialog importieren

Um mittels des Import-Dialogs Dateien und Ordner als Ressourcen zu importieren müssen Sie folgende Aktionen ausführen:

  1. Wählen Sie in der Ressourcensammlung den Ordner, in den die Ressourcen importiert werden sollen, durch einen Mausklick auf dessen Namen bzw. Symbol. Sie können auch eine Datei wählen; in diesem Fall wird in den Ordner, in welchem die Datei liegt, importiert.

  2. Rufen Sie den Import-Dialog auf, um die zu importierenden Dateien/Ordner auszuwählen. Dieser kann auf zweierlei Arten geschehen:

    • Betätigen der Schaltfläche Import in der Symbolleiste der Ressourcensammlung

      Import-Dialog aufrufen über die Symbolleiste der Ressourcensammlung.

      Abbildung 2.51. Import-Dialog aufrufen über die Symbolleiste der Ressourcensammlung.

    • Öffnen des Menüs Datei und Wahl des Menüeintrags Ressourcen importieren...

      Import-Dialog aufrufen über das Menü.

      Abbildung 2.52. Import-Dialog aufrufen über das Menü.

    In beiden Fällen öffnet sich der Import-Dialog. Es handelt sich um einen Datei- und Ordnerwahl-Dialog, der Mehrfachauswahl erlaubt.

    Import-Dialog mit Auswahl von zu importierenden Ressourcen.

    Abbildung 2.53. Import-Dialog mit Auswahl von zu importierenden Ressourcen.

  3. Wählen Sie mit der Maus bzw. der Tastatur die zu importierende Dateien und Ordner. Durch Halten der Hochstelltaste und gleichzeitiges Wählen können Sie eine zusammenhängende Auswahl treffen. Mit der Strg-Taste können auch nicht-zusammenhängende Teile der Datei-/Ordnerliste selektiert werden.

  4. Starten Sie den Import durch Betätigen der Schaltfläche Importieren. Betätigen der Schaltfläche Abbrechen schließt den Dialog ohne Ressourcen zu importieren.

Zur Illustration finden Sie im Folgenden eine Animation der zu tätigenden Aktionen.

Abbildung 2.54. Animation: Dateien/Ordner über den Import-Dialog importieren.


2.3.1.2. Dateien/Ordner mittels Drag-and-Drop importieren

Um mittels des Import-Dialogs Dateien und Ordner als Ressourcen zu importieren müssen Sie folgende Aktionen ausführen:

  1. Starten Sie die Quellanwendung (z.B. Explorer von Microsoft Windows™), von welcher aus die Dateien/Ordner mittels Drag-and-Drop importiert werden sollen.

  2. Wählen Sie in der Quellanwendung die zu importierenden Dateien/Ordner aus.

  3. Ziehen Sie die Auswahl mit gedrückter linker Maustaste in die Ressourcensammlung. Solange die Maustaste gedrückt bleibt, wird jeweils der Ordner markiert, in welchen beim Loslassen der Maustaste die Dateien/Ordner importiert würden. Befindet sich der Mauszeiger hierbei über einem Ordner-Knoten, so wird dieser gewählt, bei einem Datei-Knoten jener Ordner, in welchem sich diese Datei befindet.

  4. Lassen Sie die Maustaste los, wenn der gewünschte Zielordner markiert ist. Der Import wird dann gestartet.

[Tipp] Tipp

Wenn Sie bei noch gedrückter Maustaste die Taste Esc betätigen, wird der Drag-and-Drop-Vorgang abgebrochen.

Dateien/Ordner mittels Drag-and-Drop importieren.

Abbildung 2.55. Dateien/Ordner mittels Drag-and-Drop importieren.

[Anmerkung] Anmerkung

Beim Import mittels Drag-and-Drop werden keine abhängigen Dateien importiert. Wenn diese berücksichtigt werden sollen, müssen Sie den Import-Dialog verwenden. Näheres siehe Abschnitt 2.3.2, „Abhängigkeiten beim Importieren berücksichtigen“.

Zur Illustration finden Sie im Folgenden eine Animation der zu tätigenden Aktionen.

Abbildung 2.56. Animation: Dateien/Ordner mittels Drag-and-Drop importieren.


2.3.2. Abhängigkeiten beim Importieren berücksichtigen

Etliche Dateitypen sehen vor, dass Teile des angezeigten Inhalts einer Datei nicht in ihr selbst sondern in einer oder mehreren externen Dateien gespeichert sind. Bekanntestes Beispiel ist hierbei wohl die getrennte Speicherung einer HTML-Datei und der Bilder, die sie verwendet. Damit diese Abhängigkeiten einer Datei beim Import in jCAPT nicht manuell ebenfalls importiert werden müssen, können diese automatisch mitimportiert werden. Für eine Beschreibung, für welche Dateitypen und wie die Bestimmung der Abhängigkeiten von Ressourcen genau funtioniert siehe Kapitel 3, Bestimmung der Abhängigkeiten von Ressourcen.

Um die Abhängigkeiten beim Importieren zu berücksichtigen müssen Sie den Import wie in Abschnitt 2.3.1.1, „Dateien/Ordner über den Import-Dialog importieren“ beschrieben durchführen. Als einzige Änderung müssen Sie im Import-Dialog bei der Frage, ob abhängige Dateien ebenfalls importiert werden sollen, durch einen Klick die Auswahl auf Ja ändern.

Abhängigkeiten beim Importieren berücksichtigen.

Abbildung 2.57. Abhängigkeiten beim Importieren berücksichtigen.

Zur Illustration finden Sie im Folgenden eine Animation der zu tätigenden Aktionen.

Abbildung 2.58. Animation: Abhängigkeiten beim Importieren berücksichtigen.


2.3.3. Neuen Ordner in der Ressourcensammlung erstellen

Um das Material für das Lernpaket strukturieren zu können, ist es notwendig, dieses in Ordnern zu organisieren. In jCAPT ist es möglich, über die Ressourcensammlung neue Ordner erstellen. Sie müssen dazu folgende Aktionen durchführen:

  1. Wählen Sie in der Ressourcensammlung den Ordner, in dem der neue Ordner erstellt werden soll, durch einen Mausklick auf dessen Namen bzw. Symbol. Sie können auch eine Datei wählen; in diesem Fall wird der neue Ordner in dem Ordner, in welchem die Datei liegt, erstellt.

  2. Starten Sie die Operation zum Erstellen eines neuen Ordners. Dies kann auf zweierlei Arten geschehen:

    • Betätigen der Schaltfläche Neuer Ordner in der Symbolleiste der Ressourcensammlung

      Neuen Ordner in der Ressourcensammlung erstellen über die Symbolleiste.

      Abbildung 2.59. Neuen Ordner in der Ressourcensammlung erstellen über die Symbolleiste.

    • Öffnen des Kontextmenüs durch einen Klick mit der rechten Maustaste und Wahl des Menüeintrags Neuer Ordner...

      Neuen Ordner in der Ressourcensammlung erstellen über das Kontextmenü.

      Abbildung 2.60. Neuen Ordner in der Ressourcensammlung erstellen über das Kontextmenü.

    In beiden Fällen öffnet sich ein Dialog, in dem Sie den Namen des neuen Ordners angeben müssen. Betätigen der Schaltfläche Abbrechen bricht den Vorgang ab, ohne einen Ordner zu erstellen.

    Wahl des Namens für den neu zu erstellenden Ordner.

    Abbildung 2.61. Wahl des Namens für den neu zu erstellenden Ordner.

  3. Geben Sie den Namen des neu zu erstellenden Ordners ein.

  4. Betätigen Sie die Schaltfläche OK.

Der Ordner wird erstellt, falls an dieser Stelle nicht schon ein Dateisystem-Objekt (Datei oder Ordner) mit dem selben Namen existiert.

Zur Illustration finden Sie im Folgenden eine Animation der zu tätigenden Aktionen.

Abbildung 2.62. Animation: Neuen Ordner in der Ressourcensammlung anlegen.


2.3.4. Ressourcen löschen

In jCAPT ist es möglich Ressourcen aus der Ressourcensammlung zu löschen. Hierzu müssen Sie folgende Aktionen ausführen:

  1. Wählen Sie in der Ressourcensammlung die zu löschende Ressource durch einen Mausklick auf deren Namen bzw. Symbol.

  2. Starten Sie die Lösch-Operation. Dies kann auf zweierlei Arten geschehen:

    • Betätigen der Schaltfläche Löschen in der Symbolleiste der Ressourcensammlung

      Ressourcen löschen über die Symbolleiste.

      Abbildung 2.63. Ressourcen löschen über die Symbolleiste.

    • Öffnen des Kontextmenüs durch einen Klick mit der rechten Maustaste und Wahl des Menüeintrags Löschen

      Ressourcen löschen über das Kontextmenü.

      Abbildung 2.64. Ressourcen löschen über das Kontextmenü.

  3. Entscheiden Sie bei der Sicherheitsabfrage, ob die Ressource wirklicht gelöscht werden soll. Betätigen der Schaltfläche Nein bricht den Vorgang ab, ohne die Ressource zu löschen. Wenn Sie auf Ja klicken, wird die Ressource gelöscht.

    Sicherheitsabfrage beim Löschen einer Datei.

    Abbildung 2.65. Sicherheitsabfrage beim Löschen einer Datei.

    Sicherheitsabfrage beim Löschen eines Ordners.

    Abbildung 2.66. Sicherheitsabfrage beim Löschen eines Ordners.

[Achtung] Achtung

Beim Löschen wird kein Papierkorb verwendet, sondern die Ressource ist unwiederbringlich gelöscht. Außerdem wird beim Löschen von Ordnern der gesamte Inhalt ebenfalls gelöscht.

Zur Illustration finden Sie im Folgenden eine Animation der zu tätigenden Aktionen.

Abbildung 2.67. Animation: Ressourcen löschen.


2.3.5. Ansicht in der Ressourcensammlung aktualisieren

Da die Möglichkeiten der Ressourcensammlung in jCAPT keinen vollwertigen Ersatz für einen Dateimanager darstellen, wird es bisweilen nötig sein, einen solchen zur Organisation der Materialien zu verwenden. Während am Datenträger gelöschte Dateien beim Wechsel von einer anderen Anwendung zu jCAPT automatisch aus der Ansicht in der Ressourcensammlung entfernt werden, muss man für extern neu hinzugefügte die Ansicht manuell aktualisieren. Betätigen Sie hierzu die Schaltfläche Aktualisieren in der Symbolleiste der Ressourcensammlung.

Ansicht in der Ressourcensammlung aktualisieren

Abbildung 2.68. Ansicht in der Ressourcensammlung aktualisieren

Die Aktualisierung der Ansicht in der Ressourcensammlung wird gestart. Der Vorgang kann je nach Größe der Ressourcensammlung und Geschwindigkeit des Datenträgers einige Sekunden dauern. Am Ende spiegelt die Ansicht den Zustand der Ressourcensammlung auf dem Datenträger wider.

Zur Illustration finden Sie im Folgenden eine Animation der zu tätigenden Aktionen.

Abbildung 2.69. Animation: Ansicht in der Ressourcensammlung aktualisieren.


2.3.6. Ressourcen verschieben

Damit die Materialien organisiert werden können, bietet jCAPT die Möglichkeit, Ressourcen in der Ressourcensammlung zu verschieben. Dies erfolgt mittels Drag-and-Drop und funktioniert sowohl für Dateien als auch für Ordner:

  1. Wählen Sie in der Ressourcensammlung die zu verschiebende Ressource mittels Mausklick auf deren Namen bzw. Symbol.

  2. Beginnen Sie die Maus mit gedrückter linker Maustaste zu ziehen. Der Mauszeiger verändert sich und zeigt an, dass die Ressource verschoben wird.

  3. Ziehen Sie den Mauszeiger mit weiterhin gedrückter Maustaste über den Zielordner.

  4. Lassen Sie die Maustaste los. Die Ressource wird verschoben.

[Tipp] Tipp

Wenn Sie bei noch gedrückter Maustaste die Taste Esc betätigen, wird der Drag-and-Drop-Vorgang abgebrochen.

Abbildung 2.70. Ressourcen verschieben.

Ist im Zielordner schon eine Ressource mit dem selben Namen wie die zu verschiebende vorhanden, so wird gefragt, ob diese überschrieben werden soll.

Vorhandene Ressource(n) beim Verschieben überschreiben.

Abbildung 2.71. Vorhandene Ressource(n) beim Verschieben überschreiben.

Betätigen der Schaltfläche Ja überschreibt diese eine Ressource. Bei der Wahl von Ja, alle wird bei diesem Verschieben bei allen Namensgleichheiten die schon vorhandene Ressource überschrieben. Ein Wählen von Nein überschreibt diese eine Ressource nicht. In allen drei Fällen wird anschließend das Verschieben fortgesetzt. Bei Betätigen der Schaltfläche Abbrechen hingegen wird die Ressource nicht überschrieben und der gesamte Vorgang abgebrochen. Bis dahin schon verschobenen Ressourcen bleiben weiterhin verschoben, die noch nicht verschobenen Ressourcen bleiben unberührt.

Zur Illustration finden Sie im Folgenden eine Animation der zu tätigenden Aktionen.

Abbildung 2.72. Animation: Ressourcen verschieben.


2.3.7. Ressourcen kopieren

Neben der Möglichkeit, Ressourcen in der Ressourcensammlung zu verschieben, kann man diese in jCAPT auch kopieren. Dies erfolgt ebenfalls mittels Drag-and-Drop und funktioniert sowohl für Dateien als auch für Ordner:

  1. Betätigen Sie die Strg-Taste und halten Sie sie gedrückt.

  2. Wählen Sie in der Ressourcensammlung die zu verschiebende Ressource mittels Mausklick auf deren Namen bzw. Symbol.

  3. Beginnen Sie die Maus mit gedrückter linker Maus- und Strg-Taste zu ziehen. Der Mauszeiger verändert sich und zeigt an, dass die Ressource kopiert wird.

  4. Ziehen Sie den Mauszeiger mit weiterhin gedrückter Maus- und Strg-Taste über den Zielordner.

  5. Lassen Sie die Maus- und die Strg-Taste los. Die Ressource wird kopiert.

[Tipp] Tipp

Wenn Sie bei noch gedrückter Maustaste die Taste Esc betätigen, wird der Drag-and-Drop-Vorgang abgebrochen.

Abbildung 2.73. Ressourcen kopieren.

Ist im Zielordner schon eine Ressource mit dem selben Namen wie die zu kopierende vorhanden, so wird gefragt, ob diese überschrieben werden soll.

Vorhandene Ressource(n) beim Kopieren überschreiben.

Abbildung 2.74. Vorhandene Ressource(n) beim Kopieren überschreiben.

Betätigen der Schaltfläche Ja überschreibt diese eine Ressource. Bei der Wahl von Ja, alle wird bei diesem Verschieben bei allen Namensgleichheiten die schon vorhandene Ressource überschrieben. Ein Wählen von Nein überschreibt diese eine Ressource nicht. In allen drei Fällen wird anschließend das Kopieren fortgesetzt. Bei Betätigen der Schaltfläche Abbrechen hingegen wird die Ressource nicht überschrieben und der gesamte Vorgang abgebrochen. Bis dahin schon kopierte Ressourcen bleiben weiterhin kopiert, die noch nicht kopierten Ressourcen bleiben unberührt.

Zur Illustration finden Sie im Folgenden eine Animation der zu tätigenden Aktionen.

Abbildung 2.75. Animation: Ressourcen kopieren.


2.4. Lernpaket aufbauen und bearbeiten

2.4.1. Allgemeine Aktionen
2.4.2. Manifest
2.4.3. Ressource-Referenzen
2.4.4. Ressource-Referenz
2.4.5. Abhängigkeit (Datei/URL)
2.4.6. Abhängigkeit (Ressource-Referenz)
2.4.7. Organisationen
2.4.8. Organisation
2.4.9. Inhalt

In diesem Teil der Bedienungsanleitung wird beschrieben, wie man die Ressourcen eines CPS-Pakets logisch strukturiert. Diese logische Strukturierung wird bei der Anzeige des CPS-Pakets verwendet und kann mit einem Inhaltsverzeichnis eine Buches verglichen werden. Um sie zu erstellen existieren eine Menge von Knoten, welche jeder eine spezielle Aufgabe erfüllt. Diese Knoten werden hierarchisch angeordnet und legen so die Auswahl und Strukturierung der anzeigerelevanten Ressourcen des Lernpakets fest.


2.4.1. Allgemeine Aktionen

Bei der Bearbeitung des Manifests gibt es neben den speziellen Operationen auf die unterschiedlichen Knotentypen auch allgemeine Aktionen, welche für jeden Knoten gelten. Dies sind Operationen wie rückgängig machen und wiederholen von Aktionen, die Bewegung von Knoten im Manifest, die Verwendung der Zwischenablage und das Löschen von Knoten. Diese typunabhängigen Operationen werden im Folgenden beschrieben und liefern die Basis für spezielle Operationen auf einzelne Knotentypen.


2.4.1.1. Aktion(en) rückgängig machen

jCAPT bietet die Möglichkeit, Operationen an der Manifeststruktur wieder rückgängig zu machen. Es gibt keine prinzipielle Einschänkung bezüglich der Anzahl der Operationen, die rückgängig gemacht werden können; die tatsächliche Zahl hängt jedoch vom verfügbaren Hauptspeicher ab.

Es gibt drei Möglichkeiten, eine Aktion rückgängig zu machen:

  • Betätigen der Schaltfläche Rückgängig in der Symbolleiste

    Aktion(en) rückgängig machen über die Symbolleiste.

    Abbildung 2.76. Aktion(en) rückgängig machen über die Symbolleiste.

  • Öffnen des Menüs Bearbeiten und Wahl des Menüeintrags Rückgängig. Nach dem Text Rückgängig im Menüeintrag ist zusätzlich noch die Aktion angeführt, welche dadurch rückgängig gemacht wird.

    Aktion(en) rückgängig machen über das Menü.

    Abbildung 2.77. Aktion(en) rückgängig machen über das Menü.

  • Betätigen der Tastenkombination Strg-Z

In allen drei Fällen wird die jeweils letzte gültige Aktion rückgängig gemacht. Wenn noch keine Aktion getätigt wurde bzw. alle Aktionen rückgängig gemacht wurden, sind die Schaltfläche in der Symbolleiste und der Menüeintrag deaktiviert und können nicht angewählt werden. Auch die Tastenkombination zeigt dann keine Wirkung.

[Tipp] Tipp

Sie können ein CPS-Paket jederzeit speichern (siehe Abschnitt 2.2.5, „CPS-Paket speichern“), ohne die Möglichkeit zu verlieren, Aktionen rückgängig zu machen.

Zur Illustration finden Sie im Folgenden eine Animation der zu tätigenden Aktionen.

Abbildung 2.78. Animation: Aktion(en) rückgängig machen.


2.4.1.2. Aktion(en) wiederholen

Als Gegenstück zum Rückgängigmachen von Aktionen bietet jCAPT auch die Möglichkeit, rückgängig gemachte Operationen an der Manifeststruktur zu wiederholen.

Es gibt drei Möglichkeiten, eine Aktion zu wiederholen:

  • Betätigen der Schaltfläche Wiederholen in der Symbolleiste

    Aktion(en) wiederholen über die Symbolleiste.

    Abbildung 2.79. Aktion(en) wiederholen über die Symbolleiste.

  • Öffnen des Menüs Bearbeiten und Wahl des Menüeintrags Wiederholen. Nach dem Text Wiederholen im Menüeintrag ist zusätzlich noch die Aktion angeführt, welche dadurch wiederholt wird.

    Aktion(en) wiederholen über das Menü.

    Abbildung 2.80. Aktion(en) wiederholen über das Menü.

  • Betätigen der Tastenkombination Strg-Y

In allen drei Fällen wird die jeweils letzte rückgängig gemachte Aktion wiederholt. Wenn noch keine Aktion rückgängig gemacht wurde bzw. alle Aktionen wiederholt wurden sind die Schaltfläche in der Symbolleiste und der Menüeintrag deaktiviert und können nicht angewählt werden. Auch die Tastenkombination zeigt dann keine Wirkung.

[Tipp] Tipp

Sie können ein CPS-Paket jederzeit speichern (siehe Abschnitt 2.2.5, „CPS-Paket speichern“), ohne die Möglichkeit zu verlieren, Aktionen zu wiederholen.

Zur Illustration finden Sie im Folgenden eine Animation der zu tätigenden Aktionen.

Abbildung 2.81. Animation: Aktion(en) wiederholen.


2.4.1.3. Reihenfolge von Knoten verändern

Beim Hinzufügen von Knoten in der Manifeststruktur werden diese immer am Ende der schon bestehenden Geschwister-Knoten eingefügt. Besonders für den Organisationen-Teil, welcher beim Betrachten des CPS-Pakets den Inhalt strukturiert, ist es oft nötig, die Reihenfolge von Knoten zu ändern. Aber auch bei anderen Teilen des Manifests kann eine Umordnung für eine bessere Verständlichkeit und Wartbarkeit sorgen.

Damit in jCAPT die Reihenfolge von Knoten verändert werden kann, müssen folgende Voraussetzungen erfüllt sein:

  • es handelt sich um mindestens zwei Knoten

  • die Knoten sind alle Kinder des selben Vaterknotens

  • die Knoten haben alle den selben Typ

  • die Knoten sind von einem der folgenden Typen:

    • Organisation

    • Inhalt

    • Ressource-Referenz

    • Abhängigkeit (Datei/URL)

    • Abhängigkeit (Ressource-Referenz)

Die Knoten sind im Baum automatisch nach Typen gruppiert. Ihre Reihenfolge kann nur innerhalb dieser Gruppierungen verändert werden.

[Tipp] Tipp

Die Reihenfolge der Knoten wird beim Betrachten des CPS-Pakets nur bei Inhalt-Knoten und teilweise auch bei Organisation-Knoten sichtbar. Bei den restlichen Knotentypen hat eine Veränderung der Reihenfolge keine sichtbare Konsequenz, kann aber die Verständlichkeit und Wartbarkeit des Pakets erhöhen.

Um die Position eines Knotens in seiner Typ-Gruppe zu verändern müssen Sie folgende Aktionen durchführen:

  1. Wählen Sie in der Manifestansicht den Knoten, dessen Position Sie verändern möchten, mit einem Mausklick auf dessen Namen bzw. Symbol.

  2. Starten Sie die Verschiebe-Operation in die gewünschte Richtung. Dies kann auf viererlei Arten geschehen:

    • Betätigen der Schaltfläche Aufwärts bzw. Abwärts in der Symbolleiste der Manifestansicht

      Reihenfolge von Knoten verändern über die Symbolleiste.
      Reihenfolge von Knoten verändern über die Symbolleiste.

      Abbildung 2.82. Reihenfolge von Knoten verändern über die Symbolleiste.

    • Öffnen des Menüs Bearbeiten und Wahl des Menüeintrags Aufwärts bzw. Abwärts

      Reihenfolge von Knoten verändern über das Menü.
      Reihenfolge von Knoten verändern über das Menü.

      Abbildung 2.83. Reihenfolge von Knoten verändern über das Menü.

    • Öffnen des Kontextmenüs durch einen Klick mit der rechten Maustaste und Wahl des Menüeintrags Aufwärts bzw. Abwärts

      Reihenfolge von Knoten verändern über das Kontextmenü.
      Reihenfolge von Knoten verändern über das Kontextmenü.

      Abbildung 2.84. Reihenfolge von Knoten verändern über das Kontextmenü.

    • Betätigen der Tastenkombination Alt-Pfeil nach oben für ein Verschieben nach oben bzw. Alt-Pfeil nach unten für ein Verschieben nach unten

Der Knoten wird in der Folge um eine Position nach oben bzw. nach unten verschoben. Dabei werden Kindknoten ebenfalls mit dem Knoten bewegt. Durch Ausführung mehrere Verschiebe-Operationen lässt sich die Reihenfolge der Knoten einer gesamten Typ-Gruppe verändern.

[Anmerkung] Anmerkung

Wenn die Möglichkeiten zum Verschieben eines Knotens (Symbolleiste, Menü, Kontextmenü) deaktiviert sind und die Betätigung der Tastenkombination keine Wirkung zeigt, so ist dieser Knotentyp eventuell nicht verschiebbar, er hat keinen Knoten, gegen den er verschoben werden könnte oder er befindet sich am Rand der Typ-Gruppe.


2.4.1.4. Knoten verschieben

Neben der Möglichkeit die Reihenfolge von Knoten einer Ebene zu verändern ist es in jCAPT auch möglich, Knoten in andere Teile des Manifests zu verschieben. Der verschobene Knoten wird dabei mitsamt eventuell vorhandener Kindknoten als Kind des Zielknotens eingefügt. Die Verschieben-Operation wird mittels Drag-and-Drop erledigt, und man kann so das Manifest nach Belieben strukturieren.

[Anmerkung] Anmerkung

Knoten können nur innerhalb des selben Manifests mittels Drag-and-Drop verschoben werden. Wenn Sie Knoten in ein anderes Manifest verschieben wollen, so müssen Sie die Zwischenablage verwenden. Nach dem Ausschneiden des Knotens in die Zwischenablage (siehe Abschnitt 2.4.1.6, „Knoten in die Zwischenablage ausschneiden“), und dem Wechsel zu einem anderen geöffneten CPS-Paket (siehe Abschnitt 2.2.4, „Zwischen geöffneten CPS-Paketen wechseln“) kann der Knoten an einer geeigneten Stelle wieder aus der Zwischenablage eingefügt werden (siehe Abschnitt 2.4.1.8, „Knoten aus der Zwischenablage einfügen“).

Damit ein Knoten im Manifest verschoben werden kann, müssen einige Voraussetzungen erfüllt sein:

  • der zu verschiebende Knoten muss von einem der folgenden Typen sein:

    • Inhalt

    • Metadaten

    • Abhängigkeit (Datei/URL)

    • Abhängigkeit (Ressource-Referenz)

  • es muss erlaubt sein, dass der Zielknoten einen Knoten vom Typ des verschobenen als Kindknoten besitzt

  • die Höchstzahl an erlaubten Knoten dieses Typs an der Einfügestelle darf nicht überschritten werden

Um einen Knoten zu verschieben müssen Sie folgende Aktionen durchführen:

  1. Wählen Sie in der Manifestansicht den zu verschiebenden Knoten mittels Mausklick auf dessen Namen bzw. Symbol.

  2. Beginnen Sie die Maus mit gedrückter linker Maustaste zu ziehen. Der Mauszeiger verändert sich und zeigt an, dass der Knoten verschoben wird.

  3. Ziehen Sie den Mauszeiger mit weiterhin gedrückter Maustaste über den Zielknoten.

  4. Lassen Sie die Maustaste los.

[Tipp] Tipp

Wenn Sie bei noch gedrückter Maustaste die Taste Esc betätigen, wird der Drag-and-Drop-Vorgang abgebrochen.

Abbildung 2.85. Knoten verschieben.

Der Knoten wird in der Folge samt seinen eventuell vorhandenen Kindknoten an seine Stelle als Kindknoten des gewählten Zielknotens verschoben. Besitzt der Zielknoten schon Kindknoten vom selben Typ wie der zu verschiebende, so wird der verschobene Knoten an der Stelle nach diesen Kindknoten eingefügt.


2.4.1.5. Knoten kopieren

Neben der Möglichkeit die Knoten im Manifest zu verschieben ist es in jCAPT auch möglich, Knoten in andere Teile des Manifests zu kopieren. Der kopierte Knoten wird dabei mitsamt eventuell vorhandener Kindknoten als Kind des Zielknotens eingefügt. Die Kopieren-Operation wird mittels Drag-and-Drop erledigt, und man kann so Knoten im Manifest nach Belieben duplizieren.

[Anmerkung] Anmerkung

Knoten können nur innerhalb des selben Manifests mittels Drag-and-Drop kopiert werden. Wenn Sie Knoten in ein anderes Manifest kopieren wollen, so müssen Sie die Zwischenablage verwenden. Nach dem Kopieren des Knotens in die Zwischenablage (siehe Abschnitt 2.4.1.5, „Knoten kopieren“), und dem Wechsel zu einem anderen geöffneten CPS-Paket (siehe Abschnitt 2.2.4, „Zwischen geöffneten CPS-Paketen wechseln“) kann der Knoten an einer geeigneten Stelle wieder aus der Zwischenablage eingefügt werden (siehe Abschnitt 2.4.1.8, „Knoten aus der Zwischenablage einfügen“).

Damit ein Knoten im Manifest kopiert werden kann, müssen einige Voraussetzungen erfüllt sein:

  • der zu kopierende Knoten muss von einem der folgenden Typen sein:

    • Inhalt

    • Metadaten

    • Abhängigkeit (Datei/URL)

    • Abhängigkeit (Ressource-Referenz)

  • es muss erlaubt sein, dass der Zielknoten einen Knoten vom Typ des kopierten als Kindknoten besitzt

  • die Höchstzahl an erlaubten Knoten dieses Typs an der Einfügestelle darf nicht überschritten werden

Um einen Knoten zu kopieren müssen Sie folgende Aktionen durchführen:

  1. Betätigen Sie die Strg-Taste und halten Sie sie gedrückt.

  2. Wählen Sie in der Manifestansicht den zu kopierenden Knoten mittels Mausklick auf dessen Namen bzw. Symbol.

  3. Beginnen Sie die Maus mit gedrückter linker Maus- und Strg-Taste zu ziehen. Der Mauszeiger verändert sich und zeigt an, dass der Knoten kopiert wird.

  4. Ziehen Sie den Mauszeiger mit weiterhin gedrückter Maus- und Strg-Taste über den Zielknoten.

  5. Lassen Sie die Maus- und die Strg-Taste los.

[Tipp] Tipp

Wenn Sie bei noch gedrückter Maustaste die Taste Esc betätigen, wird der Drag-and-Drop-Vorgang abgebrochen.

Abbildung 2.86. Knoten kopieren.

Der Knoten wird in der Folge samt seinen eventuell vorhandenen Kindknoten an seine Stelle als Kindknoten des gewählten Zielknotens kopiert. Besitzt der Zielknoten schon Kindknoten vom selben Typ wie der zu kopierende, so wird der kopierte Knoten an die Stelle nach diesen Kindknoten eingefügt.

[Anmerkung] Anmerkung

Bei Knoten, welche über eine Identifikation verfügen (Inhalt und Ressource-Referenz) wird diese beim Kopieren auf einen neuen eindeutigen Wert gesetzt. Dies ist nötig, damit die Identifikation weiterhin eindeutig ist und keine zwei Knoten die gleiche besitzen.


2.4.1.6. Knoten in die Zwischenablage ausschneiden

Neben der Möglichkeit Knoten mittels Drag-and-Drop zu verschieben (siehe Abschnitt 2.4.1.4, „Knoten verschieben“) kann man in jCAPT auch die Zwischenablage zum Verschieben verwenden. Es können nur Knoten ausgeschnitten werden, die entfernbar sind und bei denen es auch Sinn macht, dass sie wieder eingefügt werden. Es sind dies Knoten der folgenden Typen:

  • Organisation

  • Inhalt

  • Ressource-Referenz

  • Abhängigkeit (Datei/URL)

  • Abhängigkeit (Ressource-Referenz)

  • Metadaten

Um einen Knoten in die Zwischenablage auszuschneiden müssen Sie folgende Aktionen durchführen:

  1. Wählen Sie in der Manifestansicht den Knoten, den Sie in die Zwischenablage ausschneiden möchten, mit einem Mausklick auf dessen Namen bzw. Symbol.

  2. Starten Sie die Ausschneiden-Operation. Dies kann auf viererlei Arten geschehen:

    • Betätigen der Schaltfläche Ausschneiden in der Symbolleiste

      Knoten in die Zwischenablage ausschneiden über die Symbolleiste.

      Abbildung 2.87. Knoten in die Zwischenablage ausschneiden über die Symbolleiste.

    • Öffnen des Menüs Bearbeiten und Wahl des Menüeintrags Ausschneiden

      Knoten in die Zwischenablage ausschneiden über das Menü.

      Abbildung 2.88. Knoten in die Zwischenablage ausschneiden über das Menü.

    • Öffnen des Kontextmenüs durch einen Klick mit der rechten Maustaste und Wahl des Menüeintrags Ausschneiden

      Knoten in die Zwischenablage ausschneiden über das Kontextmenü.

      Abbildung 2.89. Knoten in die Zwischenablage ausschneiden über das Kontextmenü.

    • Betätigen der Tastenkombination Strg-X

Der Knoten wird in der Folge samt eventuell vorhandenen Kindknoten in die Zwischenablage ausgeschnitten. Von dort kann er an anderer geeigneter Stelle später wieder eingefügt werden (siehe Abschnitt 2.4.1.8, „Knoten aus der Zwischenablage einfügen“).

[Anmerkung] Anmerkung

Wenn die Möglichkeiten zum Ausschneiden eines Knotens (Symbolleiste, Menü, Kontextmenü) deaktiviert sind und die Betätigung der Tastenkombination keine Wirkung zeigt, so ist dieser Knotentyp eventuell nicht ausschneidbar, weil er beispielsweise im Manifest nicht fehlen darf (z.B. Organisationen-Knoten).


2.4.1.7. Knoten in die Zwischenablage kopieren

Neben der Möglichkeit Knoten mittels Drag-and-Drop zu kopieren (siehe Abschnitt 2.4.1.5, „Knoten kopieren“) kann man in jCAPT auch die Zwischenablage zum Kopieren verwenden. Es können nur Knoten kopiert werden, bei denen es auch Sinn macht, dass sie wieder eingefügt werden. Es sind dies Knoten der folgenden Typen:

  • Organisation

  • Inhalt

  • Ressource-Referenz

  • Abhängigkeit (Datei/URL)

  • Abhängigkeit (Ressource-Referenz)

  • Metadaten

Um einen Knoten in die Zwischenablage zu kopieren müssen Sie folgende Aktionen durchführen:

  1. Wählen Sie in der Manifestansicht den Knoten, den Sie in die Zwischenablage zu kopieren möchten, mit einem Mausklick auf dessen Namen bzw. Symbol.

  2. Starten Sie die Kopieren-Operation. Dies kann auf viererlei Arten geschehen:

    • Betätigen der Schaltfläche Kopieren in der Symbolleiste

      Knoten in die Zwischenablage kopieren über die Symbolleiste.

      Abbildung 2.90. Knoten in die Zwischenablage kopieren über die Symbolleiste.

    • Öffnen des Menüs Bearbeiten und Wahl des Menüeintrags Kopieren

      Knoten in die Zwischenablage kopieren über das Menü.

      Abbildung 2.91. Knoten in die Zwischenablage kopieren über das Menü.

    • Öffnen des Kontextmenüs durch einen Klick mit der rechten Maustaste und Wahl des Menüeintrags Kopieren

      Knoten in die Zwischenablage kopieren über das Kontextmenü.

      Abbildung 2.92. Knoten in die Zwischenablage kopieren über das Kontextmenü.

    • Betätigen der Tastenkombination Strg-C

Der Knoten wird in der Folge samt eventuell vorhandenen Kindknoten in die Zwischenablage kopiert. Von dort kann er an anderer geeigneter Stelle später wieder eingefügt werden (siehe Abschnitt 2.4.1.8, „Knoten aus der Zwischenablage einfügen“).

[Anmerkung] Anmerkung

Wenn die Möglichkeiten zum Kopieren eines Knotens (Symbolleiste, Menü, Kontextmenü) deaktiviert sind und die Betätigung der Tastenkombination keine Wirkung zeigt, so ist dieser Knotentyp eventuell nicht kopierbar, weil er beispielsweise nur ein Mal im Manifest vorkommen darf (z.B. Organisationen-Knoten).


2.4.1.8. Knoten aus der Zwischenablage einfügen

In die Zwischenablage ausgeschnittene bzw. kopierte Knoten können an geeigneter Stelle aus dieser wieder eingefügt werden. So können Teile eines CPS-Pakets über die Zwischenablage in diesem verschoben bzw. kopiert werden. Da die Zwischenablage global arbeitet und nicht nur auf Paket-Ebene können über sie auch Knoten zwischen CPS-Paketen ausgetauscht werden. So ist es beispielsweise möglich, einen Knoten in einem CPS-Paket in die Zwischenablage zu kopieren (siehe Abschnitt 2.4.1.5, „Knoten kopieren“), zu einem anderen geöffneten CPS-Paket zu wechseln (siehe Abschnitt 2.2.4, „Zwischen geöffneten CPS-Paketen wechseln“) und den Knoten an einer geeigneten Stelle einzufügen.

[Wichtig] Wichtig

Bei Knoten, welche über eine Identifikation verfügen (Inhalt, Organisation, Ressource-Referenz) wird diese beim Einfügen auf einen neuen eindeutigen Wert gesetzt, wenn die Knoten durch eine Kopier-Operation in die Zwischenablage gekommen sind. Dies ist nötig damit die Identifikation weiterhin eindeutig ist und keine zwei Knoten die gleiche besitzen.

Damit ein Knoten aus der Zwischenablage eingefügt werden kann, müssen einige Voraussetzungen erfüllt sein:

  • es muss erlaubt sein, dass an der Einfügestelle ein Knoten vom Typ des in der Zwischenablage befindlichen existiert

  • die Höchstzahl an erlaubten Knoten dieses Typs an der Einfügestelle darf nicht überschritten werden

Um einen Knoten aus der Zwischenablage einzufügen müssen Sie folgende Aktionen durchführen:

  1. Wählen Sie in der Manifestansicht den Knoten, als dessen Kind Sie den in die Zwischenablage liegenden einfügen möchten, mit einem Mausklick auf dessen Namen bzw. Symbol.

  2. Starten Sie die Einfügen-Operation. Dies kann auf viererlei Arten geschehen:

    • Betätigen der Schaltfläche Einfügen in der Symbolleiste

      Knoten aus der Zwischenablage einfügen über die Symbolleiste.

      Abbildung 2.93. Knoten aus der Zwischenablage einfügen über die Symbolleiste.

    • Öffnen des Menüs Bearbeiten und Wahl des Menüeintrags Einfügen

      Knoten aus der Zwischenablage einfügen über das Menü.

      Abbildung 2.94. Knoten aus der Zwischenablage einfügen über das Menü.

    • Öffnen des Kontextmenüs durch einen Klick mit der rechten Maustaste und Wahl des Menüeintrags Einfügen

      Knoten aus der Zwischenablage einfügen über das Kontextmenü.

      Abbildung 2.95. Knoten aus der Zwischenablage einfügen über das Kontextmenü.

    • Betätigen der Tastenkombination Strg-V

Der Knoten in die Zwischenablage wird in der Folge samt seinen eventuell vorhandenen Kindknoten als Kindknoten des gewählten Knotens eingefügt. Besitzt dieser Knoten schon Kindknoten vom selben Typ wie der einzufügende, so wird der Knoten aus der Zwischenablage nach diesen Kindknoten eingefügt.

[Anmerkung] Anmerkung

Wenn die Möglichkeiten zum Einfügen eines Knotens (Symbolleiste, Menü, Kontextmenü) deaktiviert sind und die Betätigung der Tastenkombination keine Wirkung zeigt, so kann der Knoten nicht eingefügt werden, weil er beispielsweise an dieser Stelle nur ein Mal vorkommen darf (z.B. Manifest-Knoten).


2.4.1.9. Knoten löschen

Erstellte Knoten können in der Manifest-Ansicht auch wieder gelöscht werden. Es können nur Knoten der folgenden Typen gelöscht werden:

  • Organisation

  • Inhalt

  • Ressource-Referenz

  • Abhängigkeit (Datei/URL)

  • Abhängigkeit (Ressource-Referenz)

  • Metadaten

[Achtung] Achtung

Vorsicht ist beim Löschen von Ressource-Referenz-Knoten geboten. Inhalt- bzw. Abhängigkeit (Ressource-Referenz)-Knoten könnten noch auf diesen verweisen (siehe Abschnitt 2.4.9.4, „Verweis auf Ressource-Referenz legen“ bzw. Abschnitt 2.4.6.2, „Verweis auf abhängige Ressource-Referenz legen“) und wären nach dem Löschen ungültig. Auch beim Löschen eines Organisation-Knoten muss man darauf achten, dass dieser nicht als Standard-Organisation (siehe Abschnitt 2.4.7.1, „Standard-Organisation festlegen“) angegeben ist.

Um einen Knoten zu löschen müssen Sie folgende Aktionen durchführen:

  1. Wählen Sie in der Manifestansicht den Knoten, den Sie löschen möchten, mit einem Mausklick auf dessen Namen bzw. Symbol.

  2. Starten Sie die Löschen-Operation. Dies kann auf viererlei Arten geschehen:

    • Betätigen der Schaltfläche Löschen in der Symbolleiste

      Knoten löschen über die Symbolleiste.

      Abbildung 2.96. Knoten löschen über die Symbolleiste.

    • Öffnen des Menüs Bearbeiten und Wahl des Menüeintrags Löschen

      Knoten löschen über das Menü.

      Abbildung 2.97. Knoten löschen über das Menü.

    • Öffnen des Kontextmenüs durch einen Klick mit der rechten Maustaste und Wahl des Menüeintrags Löschen

      Knoten löschen über das Kontextmenü.

      Abbildung 2.98. Knoten löschen über das Kontextmenü.

    • Betätigen der Entf-Taste

Der Knoten wird in der Folge samt eventuell vorhandenen Kindknoten gelöscht.

[Anmerkung] Anmerkung

Wenn die Möglichkeiten zum Löschen eines Knotens (Symbolleiste, Menü, Kontextmenü) deaktiviert sind und die Betätigung der Tastenkombination keine Wirkung zeigt, so ist dieser Knotentyp eventuell nicht löschbar, weil er beispielsweise im Manifest nicht fehlen darf (z.B. Organisationen-Knoten).


2.4.2. Manifest

Der Manifestknoten ist der oberste Knoten im Manifest. Alle anderen Knoten des Manifests sind direkt oder indirekt seine Kindknoten. Der Manifest-Knoten muss an dieser Stelle genau ein Mal im Manifest vorkommen. Aus diesem Grund dürfen Sie ihn weder kopieren noch ausschneiden, verschieben oder löschen. Die Schaltflächen, Menüeinträge und Tastenkombinationen um diese Operationen auszuführen sind für den Manifest-Knoten deaktiviert. Da er die Wurzel des gesamten Manifest-Baums ist, kann man ihn auch nicht nach unten oder oben verschieben.

Sie finden den Manifest-Knoten am oberen Rand der Manifestansicht im rechten Fensterbereich von jCAPT. Er hat die Bezeichnung Manifest in Paketname, wobei Paketname der Name des Basisordners ist.

Abbildung 2.99. Manifest-Knoten.

Der Manifest-Knoten bietet neben seiner Eigenschaft als Wurzel des Manifest auch die Möglichkeit globale Einstellungen, welche für das ganze Manifest gelten sollen, festzulegen:

  • Basispfad/-URL

  • Manifestversion

Darüber hinaus besitzt der Manifest-Knoten eine eindeutige Identifikation. Diese wird automatisch beim Erstellen des CPS-Pakets (siehe Abschnitt 2.2.1, „Neues CPS-Paket erstellen“) erzeugt und sollte nicht verändert werden. Ebenso beim Erstellen angelegt werden der Organisationen-Knoten (siehe Abschnitt 2.4.7, „Organisationen“) und der Ressource-Referenzen-Knoten (siehe Abschnitt 2.4.3, „Ressource-Referenzen“) als Kindknoten des Manifest-Knoten. Neben diesen darf der Manifest-Knoten noch einen einzigen weiteren Kindknoten haben, nämlich einen Metadaten-Knoten (siehe Abschnitt 2.7.1, „Metadaten im Manifest hinzufügen“).


2.4.2.1. Basispfad/-URL für relative Speicherpositionen für das gesamte Manifest festlegen

Über den Manifest-Knoten kann man für das gesamte Manifest den Basispfad/die Basis-URL für relative Speicherpositionen festlegen. Diese Angaben wird zusammen mit im Manifest vorkommenden relativen Speicherpositionen verwendet, um den tatsächlichen Ort der Ressourcen festzulegen. Zu diesem Zweck wird bei der Anzeige des CPS-Pakets der Basispfad/die Basis-URL der in Unterknoten vorhandenen jeweiligen relativen Angabe einer Speicherposition vorangestellt. Für eine genaue Beschreibung der Berechnung anhand von Beispielen siehe Kapitel 2, Berechnung der Speicherposition von Ressourcen.

[Tipp] Tipp

Verwenden Sie immer relative Basispfade, welche nicht auf Positionen oberhalb des Basisordners verweisen. So können Sie sicherstellen, dass das Lernpaket auch auf anderen Rechnern korrekt angezeigt wird. Andernfalls könnten Dateien referenziert werden, welche beim Export des CPS-Pakets nicht berücksichtigt werden.

Um den Basispfad bzw. die Basis-URL für relative Speicherpositionen für das gesamte Manifest festzulegen müssen Sie folgende Aktionen durchführen:

  1. Wählen Sie den Manifest-Knoten in der Manifest-Ansicht durch einen Mausklick auf dessen Namen bzw. Symbol.

  2. Aktivieren Sie das Eingabefeld für den Wert des Attributs Basispfad/-URL durch einen Doppelklick.

  3. Geben Sie den Basispfad bzw. die Basis-URL ein.

  4. Schließen Sie die Eingabe durch Betätigen der Eingabetaste ab.

Basispfad/-URL für relative Speicherpositionen für das gesamte Manifest festlegen.

Abbildung 2.100. Basispfad/-URL für relative Speicherpositionen für das gesamte Manifest festlegen.

[Anmerkung] Anmerkung

Ist in einem untergeordneten Knoten (z.B. Ressource-Referenzen) ebenfalls ein Basispfad/eine Basis-URL angegeben, so überschreibt diese Einstellung jene im Manifest-Knoten.


2.4.2.2. Manifestversion angeben

Durch das Ausbessern von Fehlern und bei der Erweiterung bzw. Umstrukturierung des Inhalts werden CPS-Pakete auch noch nach der ersten Erstellung verändert. Um einen Überblick zu behalten, welchen Stand des Pakets man gerade bearbeitet kann man mit jCAPT die Version des CPS-Pakets setzen. Das Format dieser Zeichenkette ist nicht auf numerische Versionsangaben wie beispielsweise 1.5 beschränkt. Es liegt am jeweiligen Umfeld, in dem das CPS-Paket entwickelt bzw. verwendet wird, eine derartige Konvention festzulegen.

Um die Manifestversion anzugeben müssen Sie folgende Aktionen durchführen:

  1. Wählen Sie den Manifest-Knoten in der Manifest-Ansicht durch einen Mausklick auf dessen Namen bzw. Symbol.

  2. Aktivieren Sie das Eingabefeld für den Wert des Attributs Version durch einen Doppelklick.

  3. Geben Sie die aktuelle Versionsbezeichnung des CPS-Pakets ein.

  4. Schließen Sie die Eingabe durch Betätigen der Eingabetaste ab.

Abbildung 2.101. Manifestversion angeben.


2.4.3. Ressource-Referenzen

In der Rolle des Manifests als Inhaltsverzeichnis bzw. Navigationskomponente werden die einzelnen Ressourcen referenziert. Jedoch geschieht das nicht direkt in dem Teil, der die inhaltliche Strukturierung bestimmt (Organisation- bzw. Inhalt-Knoten), sondern es gibt eine zusätzliche Indirektionsstufe, die Ressource-Referenz-Knoten. Diese Knoten liegen unterhalb des Ressource-Referenzen-Knotens und werden von Inhalt-Knoten verwendet, damit diese auf Ressourcen verweisen können.

Der Ressource-Referenzen-Knoten liegt direkt unterhalb des Manifest-Knotens und darf nur an dieser Stelle und nur ein Mal im gesamten Manifest vorkommen. Aus diesem Grund dürfen Sie ihn weder kopieren noch ausschneiden, verschieben oder löschen. Die Schaltflächen, Menüeinträge und Tastenkombinationen um diese Operationen auszuführen sind für den Ressource-Referenzen-Knoten deaktiviert. Man kann ihn auch nicht nach unten oder oben verschieben, da es keinen gleichartigen Knoten gibt, mit dem er in der Position vertauscht werden könnte.

Sie finden den Ressource-Referenzen-Knoten unterhalb des Manifest-Knotens in der Manifestansicht im rechten Fensterbereich von jCAPT. Er hat die unveränderliche Bezeichnung Ressource-Referenzen.

Abbildung 2.102. Ressource-Referenzen-Knoten.

Der Ressource-Referenzen-Knoten wird beim Erstellen des CPS-Pakets (siehe Abschnitt 2.2.1, „Neues CPS-Paket erstellen“) erzeugt. Er bietet neben seiner Eigenschaft als gemeinsamer Vaterknoten aller Ressource-Referenzen des Manifests auch die Möglichkeit den Basispfad/die Basis-URL für relative Speicherpositionen für alle Ressource-Referenzen festzulegen.


2.4.3.1. Basispfad/-URL für relative Speicherpositionen für alle Ressource-Referenzen festlegen

Über den Ressource-Referenzen-Knoten kann man für alle Ressource-Referenzen den Basispfad/die Basis-URL für relative Speicherpositionen festlegen. Diese Angaben wird zusammen mit in den einzelnen Ressource-Referenz-Knoten vorkommenden relativen Speicherpositionen verwendet, um den tatsächlichen Ort der Ressourcen festzulegen. Zu diesem Zweck wird bei der Anzeige des CPS-Pakets der Basispfad/die Basis-URL der in Unterknoten vorhandenen jeweiligen relativen Angabe einer Speicherposition vorangestellt. Für eine genaue Beschreibung der Berechnung anhand von Beispielen siehe Kapitel 2, Berechnung der Speicherposition von Ressourcen.

[Tipp] Tipp

Verwenden Sie immer relative Basispfade, welche nicht auf Positionen oberhalb des Basisordners verweisen. So können Sie sicherstellen, dass das Lernpaket auch auf anderen Rechnern korrekt angezeigt wird. Andernfalls könnten Dateien referenziert werden, welche beim Export des CPS-Pakets nicht berücksichtigt werden.

Um den Basispfad bzw. die Basis-URL für relative Speicherpositionen für alle Ressource-Referenzen festzulegen müssen Sie folgende Aktionen durchführen:

  1. Wählen Sie den Ressource-Referenzen-Knoten in der Manifest-Ansicht durch einen Mausklick auf dessen Namen bzw. Symbol.

  2. Aktivieren Sie das Eingabefeld für den Wert des Attributs Basispfad/-URL durch einen Doppelklick.

  3. Geben Sie den Basispfad bzw. die Basis-URL ein.

  4. Schließen Sie die Eingabe durch Betätigen der Eingabetaste ab.

Basispfad/-URL für relative Speicherpositionen für alle Ressource-Referenzen festlegen.

Abbildung 2.103. Basispfad/-URL für relative Speicherpositionen für alle Ressource-Referenzen festlegen.

[Anmerkung] Anmerkung

Ist in einem untergeordneten Knoten (z.B. Ressource-Referenz) ebenfalls ein Basispfad/eine Basis-URL angegeben, so überschreibt diese Einstellung jene im Ressource-Referenzen-Knoten.


2.4.4. Ressource-Referenz

Ein Manifest verfügt über zwei Indirektionsstufen, über die es auf eine Ressource verweist. Die Ressource-Referenz-Knoten verweisen direkt auf die Ressourcen, entweder mit einem Dateipfad oder über eine URL. Die Inhalt-Knoten verweisen ihrerseits auf die Ressource-Referenz-Knoten. Dies hat zweierlei Vorteile: Der eine ist, dass die Referenzen auf Ressourcen an einer Stelle gesammelt und nicht über die gesamte Strukturierung des Inhalts verstreut sind. Der andere Vorteil ist, dass eine Ressource an zwei verschiedenen Stellen in der Inhaltsstruktur verwendet werden kann, ohne direkte Referenzen auf sie zu legen. Das ist hilfreich, wenn die Speicherposition der Ressource geändert wird. Diese muss dann nur an einer Stelle, eben beim Ressource-Referenz-Knoten, aktualisiert werden.

Verweise innerhalb eines CPS-Pakets.

Abbildung 2.104. Verweise innerhalb eines CPS-Pakets.

Die Ressource-Referenz-Knoten liegen direkt unterhalb des Ressource-Referenzen-Knotens. Sie dürfen nur dort im Manifest liegen und nicht geschachtelt werden. Ressource-Referenz-Knoten können in die Zwischenablage ausgeschnitten bzw. kopiert, und aus dieser wieder eingefügt werden. Da sie flach und ohne jede Hierarchie im Manifest liegen und ihre Reihenfolge keine Auswirkung auf die Anzeige des Pakets hat, macht dies nur Sinn, wenn sie auf diese Weise zwischen zwei Manifesten verschoben bzw. kopiert werden. Ein Verschieben bzw. Kopieren innerhalb des Manifests ergibt keinen Sinn, deshalb sind diese Operationen mittels Drag-and-Drop nicht verfügbar.

[Achtung] Achtung

Beim Einfügen eines in die Zwischenablage kopierten Ressource-Referenz-Knotens wird dessen Identifikation automatisch neu berechnet. Dies ist nötig, damit keine zwei Knoten jemals die selbe Identifikation aufweisen. Da die Referenzen von Inhalt-Knoten über diese Identifikation laufen, ist hierbei zu beachten, dass diese dann eventuell ungültig werden können, weil sie auf eine nicht vorhandene Ressource-Referenz verweisen.

Obwohl die Reihenfolge der Ressource-Referenz-Knoten, wie schon erwähnt, keine Relevanz für die sichtbare Form des Manifests hat, können, wenn mehr als zwei Knoten dieser Art existieren, diese nach oben bzw. unten verschoben werden. Das kann man beispielsweise nutzen, um Ressourcen mit ähnlichen Speicherpositionen zu gruppieren und dadurch die Wartung zu vereinfachen.

Sie finden die Ressource-Referenz-Knoten unterhalb des Ressource-Referenzen-Knotens in der Manifestansicht im rechten Fensterbereich von jCAPT. Verweist ein Ressource-Referenz-Knoten bereits auf eine Ressource, so wird deren Speicherposition als sein angezeigter Name verwendet. Ansonsten wird seine Identifikation, welche die Form RES-XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX hat, als Name verwendet.

Abbildung 2.105. Ressource-Referenz-Knoten.


2.4.4.1. Ressource-Referenz-Knoten erstellen

Neben den Inhalt-Knoten sind es vor allem die Ressource-Referenz-Knoten, welche beim Aufbauen eines Lernpakets im Manifest erstellt werden müssen. Hierbei gibt es keine theoretische Grenze, wieviel Knoten dieser Art erstellt werden können. Die Anzahl ist lediglich durch den verfügbaren Speicherplatz, sowohl im Hauptspeicher als auch auf dem Datenträger beschränkt.

Ressource-Referenz-Knoten können auf drei Arten erstellt werden:

  • indirekt beim Erstellen eines Inhalt-Knotens mittels Drag-and-Drop (siehe Abschnitt 2.4.9.1.1, „Inhalt-Knoten mittels Drag-and-Drop erstellen“)

  • mittels Drag-and-Drop einer Ressource

  • manuell mit anschließender Referenzierung der Ressource

[Anmerkung] Anmerkung

Da URLs keine Entsprechung in der Ressourcensammlung haben, können Ressource-Referenzen auf sie nur durch manuelle Erstellung und anschließender Referenzierung erzeugt werden.

2.4.4.1.1. Ressource-Referenz-Knoten mittels Drag-and-Drop erstellen

Um einen Ressource-Referenz-Knoten mittels Drag-and-Drop einer Ressource zu erstellen müssen Sie folgende Aktionen durchführen:

  1. Wählen Sie in der Ressourcensammlung jene Ressource, für welche eine Ressource-Referenz zu erstellen ist, mittels Mausklick auf deren Namen bzw. Symbol.

  2. Beginnen Sie die Maus mit gedrückter linker Maustaste zu ziehen. Der Mauszeiger verändert sich und zeigt an, dass der Verweis auf die Ressource übertragen wird.

  3. Ziehen Sie den Mauszeiger mit weiterhin gedrückter Maustaste über den Ressource-Referenzen-Knoten.

  4. Lassen Sie die Maustaste los.

[Tipp] Tipp

Wenn Sie bei noch gedrückter Maustaste die Taste Esc betätigen, wird der Drag-and-Drop-Vorgang abgebrochen.

Ressource-Referenz-Knoten mittels Drag-and-Drop erstellen.

Abbildung 2.106. Ressource-Referenz-Knoten mittels Drag-and-Drop erstellen.

Es wird ein neuer Ressource-Referenz-Knoten am Ende einer eventuell vorhandenen Liste von Ressource-Referenz-Knoten angelegt und die gewählte Ressource referenziert. Zusätzlich wird zumindest ein Abhängigkeit (Datei/URL)-Knoten für die gewählte Ressource erstellt. Wenn für die Ressource Abhängigkeiten aus ihrem Inhalt abgeleitet werden können (siehe Kapitel 3, Bestimmung der Abhängigkeiten von Ressourcen), so werden für diese ebenfalls Abhängigkeit (Datei/URL)-Knoten erstellt.

[Anmerkung] Anmerkung

Sie können eine Ressource auch in mehrmals in die Manifest-Ansicht ziehen und somit Ressource-Referenzen darauf erzeugen. Da diese scheinbar gleichen Knoten eine jeweils unterschiedliche Identifikation besitzen, ist dies zulässig, wenn auch für den normalen Gebrauch wenig sinnvoll.

2.4.4.1.2. Ressource-Referenz-Knoten manuell erstellen

Um einen Ressource-Referenz-Knoten manuell zu erstellen müssen Sie folgende Aktionen durchführen:

  1. Wählen Sie in der Manifestansicht den Ressource-Referenzen-Knoten mittels Mausklick auf dessen Namen bzw. Symbol.

  2. Betätigen Sie die rechte Maustaste; es öffnet sich das Kontextmenü.

  3. Wählen Sie im Kontextmenü den Menüeintrag Erstelle Knoten 'Ressource-Referenz'.

Ressource-Referenz-Knoten manuell erstellen.

Abbildung 2.107. Ressource-Referenz-Knoten manuell erstellen.

Es wird ein neuer Ressource-Referenz-Knoten am Ende einer eventuell vorhandenen Liste von Ressource-Referenz-Knoten angelegt. Da er noch keine Ressource referenziert, wird als Name seine Identifikation in der Form RES-XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX angezeigt. Für eine Erklärung, wie man eine Ressource referenziert siehe Abschnitt 2.4.4.4, „Speicherposition der Ressource festlegen“.


2.4.4.2. Typ der referenzierten Ressource angeben

Bei einer Ressource-Referenz ist es möglich, den Typ der referenzierten Ressource anzugeben. Dies ist üblicherweise nicht nötig, da der voreingestellte Wert webcontent für die meisten Anwendungen geeignet ist und nicht verändert werden soll. jCAPT bietet im Eingabefeld für den Typ eine Auswahl von nach dem Standard gültigen Werten:

  • webcontent: Inhalt, der in einem Browser dargestellt werden kann (das umfasst HTML-basierten Inhalt und jenen, welcher ein Plug-In benötigt, wie beispielsweise Flash, Real Media und Applets).

  • imsldcontent: Inhalt, welcher im Rahmen der IMS Learning Design-Spezifikation benutzt wird.

  • other: wenn kein anderer Typ geeignet ist.

Darüber hinaus wird auch die Eingabe von nicht in dieser Auswahlliste vorhandenen Werten unterstützt. Für diese Werte kann die Standardkonformität jedoch nicht garantiert werden, weshalb davon abzuraten ist, sie zu verwenden.

Um den Typ der referenzierten Ressource anzugeben müssen Sie folgende Aktionen durchführen:

  1. Wählen Sie den Ressource-Referenz-Knoten in der Manifest-Ansicht durch einen Mausklick auf dessen Namen bzw. Symbol.

  2. Aktivieren Sie das Eingabefeld für den Wert des Attributs Typ durch einen einfachen Mausklick.

  3. Öffnen Sie durch einen Klick auf die erscheinende Schaltfläche mit dem nach unten gerichteten Dreieck das Auswahlfeld und wählen Sie einen Eintrag oder geben Sie den gewünschten Wert über die Tastatur ein.

  4. Schließen Sie die Eingabe durch einen Klick auf eine Position außerhalb des Eingabefeldes ab.

Typ der referenzierten Ressource angeben.

Abbildung 2.108. Typ der referenzierten Ressource angeben.


2.4.4.3. Basispfad/-URL für relative Speicherpositionen für eine Ressource-Referenz festlegen

Über den Ressource-Referenz-Knoten kann man für diese Ressource-Referenz und untergeordnete Abhängigkeit (Datei/URL)-Knoten den Basispfad/die Basis-URL für relative Speicherpositionen festlegen. Diese Angabe wird zusammen mit im Ressource-Referenz-Knoten und den Abhängigkeit (Datei/URL)-Knoten vorkommenden relativen Speicherpositionen verwendet, um den tatsächlichen Ort der Ressourcen festzulegen. Zu diesem Zweck wird bei der Anzeige des CPS-Pakets der Basispfad/die Basis-URL der in Unterknoten vorhandenen jeweiligen relativen Angabe einer Speicherposition vorangestellt. Für eine genaue Beschreibung der Berechnung anhand von Beispielen siehe Kapitel 2, Berechnung der Speicherposition von Ressourcen.

[Tipp] Tipp

Verwenden Sie immer relative Basispfade, welche nicht auf Positionen oberhalb des Basisordners verweisen. So können Sie sicherstellen, dass das Lernpaket auch auf anderen Rechnern korrekt angezeigt wird. Andernfalls könnten Dateien referenziert werden, welche beim Export des CPS-Pakets nicht berücksichtigt werden.

Um den Basispfad bzw. die Basis-URL für relative Speicherpositionen für eine Ressource-Referenz festzulegen müssen Sie folgende Aktionen durchführen:

  1. Wählen Sie den Ressource-Referenz-Knoten in der Manifest-Ansicht durch einen Mausklick auf dessen Namen bzw. Symbol.

  2. Aktivieren Sie das Eingabefeld für den Wert des Attributs Basispfad/-URL durch einen Doppelklick.

  3. Geben Sie den Basispfad bzw. die Basis-URL ein.

  4. Schließen Sie die Eingabe durch Betätigen der Eingabetaste ab.

Basispfad/-URL für relative Speicherpositionen für eine Ressource-Referenz festlegen.

Abbildung 2.109. Basispfad/-URL für relative Speicherpositionen für eine Ressource-Referenz festlegen.

[Anmerkung] Anmerkung

Ist in einem übergeordneten Knoten (z.B. Ressource-Referenzen oder Manifest) ebenfalls ein Basispfad/eine Basis-URL angegeben, so wird diese Einstellung von jener im Ressource-Referenz-Knoten überschrieben.


2.4.4.4. Speicherposition der Ressource festlegen

Die Hauptaufgabe einer Ressource-Referenz ist der Verweis auf eine Ressource. Zu diesem Zweck muss ihre Speicherposition angegeben werden. Dies kann sowohl über einen Dateipfad als auch eine URL geschehen. Unterstützt werden hierbei einerseits absolute (z.B. file:/D:/Pakete/Italien/Rom.jpg oder http://www.lernen.at/images/logo.gif) und andererseits relative Positionsangaben (z.B. sinus.html oder kapitel3/vektoren.pdf). Zu berücksichtigen sind hierbei außerdem noch eventuell eingestellte Basispfade bzw. Basis-URLs. Diese können manifestweit (siehe Abschnitt 2.4.2.1, „Basispfad/-URL für relative Speicherpositionen für das gesamte Manifest festlegen“), für die gesamten Ressource-Referenzen (siehe Abschnitt 2.4.3.1, „Basispfad/-URL für relative Speicherpositionen für alle Ressource-Referenzen festlegen“) und auch für eine einzige Ressource-Referenz (siehe Abschnitt 2.4.4.3, „Basispfad/-URL für relative Speicherpositionen für eine Ressource-Referenz festlegen“) angegeben sein.

[Tipp] Tipp

Verwenden Sie für den Verweis auf Dateien immer relative Positionsangaben, welche nicht auf Positionen oberhalb des Basisordners verweisen. So können Sie sicherstellen, dass das Lernpaket auch auf anderen Rechnern korrekt angezeigt wird. Andernfalls könnten Dateien referenziert werden, welche beim Export des CPS-Pakets nicht berücksichtigt werden.

Um für eine Ressource-Referenz die Speicherposition der Ressource feszulegen müssen Sie folgende Aktionen durchführen:

  1. Wählen Sie den Ressource-Referenz-Knoten in der Manifest-Ansicht durch einen Mausklick auf dessen Namen bzw. Symbol.

  2. Aktivieren Sie das Eingabefeld für den Wert des Attributs Speicherposition durch einen Doppelklick.

  3. Geben Sie die Speicherposition ein.

  4. Schließen Sie die Eingabe durch Betätigen der Eingabetaste ab.

Speicherposition der Ressource festlegen.

Abbildung 2.110. Speicherposition der Ressource festlegen.


2.4.5. Abhängigkeit (Datei/URL)

Abhängigkeit (Datei/URL)-Knoten geben Abhängigkeiten an, die für die korrekte Anzeige einer referenzierten Ressource erfüllt sein müssen. Sie bennenen jene Datei(en)/URLs, die eine Ressource bei ihrer Darstellung benötigt. So können zu einem Ressource-Referenz-Knoten, welcher auf eine HTML-Datei verweist, zusätzlich Abhängigkeit (Datei/URL)-Knoten angegeben werden, die in der HTML-Datei verwendete Bilder, Stylesheets und Skripts referenzieren. Darüber hinaus müssen in gültigen CPS-Paketen Ressource-Referenz-Knoten auch für ihre referenzierte Ressource einen Abhängigkeit (Datei/URL)-Knoten besitzen.

Die Abhängigkeit (Datei/URL)-Knoten liegen direkt unterhalb eines Ressource-Referenz-Knotens. Sie dürfen nur dort im Manifest liegen und nicht geschachtelt werden. Abhängigkeit (Datei/URL)-Knoten können in die Zwischenablage ausgeschnitten bzw. kopiert, und aus dieser wieder eingefügt werden. Sie können auch zwischen Ressource-Referenz-Knoten mittels Drag-and-Drop kopiert und verschoben werden. Da ihre Reihenfolge keine Auswirkung auf die Anzeige des Pakets hat, macht eine Änderung der Reihenfolge nur bei einer dadurch erzielten Verbesserung der Wartbarkeit einen Sinn.

Sie finden die Abhängigkeit (Datei/URL)-Knoten unterhalb der Ressource-Referenz-Knoten in der Manifestansicht im rechten Fensterbereich von jCAPT. Wurde für eine Abhängigkeit bereits eine Speicherposition angegeben, so wird sie als Name des Knotens verwendet. Ansonsten wird der symbolische Name Abhängigkeit (Datei/URL) angezeigt.

Abbildung 2.111. Abhängigkeit (Datei/URL)-Knoten.


2.4.5.1. Abhängigkeit (Datei/URL)-Knoten erstellen

Zusätzlich zu jedem Ressource-Referenz-Knoten müssen Abhängigkeit (Datei/URL)-Knoten für die Ressource selbst und deren Abhängigkeiten erstellt werden. Es gibt keine theoretische Grenze, wieviel Knoten dieser Art erstellt werden können. Die Anzahl ist lediglich durch den verfügbaren Speicherplatz, sowohl im Hauptspeicher als auch auf dem Datenträger beschränkt.

Abhängigkeit (Datei/URL)-Knoten können auf drei Arten erstellt werden:

  • indirekt beim Erstellen eines Inhalt-Knotens mittels Drag-and-Drop (siehe Abschnitt 2.4.9.1.1, „Inhalt-Knoten mittels Drag-and-Drop erstellen“)

  • indirekt beim Erstellen eines Ressource-Referenz-Knotens mittels Drag-and-Drop (siehe Abschnitt 2.4.4.1.1, „Ressource-Referenz-Knoten mittels Drag-and-Drop erstellen“)

  • mittels Drag-and-Drop einer Ressource

  • manuell mit anschließender Angabe der Speicherposition

[Anmerkung] Anmerkung

Da URLs keine Entsprechung in der Ressourcensammlung haben, können sie nur nur durch manuelle Erstellung eines Abhängigkeit (Datei/URL)-Knoten und anschließender Angabe der Speicherposition als Abhängigkeit definiert werden.

2.4.5.1.1. Abhängigkeit (Datei/URL)-Knoten mittels Drag-and-Drop erstellen

Um einen Abhängigkeit (Datei/URL)-Knoten mittels Drag-and-Drop einer Ressource zu erstellen müssen Sie folgende Aktionen durchführen:

  1. Wählen Sie in der Ressourcensammlung jene Ressource, für welche eine Abhängigkeit zu erstellen ist, mittels Mausklick auf deren Namen bzw. Symbol.

  2. Beginnen Sie die Maus mit gedrückter linker Maustaste zu ziehen. Der Mauszeiger verändert sich und zeigt an, dass der Verweis auf die Ressource übertragen wird.

  3. Ziehen Sie den Mauszeiger mit weiterhin gedrückter Maustaste über jenen Ressource-Referenz-Knoten, für den die Abhängigkeit gelten soll.

  4. Lassen Sie die Maustaste los.

[Tipp] Tipp

Wenn Sie bei noch gedrückter Maustaste die Taste Esc betätigen, wird der Drag-and-Drop-Vorgang abgebrochen.

Abhängigkeit (Datei/URL)-Knoten mittels Drag-and-Drop erstellen.

Abbildung 2.112. Abhängigkeit (Datei/URL)-Knoten mittels Drag-and-Drop erstellen.

Es wird ein neuer Abhängigkeit (Datei/URL)-Knoten am Ende einer eventuell vorhandenen Liste von gleichartigen Knoten angelegt und die gewählte Ressource als Abhängigkeit vermerkt.

2.4.5.1.2. Abhängigkeit (Datei/URL)-Knoten manuell erstellen

Um einen Abhängigkeit (Datei/URL)-Knoten manuell zu erstellen müssen Sie folgende Aktionen durchführen:

  1. Wählen Sie in der Manifestansicht den Ressource-Referenz-Knoten, für welchen Sie die Abhängigkeit definieren wollen, mittels Mausklick auf dessen Namen bzw. Symbol.

  2. Betätigen Sie die rechte Maustaste; es öffnet sich das Kontextmenü.

  3. Wählen Sie im Kontextmenü den Menüeintrag Erstelle Knoten 'Abhängigkeit (Datei/URL)'.

Abhängigkeit (Datei/URL)-Knoten manuell erstellen.

Abbildung 2.113. Abhängigkeit (Datei/URL)-Knoten manuell erstellen.

Es wird ein neuer Abhängigkeit (Datei/URL)-Knoten am Ende einer eventuell vorhandenen Liste von Abhängigkeit (Datei/URL)-Knoten angelegt. Da er noch keine Ressource referenziert, wird als Name die symbolische Bezeichnung Abhängigkeit (Datei/URL) angezeigt.


2.4.5.2. Speicherposition der abhängigen Datei/URL festlegen

Um eine abhängige Ressource zu benennen muss ihre Speicherposition angegeben werden. Dies kann sowohl über einen Dateipfad als auch eine URL geschehen. Unterstützt werden hierbei einerseits absolute (z.B. file:/D:/Pakete/Italien/Rom.jpg oder http://www.lernen.at/images/logo.gif) und andererseits relative Positionsangaben (z.B. sinus.html oder kapitel3/vektoren.pdf). Zu berücksichtigen sind hierbei außerdem noch eventuell eingestellte Basispfade bzw. Basis-URLs. Diese können manifestweit (siehe Abschnitt 2.4.2.1, „Basispfad/-URL für relative Speicherpositionen für das gesamte Manifest festlegen“), für die gesamten Ressource-Referenzen (siehe Abschnitt 2.4.3.1, „Basispfad/-URL für relative Speicherpositionen für alle Ressource-Referenzen festlegen“) und auch für eine einzige Ressource-Referenz (siehe Abschnitt 2.4.4.3, „Basispfad/-URL für relative Speicherpositionen für eine Ressource-Referenz festlegen“) angegeben sein.

[Tipp] Tipp

Verwenden Sie für den Verweis auf Dateien immer relative Positionsangaben, welche nicht auf Positionen oberhalb des Basisordners verweisen. So können Sie sicherstellen, dass das Lernpaket auch auf anderen Rechnern korrekt angezeigt wird. Andernfalls könnten Dateien referenziert werden, welche beim Export des CPS-Pakets nicht berücksichtigt werden.

Um für eine Abhängigkeit die Speicherposition der Ressource festzulegen müssen Sie folgende Aktionen durchführen:

  1. Wählen Sie den Abhängigkeit (Datei/URL)-Knoten in der Manifest-Ansicht durch einen Mausklick auf dessen Namen bzw. Symbol.

  2. Aktivieren Sie das Eingabefeld für den Wert des Attributs Speicherposition durch einen Doppelklick.

  3. Geben Sie die Speicherposition ein.

  4. Schließen Sie die Eingabe durch Betätigen der Eingabetaste ab.

Speicherposition der abhängigen Datei/URL festlegen.

Abbildung 2.114. Speicherposition der abhängigen Datei/URL festlegen.


2.4.6. Abhängigkeit (Ressource-Referenz)

Abhängigkeit (Ressource-Referenz)-Knoten geben Abhängigkeiten an, die für die korrekte Anzeige einer referenzierten Ressource erfüllt sein müssen. Diese Abhängigkeiten bennenen sie über eine Ressource-Referenz. Die referenzierte Ressource dieser Ressource-Referenz und ihre Abhängigkeiten werden hierbei als Abhängigkeiten verwendet. Man kann dies unter anderem zur Wiederverwendung von Abhängigkeitsgruppen verwenden.

Verwendet beispielsweise eine Menge von HTML-Seiten ein gemeinsames Stylesheet, welches diverse Bilder (z.B. für den Hintergrund) referenziert, so kann für dieses Stylesheet eine Ressource-Referenz angelegt werden. Die Bilder könnte man mit dieser Ressource-Referenz untergeordneten Abhängigkeit (Datei/URL)-Knoten referenzieren. Bei den einzelnen HTML-Seiten müsste man zur Angabe dieser Abhängigkeitsgruppe nur mehr die Ressource-Referenz des Stylesheets über einen Abhängigkeit (Ressource-Referenz)-Knoten referenzieren.

Die Abhängigkeit (Ressource-Referenz)-Knoten liegen direkt unterhalb eines Ressource-Referenz-Knotens. Sie dürfen nur dort im Manifest liegen und nicht geschachtelt werden. Abhängigkeit (Ressource-Referenz)-Knoten können in die Zwischenablage ausgeschnitten bzw. kopiert, und aus dieser wieder eingefügt werden. Sie können auch zwischen Ressource-Referenz-Knoten mittels Drag-and-Drop kopiert und verschoben werden. Da ihre Reihenfolge keine Auswirkung auf die Anzeige des Pakets hat, macht eine Änderung der Reihenfolge nur bei einer dadurch erzielten Verbesserung der Wartbarkeit einen Sinn.

Sie finden die Abhängigkeit (Ressource-Referenz)-Knoten unterhalb der Ressource-Referenz-Knoten in der Manifestansicht im rechten Fensterbereich von jCAPT. Wurde für eine Abhängigkeit bereits eine Ressource-Referenz angegeben, so wird deren Name als Name des Knotens verwendet. Ansonsten wird der symbolische Name Abhängigkeit (Ressource-Referenz) angezeigt.

Abbildung 2.115. Abhängigkeit (Ressource-Referenz)-Knoten.


2.4.6.1. Abhängigkeit (Ressource-Referenz)-Knoten erstellen

Um anzugeben, dass eine referenzierte Ressource von einer anderen referenzierten Ressource und ihren Abhängigkeiten abhängt muss man einen Abhängigkeit (Ressource-Referenz)-Knoten erstellen. Hierbei gibt es keine theoretische Grenze, wieviel Knoten dieser Art erstellt werden können. Die Anzahl ist lediglich durch den verfügbaren Speicherplatz, sowohl im Hauptspeicher als auch auf dem Datenträger beschränkt.

Abhängigkeit (Ressource-Referenz)-Knoten können auf zwei Arten erstellt werden:

  • mittels Drag-and-Drop einer Ressource-Referenz

  • manuell mit anschließendem Verweisen auf die Ressource-Referenz

2.4.6.1.1. Abhängigkeit (Ressource-Referenz)-Knoten mittels Drag-and-Drop erstellen

Um einen Abhängigkeit (Ressource-Referenz)-Knoten mittels Drag-and-Drop einer Ressource-Referenz zu erstellen müssen Sie folgende Aktionen durchführen:

  1. Wählen Sie in der Manifestansicht den Ressource-Referenz-Knoten, den Sie als Abhängigkeit definieren wollen, mittels Mausklick auf dessen Namen bzw. Symbol.

  2. Beginnen Sie die Maus mit gedrückter linker Maustaste zu ziehen. Der Mauszeiger verändert sich und zeigt an, dass der Verweis auf die Ressource übertragen wird.

  3. Ziehen Sie den Mauszeiger mit weiterhin gedrückter Maustaste über den Ressource-Referenzen-Knoten, für den Sie die Abhängigkeit festlegen wollen.

  4. Lassen Sie die Maustaste los.

[Tipp] Tipp

Wenn Sie bei noch gedrückter Maustaste die Taste Esc betätigen, wird der Drag-and-Drop-Vorgang abgebrochen.

Abhängigkeit (Ressource-Referenz)-Knoten mittels Drag-and-Drop erstellen.

Abbildung 2.116. Abhängigkeit (Ressource-Referenz)-Knoten mittels Drag-and-Drop erstellen.

Es wird ein neuer Abhängigkeit (Ressource-Referenz)-Knoten am Ende einer eventuell vorhandenen Liste von Abhängigkeit (Ressource-Referenz)-Knoten angelegt und auf die gewählte Ressource-Referenz verwiesen.

2.4.6.1.2. Abhängigkeit (Ressource-Referenz)-Knoten manuell erstellen

Um einen Abhängigkeit (Ressource-Referenz)-Knoten manuell zu erstellen müssen Sie folgende Aktionen durchführen:

  1. Wählen Sie in der Manifestansicht den Ressource-Referenz-Knoten, für welchen Sie die Abhängigkeit definieren wollen, mittels Mausklick auf dessen Namen bzw. Symbol.

  2. Betätigen Sie die rechte Maustaste; es öffnet sich das Kontextmenü.

  3. Wählen Sie im Kontextmenü den Menüeintrag Erstelle Knoten 'Abhängigkeit (Ressource-Referenz)'.

Abhängigkeit (Ressource-Referenz)-Knoten manuell erstellen.

Abbildung 2.117. Abhängigkeit (Ressource-Referenz)-Knoten manuell erstellen.

Es wird ein neuer Abhängigkeit (Ressource-Referenz)-Knoten am Ende einer eventuell vorhandenen Liste von Abhängigkeit (Ressource-Referenz)-Knoten angelegt. Da er noch auf keine Ressource-Referenz verweist, wird als Name die symbolische Bezeichnung Abhängigkeit (Ressource-Referenz) angezeigt.


2.4.6.2. Verweis auf abhängige Ressource-Referenz legen

Um den Verweis auf die abhängige Ressource-Referenz zu legen müssen Sie folgende Aktionen durchführen:

  1. Wählen Sie den Abhängigkeit (Ressource-Referenz)-Knoten in der Manifest-Ansicht durch einen Mausklick auf dessen Namen bzw. Symbol.

  2. Aktivieren Sie das Eingabefeld für den Wert des Attributs Referenzierte Ressource durch einen Doppelklick. Es erscheint ein Dialog, in dem Sie die Ressource-Referenz auswählen können.

    Verweis auf abhängige Ressource-Referenz legen.

    Abbildung 2.118. Verweis auf abhängige Ressource-Referenz legen.

  3. Wählen Sie die abhängige Ressource-Referenz durch einen Klick auf ihren Namen.

    Auswahl der abhängigen Ressource-Referenz.

    Abbildung 2.119. Auswahl der abhängigen Ressource-Referenz.

  4. Übernehmen Sie die Eingabe und schließen Sie den Dialog durch Betätigen der Schaltfläche OK. Ein Klick auf Abbrechen schließt den Dialog ohne die Auswahl zu ändern.


2.4.6.3. Ressource-Referenz-Knoten anzeigen

Damit man nicht händisch nach der Ressource-Referenz, auf die verwiesen wird, suchen muss, kann man diese ausgehend vom Abhängigkeit (Ressource-Referenz)-Knoten finden und markieren lassen.

Um den Ressource-Referenz-Knoten anzuzeigen müssen Sie folgende Aktionen durchführen:

  1. Wählen Sie in der Manifestansicht den Abhängigkeit (Ressource-Referenz)-Knoten, für welchen Sie die Ressource-Referenz anzeigen wollen, mittels Mausklick auf dessen Namen bzw. Symbol.

  2. Betätigen Sie die rechte Maustaste; es öffnet sich das Kontextmenü.

  3. Wählen Sie im Kontextmenü den Menüeintrag Ressource-Referenz anzeigen'.

Abbildung 2.120. Ressource-Referenz-Knoten anzeigen

Wenn der Abhängigkeit (Ressource-Referenz)-Knoten auf eine gültige und existierende Ressource-Referenz verweist, so wird diese in der Folge markiert.


2.4.7. Organisationen

Eine der Hauptaufgaben eines Manifests ist die Festlegung einer Struktur für die einzelnen Ressourcen. Eine Organisation definiert solch eine Struktur und verweist auf eine Auswahl aus den Ressourcen. Es ist vorgesehen, dass mehrere Organisationen existieren können um inhaltlich gleiche aber von der Präsentation verschiedene Darstellungen des Lerninhalts zu bieten. Diese einzelnen Organisationen sind im Organisationen-Knoten zusammengefasst.

Der Organisationen-Knoten liegt direkt unterhalb des Manifest-Knotens und darf nur an dieser Stelle und nur ein Mal im gesamten Manifest vorkommen. Aus diesem Grund dürfen Sie ihn weder kopieren noch ausschneiden, verschieben oder löschen. Die Schaltflächen, Menüeinträge und Tastenkombinationen um diese Operationen auszuführen sind für den Organisationen-Knoten deaktiviert. Man kann ihn auch nicht nach unten oder oben verschieben, da es keinen gleichartigen Knoten gibt, mit dem er in der Position vertauscht werden könnte.

Sie finden den Organisationen-Knoten unterhalb des Manifest-Knotens in der Manifestansicht im rechten Fensterbereich von jCAPT. Er hat die unveränderliche Bezeichnung Organisationen.

Abbildung 2.121. Organisationen-Knoten.

Der Organisationen-Knoten wird beim Erstellen des CPS-Pakets (siehe Abschnitt 2.2.1, „Neues CPS-Paket erstellen“) erzeugt. Er bietet neben seiner Eigenschaft als gemeinsamer Vaterknoten aller Organisationen des Manifests auch die Möglichkeit die Standard-Organisation festzulegen (siehe Abschnitt 2.4.7.1, „Standard-Organisation festlegen“).


2.4.7.1. Standard-Organisation festlegen

Für den Fall, dass im Manifest mehrere Organisationen vorhanden sind, muss die Anwendung, welche das CPS-Paket anzeigt, entscheiden, welche sie davon darstellt. Verfügt die Anwendung über keine Möglichkeit zur Auswahl der anzuzeigenden Organisation wird sie die Standard-Organisation darstellen. Diese kann über den Organisationen-Knoten gesetzt werden.

Um die Standard-Organisation festzulegen müssen Sie folgende Aktionen durchführen:

  1. Wählen Sie den Organisationen-Knoten in der Manifest-Ansicht durch einen Mausklick auf dessen Namen bzw. Symbol.

  2. Aktivieren Sie das Eingabefeld für den Wert des Attributs Standardorganisation durch einen Doppelklick. Es erscheint ein Dialog, in dem Sie die Organisation auswählen können.

    Abbildung 2.122. Standard-Organisation festlegen.

  3. Wählen Sie die Organisation durch einen Klick auf ihren Namen.

    Auswahl der Standard-Organisation.

    Abbildung 2.123. Auswahl der Standard-Organisation.

  4. Übernehmen Sie die Eingabe und schließen Sie den Dialog durch Betätigen der Schaltfläche OK. Ein Klick auf Abbrechen schließt den Dialog ohne die Auswahl zu ändern.

[Achtung] Achtung

Wenn die gewählte Standard-Organisation später ausgeschnitten oder gelöscht wird, so wird der Verweis auf sie nicht entfernt. In diesem Fall muss er händisch neu gesetzt werden.


2.4.8. Organisation

Unter einer Organisation versteht man eine konkrete Auswahl und Strukturierung von Ressourcen eines CPS-Pakets durch das Manifest. Die Organisation dient hierbei nur als Behälter für die einzelnen Inhalt-Knoten, welche die Struktur festlegen. Es dürfen durchaus mehr als eine Organisation in einem CPS-Paket vorhanden sein. In diesem Fall sollten sie alle den gleichen Inhalt aber in verschiedenen Ausprägungen vermitteln. So könnte beispielsweise Inhalt in einer Organisation mit traditionellem Text, in einer zweiten durch ein interaktives Spiel und in der dritten mittels eines Hörtexts präsentiert werden.

Die Organisation-Knoten liegen direkt unterhalb des Organisationen-Knotens. Sie dürfen nur dort im Manifest liegen und nicht geschachtelt werden. Organisation-Knoten können in die Zwischenablage ausgeschnitten bzw. kopiert, und aus dieser wieder eingefügt werden. Da sie flach und ohne jede Hierarchie im Manifest liegen, macht ein Verschieben bzw. Kopieren mittes Drag-and-Drop innerhalb des Manifests keinen Sinn, weshalb diese Operationen nicht verfügbar sind.

[Achtung] Achtung

Beim Einfügen eines in die Zwischenablage kopierten Organisation-Knotens wird dessen Identifikation automatisch neu berechnet. Dies ist nötig, damit keine zwei Knoten jemals die selbe Identifikation aufweisen. Da die Auswahl der Standard-Organisation über diese Identifikation läuft, ist hierbei zu beachten, dass diese Auswahl dann eventuell ungültig werden kann, weil sie auf eine nicht vorhandene Organisation verweist.

Für den Fall, dass mehrere Organisation-Knoten exisitieren, kann deren Reihenfolge verändert werden. Dies kann nötig sein, wenn keine Standard-Organisation angegeben ist. Die meisten Anwendungen zum Anzeigen von CPS-Paketen wählen dann nämlich die erste Organisation zur Darstellung.

Sie finden die Organisation-Knoten unterhalb des Organisationen-Knotens in der Manifestansicht im rechten Fensterbereich von jCAPT. Wurde die Organisation bereits mit einem Titel versehen, so wird dieser als ihr angezeigter Name verwendet. Ansonsten wird der symbolische Bezeichner Organisation angezeigt.

Abbildung 2.124. Organisation-Knoten.


2.4.8.1. Organisation-Knoten erstellen

Bevor mit dem Aufbau einer inhaltlichen Struktur des CPS-Pakets begonnen werden kann, muss zuerst ein Organisation-Knoten angelegt werden. Dieser fungiert als Behälter für die einzelnen Inhalt-Knoten und gibt der Strukturierung gleichzeitig einen Namen.

Organisation-Knoten können auf drei Arten erstellt werden:

  • indirekt beim Erstellen eines Inhalt-Knotens mittels Drag-and-Drop (siehe Abschnitt 2.4.9.1.1, „Inhalt-Knoten mittels Drag-and-Drop erstellen“)

  • manuell mit anschließendem Benennen

Um einen Organisation-Knoten manuell zu erstellen müssen Sie folgende Aktionen durchführen:

  1. Wählen Sie in der Manifestansicht den Organisationen-Knoten mittels Mausklick auf dessen Namen bzw. Symbol.

  2. Betätigen Sie die rechte Maustaste; es öffnet sich das Kontextmenü.

    Organisation-Knoten manuell erstellen.

    Abbildung 2.125. Organisation-Knoten manuell erstellen.

  3. Wählen Sie im Kontextmenü den Menüeintrag Erstelle Knoten 'Organisation'. Es öffnet sich ein Dialog, in dem Sie den Namen des neu zu erstellenden Organisation-Knotens angeben können.

    Neuen Organisation-Knoten benennen.

    Abbildung 2.126. Neuen Organisation-Knoten benennen.

  4. Geben Sie den Namen des neu zu erstellenden Organisation-Knotens ein.

  5. Betätigen Sie die Schaltfläche OK um den Organisation-Knoten mit dem angegebenen Namen zu erstellen. Wenn Sie Abbrechen wählen wird der neue Organisation-Knoten nicht mit einem Namen versehen.

Es wird ein neuer Organisation-Knoten am Ende einer eventuell vorhandenen Liste von Organisation-Knoten angelegt. Er trägt den angegebenen Namen bzw. die symbolische Bezeichnung Organisation, wenn kein Name angegeben wurde.


2.4.8.2. Organisation-Knoten umbenennen

Um einen Organisation-Knoten umzubenennen müssen Sie folgende Aktionen durchführen:

  1. Wählen Sie in der Manifestansicht den Organisation-Knoten, den Sie umbenennen möchten, mittels Mausklick auf dessen Namen bzw. Symbol.

  2. Ändern Sie den Namen in dem Feld unter der Beschriftung Titel im Bereich unter der Manifestansicht.

Abbildung 2.127. Organisation-Knoten umbenennen.


2.4.8.3. Inhaltsstrukturierung einer Organisation festlegen

Standardmäßig ist für die Inhaltsstrukturierung von Organisation-Knoten der Wert hierarchical festgelegt. Dieser Wert ist der einzige, der derzeit für CPS-Pakete unterstützt wird und sollte nicht verändert werden. Nichtsdestotrotz ist eine Änderung für Ausnahmefälle möglich, wenn auch nicht angeraten.

Um für eine Organisation die Inhaltsstrukturierung festzulegen müssen Sie folgende Aktionen durchführen:

  1. Wählen Sie den Organisation-Knoten, für den Sie die Inhaltsstrukturierung festlegen wollen, durch einen Mausklick auf dessen Namen bzw. Symbol.

  2. Aktivieren Sie das Eingabefeld für den Wert des Attributs Inhaltsstrukturierung durch einen Doppelklick.

  3. Geben Sie den gewünschten Wert ein.

  4. Schließen Sie die Eingabe durch Betätigen der Eingabetaste ab.

Inhaltsstrukturierung einer Organisation festlegen.

Abbildung 2.128. Inhaltsstrukturierung einer Organisation festlegen.


2.4.9. Inhalt

Mit Inhalt-Knoten wird in einem CPS-Paket die Strukturierung und Auswahl der zu präsentierenden Ressourcen festgelegt. Jeder Inhalt-Knoten hat einen Titel und verweist auf eine Ressource-Referenz, mithilfe derer er eine Ressource bindet. Geschachtelt angeordnet ergibt sich so eine Hierarchie von benannten Verweisen auf Ressourcen.

Die Inhalt-Knoten liegen direkt unterhalb eines Organisation-Knotens. Sie dürfen nur dort im Manifest liegen und können in sich geschachtelt werden. Inhalt-Knoten können in die Zwischenablage ausgeschnitten bzw. kopiert, und aus dieser wieder eingefügt werden. Sie können auch zwischen Organisation-Knoten bzw. als Kind-Knoten von anderen Inhalt-Knoten mittels Drag-and-Drop kopiert und verschoben werden. Da es sich um den bei der Anzeige des CPS-Pakets sichtbaren Teil handelt, ist die Reihenfolge von Inhalt-Knoten relevant. Sie können deshalb in Bezug auf andere Inhalt-Knoten nach oben bzw. unten verschoben werden.

Sie finden die Inhalt-Knoten unterhalb der Organisation-Knoten in der Manifestansicht im rechten Fensterbereich von jCAPT. Wurde ein Inhalt-Knoten bereits mit einem Titel versehen, so wird dieser als sein angezeigter Name verwendet. Ansonsten wird der symbolische Bezeichner Inhalt angezeigt.

Abbildung 2.129. Inhalt-Knoten.


2.4.9.1. Inhalt-Knoten erstellen

Zur Festlegung der Struktur, in welcher die Ressourcen bei der Anzeige des CPS-Pakets organisiert werden sollen, muss man Inhalt-Knoten erstellen. Hierbei gibt es keine theoretische Grenze, wieviel Knoten dieser Art erstellt werden können. Die Anzahl ist lediglich durch den verfügbaren Speicherplatz, sowohl im Hauptspeicher als auch auf dem Datenträger beschränkt.

Inhalt-Knoten können auf drei Arten erstellt werden:

  • mittels Drag-and-Drop einer Ressource

  • mittels Drag-and-Drop einer Ressource-Referenz

  • manuell mit anschließendem Verweisen auf die Ressource-Referenz

2.4.9.1.1. Inhalt-Knoten mittels Drag-and-Drop erstellen

Um einen Inhalt-Knoten mittels Drag-and-Drop zu erstellen müssen Sie folgende Aktionen durchführen:

  1. Wählen Sie in der Ressourcensammlung jene Ressource bzw. in der Manifestansicht jene Ressource-Referenz, für welche der Inhalt-Knoten zu erstellen ist, mittels Mausklick auf deren Namen bzw. Symbol.

  2. Beginnen Sie die Maus mit gedrückter linker Maustaste zu ziehen. Der Mauszeiger verändert sich und zeigt an, dass der Verweis auf die Ressource übertragen wird.

  3. Ziehen Sie den Mauszeiger mit weiterhin gedrückter Maustaste über den Organisation- bzw. Inhalt-Knoten, als dessen Kindknoten Sie den neuen Inhalt-Knoten anlegen wollen.

  4. Lassen Sie die Maustaste los.

[Tipp] Tipp

Wenn Sie bei noch gedrückter Maustaste die Taste Esc betätigen, wird der Drag-and-Drop-Vorgang abgebrochen.

Inhalt-Knoten mittels Drag-and-Drop einer Ressource erstellen.

Abbildung 2.130. Inhalt-Knoten mittels Drag-and-Drop einer Ressource erstellen.

Inhalt-Knoten mittels Drag-and-Drop einer Ressource-Referenz erstellen.

Abbildung 2.131. Inhalt-Knoten mittels Drag-and-Drop einer Ressource-Referenz erstellen.

Das Ergebnis dieser Aktion ist weitreichend: Wurde eine Ressource bei der Drag-and-Drop Operation verwendet, so wird zuerst als Kinde des Ressource-Referenzen-Knotens ein Ressource-Referenz-Knoten angelegt und die gewählte Ressource referenziert. Zusätzlich wird unterhalb dieses neuen Ressource-Referenz-Knotens zumindest ein Abhängigkeit (Datei/URL)-Knoten für die gewählte Ressource erstellt. Wenn für die Ressource Abhängigkeiten aus ihrem Inhalt abgeleitet werden können (siehe Kapitel 3, Bestimmung der Abhängigkeiten von Ressourcen), so werden für diese ebenfalls Abhängigkeit (Datei/URL)-Knoten erstellt.

Anschließend wird sowohl beim Drag-and-Drop einer Ressource als auch einer Ressource-Referenz ein neuer Inhalt-Knoten als Kindknoten jenes Knotens (Organisation- oder anderer Inhalt-Knoten) angelegt, der Zielknoten der Drag-and-Drop-Aktion war. Von diesem Knoten wird ein Verweis auf die (erstellte) Ressource-Referenz gelegt.

Der Titel dieses neuen Inhalt-Knotens hängt vom Typ und Inhalt der Ressource ab. Handelt es sich um eine HTML-Datei mit der Endung .html bzw. .htm, so wird versucht, den Titel aus dem title-Element der HTML-Quelle zu extrahieren. Wenn dies fehlschlägt oder die Ressource keine HTML-Datei ist, so wird der Name der Ressource ohne etwaige Dateiendungen als Titel des Inhalt-Knotens verwendet.

[Tipp] Tipp

Um eine baumartige Struktur zu erhalten, kann eine Ressource bzw. eine Ressource-Referenz, wie schon erwähnt, nicht nur auf einen Organisation-Knoten gezogen werden, sondern auch auf schon bestehende Inhalt-Knoten innerhalb der Organisation. Der so neu entstehende Inhalt-Knoten wird in diesem Fall als Kindknoten zu dem schon bestehenden erzeugt.

Inhalt-Knoten als Kindknoten mittels Drag-and-Drop erstellen.

Abbildung 2.132. Inhalt-Knoten als Kindknoten mittels Drag-and-Drop erstellen.

[Anmerkung] Anmerkung

Wenn Sie eine Ressource mittels Drag-and-Drop auf den Organisationen-Knoten ziehen, so wird ein neuer Organisation-Knoten mit dem Namen der Ressource und ein Inhalt-Knoten wie oben beschrieben in diesem neuen Organisation-Knoten erstellt. Gleichzeitig wird durch eine Meldung auf diesen Umstand hingewiesen.

Organisation-Knoten indirekt erstellen.

Abbildung 2.133. Organisation-Knoten indirekt erstellen.

2.4.9.1.2. Inhalt-Knoten manuell erstellen

Um einen Inhalt-Knoten manuell zu erstellen müssen Sie folgende Aktionen durchführen:

  1. Wählen Sie in der Manifestansicht den Organisation- bzw. Inhalt-Knoten, als dessen Kindknoten Sie den neuen Inhalt-Knoten anlegen wollen, mittels Mausklick auf dessen Namen bzw. Symbol.

  2. Betätigen Sie die rechte Maustaste; es öffnet sich das Kontextmenü.

    Inhalt-Knoten manuell erstellen.

    Abbildung 2.134. Inhalt-Knoten manuell erstellen.

  3. Wählen Sie im Kontextmenü den Menüeintrag Erstelle Knoten 'Inhalt'. Es öffnet sich ein Dialog, in dem Sie den Namen des neu zu erstellenden Inhalt-Knotens angeben können.

    Neuen Inhalt-Knoten benennen.

    Abbildung 2.135. Neuen Inhalt-Knoten benennen.

  4. Geben Sie den Namen des neu zu erstellenden Inhalt-Knotens ein.

  5. Betätigen Sie die Schaltfläche OK um den Inhalt-Knoten mit dem angegebenen Namen zu erstellen. Wenn Sie Abbrechen wählen wird der neue Inhalt-Knoten nicht mit einem Namen versehen.

Es wird ein neuer Inhalt-Knoten am Ende einer eventuell vorhandenen Liste von Inhalt-Knoten angelegt. Er trägt den angegebenen Namen bzw. die symbolische Bezeichnung Inhalt, wenn kein Name angegeben wurde.


2.4.9.2. Inhalt-Knoten umbenennen

Um einen Inhalt-Knoten umzubenennen müssen Sie folgende Aktionen durchführen:

  1. Wählen Sie in der Manifestansicht den Inhalt-Knoten, den Sie umbenennen möchten, mittels Mausklick auf dessen Namen bzw. Symbol.

  2. Ändern Sie den Namen in dem Feld unter der Beschriftung Titel im Bereich unter der Manifestansicht.

Abbildung 2.136. Inhalt-Knoten umbenennen.


2.4.9.3. Sichtbarkeit eines Inhalt-Knotens festlegen

Für einen Inhalt-Knoten kann man seine Sichtbarkeit beim Anzeigen des CPS-Pakets festlegen. Dies eignet sich besonders zum schnellen Erstellen von speziellen Ausprägungen eines CPS-Pakets. Anstatt hierbei die Inhalt-Knoten zu löschen genügt es, sie unsichtbar zu machen. jCAPT bietet im Eingabefeld für die Sichtbarkeit eine Auswahl von nach dem Standard gültigen Werten:

  • true: der Inhalt-Knoten wird beim Anzeigen des CPS-Pakets angezeigt.

  • false: der Inhalt-Knoten wird beim Anzeigen des CPS-Pakets verborgen.

Darüber hinaus wird auch die Eingabe von nicht in dieser Auswahlliste vorhandenen Werten unterstützt. Für diese Werte kann die Standardkonformität jedoch nicht garantiert werden, weshalb davon abzuraten ist, sie zu verwenden.

[Wichtig] Wichtig

Die Sichtbarkeit wird nicht an untergeordnete Inhalt-Knoten vererbt. Um einen kompletten Zweig der Hierarchie für die Anzeige auszublenden muss die Sichtbarkeit von allen darin enthaltenen Inhalt-Knoten auf false gesetzt werden. Eine Ausnahme bildet hier der Export als Offline-Version. Er unterstützt auch die Vererbung von Sichtbarkeit (siehe Abschnitt 2.8.2.2, „Erweiterte Export-Einstellungen vornehmen“).

Um die Sichtbarkeit eines Inhalt-Knotens festzulegen müssen Sie folgende Aktionen durchführen:

  1. Wählen Sie den Inhalt-Knoten, für den Sie die Sichtbarkeit festlegen wollen, durch einen Mausklick auf dessen Namen bzw. Symbol.

  2. Aktivieren Sie das Eingabefeld für den Wert des Attributs Sichtbar durch einen einfachen Mausklick.

  3. Öffnen Sie durch einen Klick auf die erscheinende Schaltfläche mit dem nach unten gerichteten Dreieck das Auswahlfeld und wählen Sie einen Eintrag oder geben Sie den Wert über die Tastatur ein.

  4. Schließen Sie die Eingabe durch einen Klick auf eine Position außerhalb des Eingabefeldes ab.

Sichtbarkeit eines Inhalt-Knotens festlegen.

Abbildung 2.137. Sichtbarkeit eines Inhalt-Knotens festlegen.


2.4.9.4. Verweis auf Ressource-Referenz legen

Um den Verweis auf die Ressource-Referenz zu legen müssen Sie folgende Aktionen durchführen:

  1. Wählen Sie den Inhalt-Knoten in der Manifest-Ansicht durch einen Mausklick auf dessen Namen bzw. Symbol.

  2. Aktivieren Sie das Eingabefeld für den Wert des Attributs Referenzierte Ressource durch einen Doppelklick. Es erscheint ein Dialog, in dem Sie die Ressource-Referenz auswählen können.

    Verweis auf Ressource-Referenz legen.

    Abbildung 2.138. Verweis auf Ressource-Referenz legen.

  3. Wählen Sie die Ressource-Referenz durch einen Klick auf ihren Namen.

    Auswahl der Ressource-Referenz.

    Abbildung 2.139. Auswahl der Ressource-Referenz.

  4. Übernehmen Sie die Eingabe und schließen Sie den Dialog durch Betätigen der Schaltfläche OK. Ein Klick auf Abbrechen schließt den Dialog ohne die Auswahl zu ändern.


2.4.9.5. Ressource-Referenz-Knoten anzeigen

Damit man nicht händisch nach der Ressource-Referenz, auf die verwiesen wird, suchen muss, kann man diese ausgehend vom Inhalt-Knoten finden und markieren lassen.

Um den Ressource-Referenz-Knoten anzuzeigen müssen Sie folgende Aktionen durchführen:

  1. Wählen Sie in der Manifestansicht den Inhalt-Knoten, für welchen Sie die Ressource-Referenz anzeigen wollen, mittels Mausklick auf dessen Namen bzw. Symbol.

  2. Betätigen Sie die rechte Maustaste; es öffnet sich das Kontextmenü.

  3. Wählen Sie im Kontextmenü den Menüeintrag Ressource-Referenz anzeigen'.

Abbildung 2.140. Ressource-Referenz-Knoten anzeigen

Wenn der Inhalt-Knoten auf eine gültige und existierende Ressource-Referenz verweist, so wird diese in der Folge markiert.


2.4.9.6. Parameter für Laden der Ressource angeben

Für das bei der Anzeige des CPS-Pakets und Auswahl des Inhalt-Knotes nötige Laden der Ressource, auf welche die angegebene Ressource-Referenz verweist, können Parameter angegeben werden. Hierbei gibt es kein festgelegtes Format, doch handelt es sich meist um Parameter, wie sie in URLs verwendet werden. Gibt man beispielsweise für eine HTML-Seite als Parameter #position an, so wird beim Laden der Ressource die Anzeige auf jenen Teil positioniert, der mit dem internen Anker position bezeichnet ist.

Parameter kann man auch für Ressourcen in Form von Webanwendungen nützen. Angenommen, als die verwendete Ressource-Referenz verweist auf die URL http://www.gooogle.com/search. Dies ist die Adresse der Webanwendung zum Suchen bei Google. Ihr kann man eine Menge von Parametern übergeben, unter anderem den Suchtext. Mittels des Parameters ?q=Lernpakete kann man beispielsweise erreichen, dass bei der Wahl dieses Inhalt-Knotens in der Anzeige des CPS-Pakets nach dem Wort Lernpakete auf Google gesucht wird.

Jedes dieser Beispiele hätte man auch durch ein Einbauen der Paramter als Teil der Angabe der Speicherposition in der Ressource-Referenz realisieren können. Der Vorteil von Parametern bei Inhalt-Knoten ist jedoch, dass man ein und die selbe Ressource-Referenz in mehreren Inhalt-Knoten benutzen und jedes Mal verschiedene Parameter verwenden kann. Dies entspricht auch eher dem Konzept von nur einer verwendeten Ressource, welche für unterschiedliche Zwecke parametrisiert wird.

Um Parameter für das Laden der Ressource anzugeben müssen Sie folgende Aktionen durchführen:

  1. Wählen Sie den Inhalt-Knoten, für den Sie die Parameter festlegen wollen, durch einen Mausklick auf dessen Namen bzw. Symbol.

  2. Aktivieren Sie das Eingabefeld für den Wert des Attributs Parameter durch einen Doppelklick.

  3. Geben Sie den gewünschten Wert ein.

  4. Schließen Sie die Eingabe durch Betätigen der Eingabetaste ab.

Parameter für Laden der Ressource angeben.

Abbildung 2.141. Parameter für Laden der Ressource angeben.


2.5. Dateivorschau

2.5.1. Dateivorschau-Fenster anzeigen
2.5.2. Ressourcen in der Dateivorschau anzeigen
2.5.3. Dateivorschau-Fenster verbergen
2.5.4. Ressource in assoziierter Anwendung öffnen

In jCAPT gibt es mehrere Elemente der Anzeige, die einen Bezug zu Ressourcen haben:

  • In der Ressourcen-Sammlung:

    • Ressource-Knoten: als Repräsentation von Dateien und Ordnern

  • In der Manifest-Ansicht:

    • Ressource-Referenz-Knoten: mit einem Verweis auf eine Ressource

    • Abhängigkeit (Datei/URL)-Knoten: mit einem Verweis auf eine Ressource

    • Abhängigkeit (Ressource-Referenz)-Knoten: mit einem Verweis auf einen Ressource-Referenz-Knoten

    • Inhalt-Knoten: mit einem Verweis auf einen Ressource-Referenz-Knoten

Um den Überblick über diese Ressourcen zu behalten verfügt jCAPT über eine integrierte Dateivorschau. Mit ihr kann deren Inhalt betrachtet werden, sofern sie vom richtigen Typ sind. Standardmäßig werden folgende Dateitypen unterstützt:

  • statische Webseiten: .htm, .html

  • Bilder: .gif, .jpg, .jpeg, .png

  • PDFs: .pdf

  • PowerPoint-Präsentationen: .ppt

  • Textdateien: .txt

  • ShockWave-Dateien: .swf

[Tipp] Tipp

Die Liste von Dateitypen, welche in der Vorschau angezeigt werden, kann konfiguriert werden. Eine Beschreibung dazu finden Sie in Abschnitt 1.3, „Einstellungen zu CPS-Paketen“.

Die Vorschau funktioniert auch mit Angaben der Speicherposition in Form von URLs. Verweist die URL auf eine lokale Datei, so muss deren Dateityp unterstützt sein, damit sie angezeigt wird. Handelt es sich um eine nicht-lokale URL, beispielsweise auf eine Webseite, so wird diese auf jeden Fall angezeigt.

Darüber hinaus kann man aus jCAPT heraus die Ressourcen in ihrer assoziierten Anwendung öffnen, ganz so wie man dies in einem Dateimanager (z.B. Windows Explorer) tun kann. Dies ermöglicht eine schnelle und bequeme Arbeit mit den Ressourcen, falls inhaltliche Änderungen an ihnen vorgenommen werden müssen. Auch hier sind Angaben der Speicherposition in Form von URLs unterstützt; die URL wird im Standard-Browser (z.B. Internet Explorer, Firefox, Mozilla, Opera, ...) geöffnet.


2.5.1. Dateivorschau-Fenster anzeigen

Die Dateivorschau erfolgt über ein eigenes Fenster, welches standardmäßig verborgen ist. Sie können das Dateivorschau-Fenster auf zweierlei Arten anzeigen:

  • Durch Betätigen der Schaltfläche Dateivorschau in der Symbolleiste im Arbeitsbereich

    Dateivorschau-Fenster anzeigen über die Symbolleiste im Arbeitsbereich.

    Abbildung 2.142. Dateivorschau-Fenster anzeigen über die Symbolleiste im Arbeitsbereich.

  • Durch Öffnen des Menüs Ansicht und Wahl des Menüeintrags Dateivorschau-Fenster anzeigen/verbergen

    Dateivorschau-Fenster anzeigen über das Menü.

    Abbildung 2.143. Dateivorschau-Fenster anzeigen über das Menü.

In beiden Fällen öffnet sich das Dateivorschau-Fenster im rechten unteren Bereich von jCAPT. Es kann wie ein normales Fenster minimiert, maximiert, in seiner Größe verändert und wieder geschlossen werden.

[Anmerkung] Anmerkung

Wenn das Dateivorschau-Fenster schon einmal angezeugt und wieder verborgen wurde, so nimmt es bei neuerlichem Anzeigen die genau Größe und Position ein, die es vor dem Verbergen hatte. Dies funktioniert allerdings nur, wenn jCAPT zwischen Verbergen und Anzeigen nicht neu gestartet wurde.

Wenn sich das Dateivorschau-Fenster vor dem Hauptfenster von jCAPT befindet und Sie in das Hauptfenster klicken, so kommt dieses in den Vordergrund und verdeckt unter Umständen Teile des Dateivorschau-Fensters. Dies ist kein Problem, da das Dateivorschau-Fenster beim Anzeigen von Ressourcen (siehe Abschnitt 2.5.2, „Ressourcen in der Dateivorschau anzeigen“) automatisch wieder in den Vordergrund gebracht wird.

Beim Minimiern des Hauptfensters von jCAPT wird das Dateivorschau-Fenster ebenfalls minimiert, beim Wiederherstellen wird es ebenfalls wiederhergestellt. So ist trotz der scheinbaren Unabhängigkeit des Dateivorschau-Fensters dieses in gewisser Weise an das Hauptfenster gebunden.


2.5.2. Ressourcen in der Dateivorschau anzeigen

Wenn das Dateivorschau-Fenster aktiviert ist und der Dateityp der Ressource unterstützt ist, so wird diese durch einen Mausklick auf den jeweiligen Knoten in der Vorschau angezeigt.

Ressourcen der Ressourcensammlung in der Dateivorschau anzeigen.

Abbildung 2.144. Ressourcen der Ressourcensammlung in der Dateivorschau anzeigen.

Bei der Anzeige von referenzierten Ressourcen des Manifests können neben über Dateipfade spezifizierte Dateien auch durch URLs angegebene Ressourcen betrachtet werden.

Referenzierte Ressource des Manifests in der Dateivorschau anzeigen.

Abbildung 2.145. Referenzierte Ressource des Manifests in der Dateivorschau anzeigen.


2.5.3. Dateivorschau-Fenster verbergen

Wenn das Dateivorschau-Fenster geöffnet ist können Sie es auf dreierlei Arten verbergen:

  • Durch Betätigen der eingerasteten Schaltfläche Dateivorschau in der Symbolleiste im Arbeitsbereich

    Dateivorschau-Fenster verbergen über die Symbolleiste im Arbeitsbereich.

    Abbildung 2.146. Dateivorschau-Fenster verbergen über die Symbolleiste im Arbeitsbereich.

  • Durch Öffnen des Menüs Ansicht und Wahl des Menüeintrags Dateivorschau-Fenster anzeigen/verbergen

    Dateivorschau-Fenster verbergen über das Menü.

    Abbildung 2.147. Dateivorschau-Fenster verbergen über das Menü.

  • Durch Betätigen der Standard-Schaltfläche zum Schließen eines Fensters. Diese befindet sich im rechten oberen Eck des Dateivorschau-Fensters und zeigt ein Kreuz-Symbol.

    Dateivorschau-Fenster verbergen über die Standardschaltfläche.

    Abbildung 2.148. Dateivorschau-Fenster verbergen über die Standardschaltfläche.

In beiden Fällen öffnet sich das Dateivorschau-Fenster. Dieses kann wie ein normales Fenster minimiert, maximiert, in seiner Größe verändert und wieder geschlossen werden.


2.5.4. Ressource in assoziierter Anwendung öffnen

Um eine (referenzierte) Ressource in der assoziierten Anwendung zu öffnen müssen Sie einen Doppelklick auf den entsprechenden Knoten ausführen. Dies funktioniert im Gegensatz zur Dateivorschau für jeden Dateityp. Sollte ein Dateityp mit keiner Anwendung assoziiert sein, so wird nachgefragt, mit welcher Anwendung diese Datei geöffnet werden soll.


2.6. Paketvorschau

Um einen Eindruck vom fertigen CPS-Paket zu gewinnen, ohne dieses exportieren zu müssen, existiert in jCAPT eine integrierte Paketvorschau. Sie eignet sich hervorragend zum Testen des Pakets, ob alle internen und externen Referenzen richtig aufgelöst werden, die gewünschten Ressourcen angezeigt werden, und ob die eingegebenen Metadaten korrekt sind. Ihre Anzeige entspricht im Grunde jenem Ergebnis, welches man durch einen Offline-Export des CPS-Pakets erhalten würde, und wie CPS-Pakete auch in Learning Management Systemen (LMS) dargestellt werden.

Um die Paketvorschau anzuzeigen müssen Sie folgenden Aktionen durchführen:

  1. Wählen Sie die Organisation, für welche Sie die Vorschau anzeigen wollen durch einen Klick auf den Namen oder das Symbole des entsprechenden Organisation-Knotens oder eines seiner Inhalt-Knoten.

    [Anmerkung] Anmerkung

    Wenn keine Organisation zur Anzeige in der Vorschau gewählt ist, weil beispielsweise der Manifest-Knoten gewählt ist, so wird die eingestellte Standard-Organisation (siehe Abschnitt 2.4.7.1, „Standard-Organisation festlegen“) dargestellt. Wurde keine Standard-Organisation gewählt, so wird die erste Organisation im Manifest angezeigt. Wenn keine Organisation existiert, wird ein leeres Paket in der Vorschau dargestellt.

  2. Betätigen Sie die Schaltfläche Paketvorschau in der Symbolleiste.

    Abbildung 2.149. Paketvorschau aktivieren.

  3. Warten Sie, bis die Paketvorschau erstellt ist und angezeigt wird. In der Zwischenzeit wird eine Forschrittsanzeige dargestellt. Wenn Sie Abbrechen wählen wird die Erstellung der Vorschau abgebrochen und die Bedienung kehrt zur Manifestansicht zurück.

    Fortschrittsanzeige beim Erstellen der Paketvorschau.

    Abbildung 2.150. Fortschrittsanzeige beim Erstellen der Paketvorschau.

Nach einer erfolgreichen Erstellung der Vorschau öffnet sich das Vorschaufenster. Links finden Sie die Struktur des CPS-Pakets, rechts werden die Inhalte nach Anwählen von Inhalt-Knoten angezeigt. Links oben sind außerdem die von Browsern bekannten Schaltflächen Vor, Zurück und Stop vorhanden.

Vorschau für CPS-Paket.

Abbildung 2.151. Vorschau für CPS-Paket.

Sie können die Vorschau durch Betätigen der Standard-Schaltfläche zum Schließen eines Fensters (befindet sich im rechten oberen Eck des Vorschau-Fensters und zeigt ein Kreuz-Symbol) schließen.

Paketvorschau-Fenster schließen über die Standardschaltfläche.

Abbildung 2.152. Paketvorschau-Fenster schließen über die Standardschaltfläche.

[Wichtig] Wichtig

Da es sich bei der Vorschau um einen vereinfachten Offline-Export des CPS-Pakets handelt, würden schon vorhandene Dateien eines früheren Offline-Exports im Basisordner durch die Erstellung der Vorschau überschrieben werden. jCAPT erkennt, wenn solche Dateien vorhanden sind und fragt nach, ob einem Überschreiben durch die Vorschau zugestimmt wird. Stimmen Sie hier nur zu, wenn Sie wissen, dass Sie den im Basisordner vorhandenen Offline-Export nicht mehr benötigen. Wenn Sie nicht zustimmen, werden die Dateien nicht überschrieben und die Vorschau nicht angezeigt.

Sicherheitsabfrage bei vorhandenen Dateien eines Offline-Exports.

Abbildung 2.153. Sicherheitsabfrage bei vorhandenen Dateien eines Offline-Exports.

Zur Illustration finden Sie im Folgenden eine Animation der zu tätigenden Aktionen.

Abbildung 2.154. Animation: Paketvorschau benutzen.


2.7. Metadatenerstellung und -bearbeitung

2.7.1. Metadaten im Manifest hinzufügen
2.7.2. Metadaten-Dialog bedienen
2.7.3. Metadaten in der Formular-Ansicht bearbeiten
2.7.4. Metadaten in der Baum-Ansicht bearbeiten
2.7.5. Metadaten extrahieren


2.7.1. Metadaten im Manifest hinzufügen

Ohne ein explizites Hinzufügen existieren im Manifest keine speziellen Metadatensätze. Sie müssen erst zu den jeweils relevanten Knoten hinzugefügt werden. Pro Knoten kann nur ein Metadatensatz vorhanden sein, damit es zu keinen Mehrdeutigkeiten kommt. Die Wahl des Metadaten-Schemas kann übrigens für jeden Knoten unterschiedlich sein.

Metadaten können zu folgenden Knoten hinzugefügt werden:

  • Manifest-Knoten: zur Beschreibung des Manifests als Ganzes.

  • Organisation-Knoten: ein Manifest kann mehrere inhaltsgleiche (aber unter Umständen in verschiedenen Sprachen bzw. Formaten vorliegende) Organisationen enthalten. Erst durch eine Auszeichnung mit Metadaten wird eine gegenseitige Abgrenzung ermöglicht.

  • Inhalt-Knoten: zur Beschreibung einzelner inhaltlicher Teile eines CPS-Pakets.

  • Ressource-Referenz-Knoten: um eine Ressource näher zu beschreiben.

[Tipp] Tipp

Fügen Sie zumindest zum Manifest-Knoten einen Metadatensatz hinzu. Dieser wird von den meisten Anwendungen verarbeitet und kann beispielsweise zum Auffinden des Pakets verwendet werden.

Um Metadaten im Manifest hinzuzufügen müssen Sie folgende Aktionen durchführen:

  1. Wählen Sie den Knoten, für den Sie Metadaten hinzufügen möchten, durch einen Klick auf dessen Namen bzw. Symbol.

  2. Betätigen Sie die rechte Maustaste; es öffnet sich das Kontextmenü.

    Metadaten im Manifest hinzufügen.
    Metadaten im Manifest hinzufügen.
    Metadaten im Manifest hinzufügen.
    Metadaten im Manifest hinzufügen.

    Abbildung 2.155. Metadaten im Manifest hinzufügen.

  3. Wählen Sie im Kontextmenü den Menüeintrag Erstelle Knoten 'Metadaten'; es öffnet sich ein Dialog zur Wahl des Schemas für den zu erstellenden Metadatensatz.

    Auswahl des Metadatenschemas.

    Abbildung 2.156. Auswahl des Metadatenschemas.

  4. Wählen Sie ein für die Verwendung des CPS-Pakets relevantes Schema und bestätigen Sie die Wahl durch Betätigen der Schaltfläche OK. Wenn Sie Abbrechen betätigen wird der Dialog geschlossen und es werden keine Metadaten zum gewählen Knoten hinzugefügt. Wenn Sie zusätzlich die Auswahlbox mit dem Titel Diese Auswahl standardmäßig benutzen und nicht mehr nachfragen. markieren, so wird anstatt dieser Wahl künftig automatisch das gewählte Schema verwendet. Dies können sie in der Konfiguration wieder zurücksetzen (siehe Abschnitt 1.4, „Einstellungen für die Metadatenbearbeitung“).

Nach dem Hinzufügen der Metadaten zum gewählten Knoten öffnet sich ein Dialog, in welchem die Metadaten bearbeitet werden können. Eine genaue Beschreibung zur Bedienung des Metadaten-Dialogs finden Sie in Abschnitt 2.7.2, „Metadaten-Dialog bedienen“.

Nachdem der Dialog zum Bearbeiten der Metadaten wieder geschlossen wurde sehen Sie im Manifest den erzeugten Metadaten-Knoten unterhalb des gewählten Ordners. Er trägt den Namen Metadaten (Schemabezeichnung), wobei die Schemabezeichnung je nach gewähltem Schema variiert.

Metadaten-Knoten in der Manifeststruktur.

Abbildung 2.157. Metadaten-Knoten in der Manifeststruktur.

[Wichtig] Wichtig

Beim Hinzufügen von Metadaten wird im Basisordner die Schemadefinition des gewählten Metadaten-Schemas hinzugefügt. Diese befindet sich in Dateien mit der Endung .xsd. Es kann auch passieren, dass (mehrere) Ordner mit Teilen dieser Schemadefinition erzeugt werden. Diese Dateien dürfen nicht gelöscht werden, da sie anderen Systemen zur Überprüfung der Metadaten dienen. Sollte ein/e derartige/r Datei/Ordner einmal irrtümlicherweise gelöscht werden, so wird er/sie beim nächsten Speichern des CPS-Pakets wiederhergestellt.


2.7.2. Metadaten-Dialog bedienen

Die Metadaten werden nicht in der Ansicht zur Bearbeitung der Ressourcen und des Manifests bearbeitet sondern in einem eigenen Dialog. Dieser verfügt über eine separate Menü- und Symbolleiste mit ähnlichen Elementen wie das Hauptfenster von jCAPT. Da es sich um einen modalen Dialog handelt, kann man, während der Metadaten-Dialog geöffnet ist, nur die Metadaten bearbeiten und hat keinen Zugriff auf das Hauptfenster. Dies ist erforderlich um Inkonsistenzen im Manifest zu verhindern.

Abbildung 2.158. Metadaten-Dialog.

Der Metadaten-Dialog verfügt über eine Formular-Ansicht und eine Baum-Ansicht zur Bearbeitung der Metadaten. Diese bieten für unterschiedliche Aufgabenbereiche optimierte Sichten auf die Metadaten. Wählen Sie die Formular-Ansicht, um die wichtigsten Metadaten schnell und unkompliziert einzugeben. Wählen Sie die Baum-Ansicht, wenn sie mehr Kontrolle oder eine Gesamtsicht über die Metadaten benötigen und direkt mit deren Baumstruktur arbeiten müssen.

Sowohl in der Formular- als auch der Baum-Ansicht verfügt der Metadaten-Dialog über eine Möglichkeit zur Wahl des Profils für das verwendete Metadaten-Schema. Profile bieten die Möglichkeit den Umfang und die Ausprägung der Werte im Metadatensatz innerhalb des Schemas weiter zu konkretisieren. Dies ermöglicht es beispielsweise Ländern, Firmen und Institutionen die Metadatensätze über das Metadaten-Schema hinaus für ihre Zwecke zu standardisieren.


2.7.2.1. Metadaten-Dialog öffnen

Sie können den Dialog zum Bearbeiten der Metadaten von der Manifest-Ansicht aus über den jeweiligen Metadaten-Knoten öffnen. Wenn Sie gerade einen Metadaten-Knoten erzeugt haben, so ist der Metadaten-Dialog bereits offen.

Um den Metadaten-Dialog zu öffnen müssen Sie folgende Aktionen durchführen:

  1. Wählen Sie den Metadaten-Knoten jenes Knotens, dessen Metadatensatz Sie bearbeiten wollen, durch einen Klick auf dessen Namen bzw. Symbol.

  2. Öffnen Sie den Metadaten-Dialog für diesen Metadatensatz. Dies kann auf drei Arten geschehen:

    • Öffnen des Menüs Bearbeiten und Wahl des Menüeintrags Metadaten bearbeiten...

      Metadaten-Dialog öffnen über das Menü.

      Abbildung 2.159. Metadaten-Dialog öffnen über das Menü.

    • Öffnen des Kontextmenüs durch einen Klick mit der rechten Maustaste und Wahl des Menüeintrags Metadaten bearbeiten...

      Metadaten-Dialog öffnen über das Kontextmenü.

      Abbildung 2.160. Metadaten-Dialog öffnen über das Kontextmenü.

    • Ausführen eines Doppelklicks auf den Metadaten-Knoten

Es öffnet sich der Metadaten-Dialog und zeigt den jeweiligen Metadatensatz in der Formular-Ansicht.


2.7.2.2. Zwischen Formular- und Baumansicht wechseln

Je nach Art, Umfang und Ziel der Bearbeitung der Metadaten kann man zwischen der Formular- und der Baum-Ansicht wählen. Zum schnellen und bequemen Eingeben der wichtigsten Metadaten eignet sich die Formular-Ansicht. Will man direkte Kontrolle über die Metadaten und möchte weiterreichende Bearbeitungsmöglichkeiten, so bietet sich die Baum-Ansicht an.

Um zwischen diesen zwei Ansichten zu wechseln, müssen Sie die entsprechend beschriftete Lasche (Formular-Ansicht bzw. Baum-Ansicht) der zwei Registerkarten betätigen.

Registerkarten zum Wechsel der Ansicht im Metadaten-Dialog.

Abbildung 2.161. Registerkarten zum Wechsel der Ansicht im Metadaten-Dialog.

[Anmerkung] Anmerkung

Die meisten Menüeinträge und Symbole der Symbolleiste sind in der Formular-Ansicht deaktiviert und können nur in der Baum-Ansicht verwendet werden. Einzig das Rückgängigmachen und das Wiederholen von Aktionen ist in beiden Ansichten möglich.


2.7.2.3. Aktion(en) rückgängig machen

jCAPT bietet die Möglichkeit, Operationen an der Metadatenstruktur wieder rückgängig zu machen. Es gibt keine prinzipielle Einschänkung bezüglich der Anzahl der Operationen, die rückgängig gemacht werden können; die tatsächliche Zahl hängt jedoch vom verfügbaren Hauptspeicher ab.

Es gibt drei Möglichkeiten, eine Aktion rückgängig zu machen:

  • Betätigen der Schaltfläche Rückgängig in der Symbolleiste

    Aktion(en) rückgängig machen über die Symbolleiste.

    Abbildung 2.162. Aktion(en) rückgängig machen über die Symbolleiste.

  • Öffnen des Menüs Bearbeiten und Wahl des Menüeintrags Rückgängig. Nach dem Text Rückgängig im Menüeintrag ist zusätzlich noch die Aktion angeführt, welche dadurch rückgängig gemacht wird.

    Aktion(en) rückgängig machen über das Menü.

    Abbildung 2.163. Aktion(en) rückgängig machen über das Menü.

  • Betätigen der Tastenkombination Strg-Z

In allen drei Fällen wird die jeweils letzte gültige Aktion rückgängig gemacht. Wenn noch keine Aktion getätigt wurde bzw. alle Aktionen rückgängig gemacht wurden, sind die Schaltfläche in der Symbolleiste und der Menüeintrag deaktiviert und können nicht angewählt werden. Auch die Tastenkombination zeigt dann keine Wirkung.

[Anmerkung] Anmerkung

Wenn Sie eine Aktion in der Formular-Ansicht rückgängig machen, so kann es sein, dass dies erst nach mehrmaligem Betätigen der Schaltfläche oder der Tastenkombination bzw. Wahl des Menüeintrags Wirkung zeigt. Der Grund ist, dass beim Bearbeiten der Metadaten in der Formular-Ansicht im Hintergrund oft mehrere Aktionen durchgeführt werden, die in dieser nicht sichtbar sind. Auch ihre Rückgängigmachung ist nicht sichtbar, weshalb es manchmal den Anschein hat, es würde nichts geschehen. Führen Sie in diesem Fall die Rückgängigmachen-Aktion so oft aus, bis Sie den gewünschten Effekt erzielen.


2.7.2.4. Aktion(en) wiederholen

Als Gegenstück zum Rückgängigmachen von Aktionen bietet jCAPT auch die Möglichkeit, rückgängig gemachte Operationen an der Metadatenstruktur zu wiederholen.

Es gibt drei Möglichkeiten, eine Aktion zu wiederholen:

  • Betätigen der Schaltfläche Wiederholen in der Symbolleiste

    Aktion(en) wiederholen über die Symbolleiste.

    Abbildung 2.164. Aktion(en) wiederholen über die Symbolleiste.

  • Öffnen des Menüs Bearbeiten und Wahl des Menüeintrags Wiederholen. Nach dem Text Wiederholen im Menüeintrag ist zusätzlich noch die Aktion angeführt, welche dadurch wiederholt wird.

    Aktion(en) wiederholen über das Menü.

    Abbildung 2.165. Aktion(en) wiederholen über das Menü.

  • Betätigen der Tastenkombination Strg-Y

In allen drei Fällen wird die jeweils letzte rückgängig gemachte Aktion wiederholt. Wenn noch keine Aktion rückgängig gemacht wurde bzw. alle Aktionen wiederholt wurden sind die Schaltfläche in der Symbolleiste und der Menüeintrag deaktiviert und können nicht angewählt werden. Auch die Tastenkombination zeigt dann keine Wirkung.

[Anmerkung] Anmerkung

Wenn Sie eine Aktion in der Formular-Ansicht wiederholen, so kann es sein, dass dies erst nach mehrmaligem Betätigen der Schaltfläche oder der Tastenkombination bzw. Wahl des Menüeintrags Wirkung zeigt. Der Grund ist, dass beim Bearbeiten der Metadaten in der Formular-Ansicht im Hintergrund oft mehrere Aktionen durchgeführt werden, die in dieser nicht sichtbar sind. Auch ihre Wiederholung ist nicht sichtbar, weshalb es manchmal den Anschein hat, es würde nichts geschehen. Führen Sie in diesem Fall die Wiederholen-Aktion so oft aus, bis Sie den gewünschten Effekt erzielen.


2.7.2.5. Profil für Metadaten-Schema wählen

Profile dienen der Standardisierung von Metadaten eines Schemas. Sie werden beispielsweise von Ländern, Firmen und Institutionen eingestzt, um komplatible Metadaten zu gewährleisten. Ein Profil umfasst meist eine Aufzählung von verpflichtenden und optionalen Metadaten-Feldern, Wertebereiche, ein vorgefertigtes Vokabular und eine angepasste Beschreibung für die einzelnen Felder.

jCAPT unterstützt all diese Vorgaben eines Profils. Die Formular-Ansicht zeigt nur die laut Profil verpflichtenden Metadaten-Felder. Die Eingabemöglichkeiten in den einzelnen Felder können sowohl in der Formular- als auch der Baum-Ansicht in ihrem Wertebereich beschränkt werden. Für bestimmte Felder kann beispielsweise ein Zahlenbereich vorgegeben werden. Auch die Benennung der Metadaten-Felder und der Inhalt der kontextsensitiven Hilfe hängt vom jeweiligen Profil ab.

Um ein Profil für das aktuelle Metadaten-Schema zu wählen müssen Sie in dem Auswahl-Feld im rechten oberen Bereich des Metadaten-Dialogs den entsprechenden Eintrag selektieren. Diese Wahl gilt dann sowohl für die Formular- als auch die Baum-Ansicht.

Profil für Metadaten-Schema wählen.

Abbildung 2.166. Profil für Metadaten-Schema wählen.


2.7.2.6. Metadaten-Dialog schließen

Solange die Metadaten im Metadaten-Dialog bearbeitet werden, sind sie nicht im Manifest gespeichert. Erst durch das Betätigen der Schaltfläche OK am rechten unteren Rand des Dialogs wird dieser geschlossen und die Metadaten werden gespeichert. Wenn Sie Abbrechen wählen, wird der Dialog geschlossen ohne die Metadaten ins Manifest zurückzuspeichern.

Abbildung 2.167. Metadaten-Dialog schließen.


2.7.3. Metadaten in der Formular-Ansicht bearbeiten

Die Formular-Ansicht stellt die einfachste und bequemste Art dar, Metadaten zu bearbeiten. Diesem Komfort steht natürlich eine geringere Mächtigkeit im Vergleich zur Baum-Ansicht gegenüber. Gewisse Aspekte, wie beispielsweise die Bearbeitung von Attributen (z.B. Sprache) von Metadaten-Feldern, können nicht in der Formular-Ansicht erledigt werden. Aus diesem Grund ist es hilfreich, eine Grundstock an Metadaten in der Formular-Ansicht einzugeben und für eine genauere Bearbeitung dann zur Baum-Ansicht zu wechseln.

In der Formular-Ansicht befindet sich in der oberen Hälfte des Metadaten-Dialogs das Formular mit seinen Eingabemöglichkeiten für die einzelnen Metadaten-Felder und in der unteren Hälfte die kontextsensitive Hilfe. Die einzelnen Metadaten-Felder im Formular sind in Gruppierungen eingeteilt. Jede dieser Gruppierungen hat eine Bezeichnung, welche grau hinterlegt ist.

Formular-Ansicht im Metadaten-Dialog.

Abbildung 2.168. Formular-Ansicht im Metadaten-Dialog.

[Tipp] Tipp

Wenn Sie für gewisse Metadaten-Felder mehrere unterschiedliche Werte definieren möchten bzw. Werte in mehreren Sprachen ablegen wollen, so können Sie das nur in der Baum-Ansicht tun. In der Formular-Ansicht kann nur jeweils ein Wert für jedes Metadaten-Feld eingegeben werden.


2.7.3.1. Kontextsensitive Hilfe verwenden

Zu den einzelnen Gruppierungen und Metadaten-Feldern in der Formular-Ansicht existiert eine kontextsensitive Hilfe. Sie liefert eine Beschreibung des jeweiligen Elements, seine Bedeutung innerhalb der Metadaten, den Wertebereich und möglicherweise Links zu weiterführenden Informationen. Angezeigt wird der Hilfetext im unteren Bereich der Formular-Ansicht bzw. im unteren rechten Bereich der Baum-Ansicht. Ein Unterschied besteht hier lediglich in der Positionierung, nicht jedoch im Inhalt.

Abbildung 2.169. Kontextsensitive Hilfe.

Allfällige Links werden durch ein Betätigen mit der Maus im Standard-Browser (z.B. Internet Explorer, Firefox, Mozilla, Opera, ...) geöffnet. Wenn der Hilfetext nicht in den verfügbaren Platz zur Anzeige passt, so erscheint auf der rechten Seite eine Bildlaufleiste, mithilfe derer Sie den angezeigten Ausschnitt wählen können.

Um die kontextsensitive Hilfe für eine Gruppierung aufzurufen müssen Sie mit der Maus auf das graue Feld, in welchem der Name der Gruppierung steht, klicken. Um zu signalisieren, dass ein Hilfetext angezeigt werden kann, ändert sich der Mauszeiger zu einer stilisierten Hand und das Feld wird farblich hervorgehoben. Ist kein Hilfetext vorhanden, so findet keine derartige Hervorhebung statt und es wird kein Hilfetext angezeigt.

Kontextsensitive Hilfe für Gruppierung aufrufen.

Abbildung 2.170. Kontextsensitive Hilfe für Gruppierung aufrufen.

Um die kontextsensitive Hilfe für ein Metadaten-Feld aufzurufen können Sie einerseits auf die Beschriftung neben dem Feld oder in das Feld selbst klicken. Wie bei dem Gruppierungsfeld verändert sich der Mauszeiger über der Beschriftung zu einer stilisierte Hand um anzuzeigen, dass ein Hilfetext angezeigt werden kann. Ist kein Hilfetext vorhanden, so findet keine derartige Veränderung statt und es wird kein Hilfetext angezeigt.

Kontextsensitive Hilfe für Metadatenfeld aufrufen.

Abbildung 2.171. Kontextsensitive Hilfe für Metadatenfeld aufrufen.

Um zu erkennen, auf welchen Teil des Formulars sich der aktuelle Hilfetext bezieht, wird dieser durch roten Text herorgehoben.


2.7.3.2. Wert eines Metadaten-Feldes festlegen

Es gibt zwei Möglichkeiten, den Wert eines Metadaten-Feldes festzulegen:

  • Eingabe des Wertes in einem Eingabefeld: klicken Sie in das Eingabefeld und geben Sie den Wert über die Tastatur ein.

    Wert in Metadatenfeld eingeben.

    Abbildung 2.172. Wert in Metadatenfeld eingeben.

    [Anmerkung] Anmerkung

    Für bestimmte Felder kann im Profil (siehe Abschnitt 2.7.2.5, „Profil für Metadaten-Schema wählen“) ein Wertebereich vorgesehen sein. In diesem Fall kann es sein, dass beispielsweise nur (bestimmte) Zahlen angegeben werden können. Der gültige Wertebereich findet sich meist in der kontextsensitiven Hilfe zu dem jeweiligen Metadaten-Feld.

  • Auswahl des Wertes aus einer Menge von gültigen Werten: für gewisse Metadaten-Felder gibt das Profil (siehe Abschnitt 2.7.2.5, „Profil für Metadaten-Schema wählen“) eine Menge von gültigen Werten vor, aus welcher gewählt werden kann. Betätigen Sie die Schaltfläche mit dem nach unten gerichteten Dreieck und wählen Sie in der sich öffnenden Liste den gewünschten Wert.

    Wert aus Liste von gültigen Werten wählen.

    Abbildung 2.173. Wert aus Liste von gültigen Werten wählen.

    [Achtung] Achtung

    In dem Auswahlfeld für gültige Werte kann auch ein Wert eingegeben werden, welcher nicht in der Liste der gültigen enthalten ist. Beachten Sie hierbei, dass dieser dann nicht mehr dem Profil entspricht und möglicherweise von Anwendungen, welche die Metadaten des CPS-Pakets verarbeiten, nicht verstanden wird.


2.7.4. Metadaten in der Baum-Ansicht bearbeiten

Die Baum-Ansicht bietet einen direkten Zugriff auf die Metadatenstruktur, so wie sie auch im Manifest gespeichert wird. In ihr können alle Aspekte der Metadaten-Bearbeitung durchgeführt werden, womit sie an Mächtigkeit der Formular-Ansicht klar überlegen ist. Gegenüber dieser hat sie jedoch den Nachteil einer komplexeren Bedienung. Diese ähnelt jedoch jener in der Manifeststruktur, weshalb sich keine besonderen Schwierigkeiten ergeben sollten.

In der Baum-Ansicht befindet sich in der oberen Hälfte des Metadaten-Dialogs die Metadatenstruktur in Form eines Baumes. Zu jedem Knoten kann darüber hinaus noch sein Wert und der seines Attributs angezeigt werden. In der unteren Hälfte befinden sich links die Eingabefelder für den Wert des jeweiligen Knotens und seines Attributs. Auf der rechten Seite liegt die kontextsensitive Hilfe.

Baum-Ansicht im Metadaten-Dialog.

Abbildung 2.174. Baum-Ansicht im Metadaten-Dialog.


2.7.4.1. Knoten erstellen

Die eigentlichen Metadaten sind als Werte von einzelnen Knoten abgelegt. Um sie zu spezifizieren müssen zuerst Knoten erstellt werden. Die Knoten werden hierbei in einer hierarchischen Baum-Struktur angelegt. Der genau Aufbau dieser Metadatenstruktur wird vom Metadaten-Schema festgelegt. Es kann also nicht jeder Knoten an jeder beliebigen Stelle angelegt werden, meist hat jeder Knoten einen spezifischen Platz im Baum. Manche Knoten (z.B. Sprachspezifischer Freitext- bzw. Language String-Knoten) sind jedoch sehr allgemeiner Natur und können als Kindknoten vieler anderer Knoten vorkommen.

Um einen Knoten zu erstellen müssen Sie folgende Aktionen durchführen:

  1. Wählen Sie in der Metadatenstruktur den Knoten, als dessen Kind Sie den Knoten erstellen möchten, mit einem Mausklick auf dessen Namen bzw. Symbol.

  2. Betätigen Sie die rechte Maustaste; es öffnet sich das Kontextmenü.

  3. Wählen Sie im Kontextmenü den Menüeintrag Erstelle Knoten 'Knotentyp'. Der Knotenname entspricht hierbei dem Typ des Knotens, den Sie erstellen möchten.

Metadaten-Knoten in der Baum-Ansicht hinzufügen.

Abbildung 2.175. Metadaten-Knoten in der Baum-Ansicht hinzufügen.

Es wird ein neuer Knoten vom angegebenen Typ als Kind des vorher gewählten Knotens erstellt und ausgewählt. Bei manchen Knoten ist es möglich, dass zusätzlich benötigte Kindknoten ebenfalls erstellt werden.

[Anmerkung] Anmerkung

Wenn im Kontextmenü zum Erstellen eines Knotens dieser ausgegraut ist und nicht gewählt werden kann, so verbietet der jeweilige Metadaten-Standard, diesen Knoten einzufügen. Dies kann beispielsweise der Fall sein, wenn ein Knoten, welcher nur einmal existieren darf (z.B. Titel), schon vorhanden ist.


2.7.4.2. Wert eines Knotens festlegen

Der eigentliche Zweck von Metadaten-Knoten ist das Halten von Werten bzw. die Strukturierung des Baums. Zur Eingabe des Werts eines Knotens existieren abhängig vom Knotentyp verschiedene Eingabeelemente. Sie alle werden im linken unteren Bereich des Metadaten-Dialogs dargestellt. So können dort unter anderem ein einzeiliges oder mehrzeiliges Texteingabefeld, eine Auswahlliste für festgelegte Werte bzw. eine Möglichkeit zur Bearbeitung des Werts von Attributen angezeigt werden. Es gibt auch Knoten, welche nur zur Strukturierung untergeordneter Knoten dienen und selbst keinen Wert haben. In diesem Fall fehlen diese Eingabelemente.

Eingabemöglichkeiten für den Wert von Metadaten-Knoten.
Eingabemöglichkeiten für den Wert von Metadaten-Knoten.
Eingabemöglichkeiten für den Wert von Metadaten-Knoten.

Abbildung 2.176. Eingabemöglichkeiten für den Wert von Metadaten-Knoten.

Im einzeiligen Textfeld können bei den meisten Knoten beliebiger Text bzw. Werte in der vom Schema geforderten Form eingegeben werden. Für manche Knoten ist jedoch im Profil eine Einschränkung bezüglich des Wertebereichs bzw. des Typs der eingegebenen Daten festgelegt. In diesem Fall können beispielsweise in einem Feld, welches den Preis angibt, nur positive Zahlen eingegeben werden.

Mehrzeilige Textfelder eignen sich zur Eingabe von größeren Mengen Text (z.B. Kurzbeschreibungen) und unterliegen keinen Einschränkungen durch das Schema bzw. Profil.

Mittels einer Auswahlliste kann der Wert aus einer durch das Profil vorgegebenen Menge von gültigen Werten gewählt werden.


2.7.4.3. Wert eines Attributs verändern

Attribute erlauben es zu einem Knoten Zusatzinformationen anzugeben. Diese beziehen sich einerseits auf den Knoten selbst (z.B. Eindeutige Element-ID als Wert, welcher den Knoten eindeutig im Metadatensatz identifiziert) oder aber auf den Wert des Knotens (z.B. Sprache, in welcher der textuelle Wert des Knotens verfasst ist). Abhängig vom Typ des Attributs kann man dessen Wert als freien Text eingeben oder muss ihn aus einer Liste von gültigen Werten wählen.

Eingabemöglichkeiten für den Wert von Attributen.
Eingabemöglichkeiten für den Wert von Attributen.

Abbildung 2.177. Eingabemöglichkeiten für den Wert von Attributen.


2.7.4.4. Reihenfolge von Knoten verändern

Beim Hinzufügen von Knoten in der Metadatenstruktur werden diese immer am Ende von schon bestehenden Geschwister-Knoten eingefügt. Eine Umordnung kann hier für eine bessere Verständlichkeit und Wartbarkeit sorgen.

Damit in jCAPT die Reihenfolge von Metadaten-Knoten verändert werden kann, müssen folgende Voraussetzungen erfüllt sein:

  • es handelt sich um mindestens zwei Knoten

  • die Knoten sind alle Kinder des selben Vaterknotens

  • die Knoten haben alle den selben Typ

[Anmerkung] Anmerkung

Die Knoten sind im Baum automatisch nach Typen gruppiert. Ihre Reihenfolge kann nur innerhalb dieser Gruppierungen verändert werden.

Um die Position eines Knotens in seiner Typ-Gruppe zu verändern müssen Sie folgende Aktionen durchführen:

  1. Wählen Sie den Metadaten-Knoten, dessen Position Sie verändern möchten, mit einem Mausklick auf dessen Namen bzw. Symbol.

  2. Starten Sie die Verschiebe-Operation in die gewünschte Richtung. Dies kann auf viererlei Arten geschehen:

    • Betätigen der Schaltfläche Aufwärts bzw. Abwärts in der Symbolleiste

      Reihenfolge von Knoten verändern über die Symbolleiste.
      Reihenfolge von Knoten verändern über die Symbolleiste.

      Abbildung 2.178. Reihenfolge von Knoten verändern über die Symbolleiste.

    • Öffnen des Menüs Bearbeiten und Wahl des Menüeintrags Aufwärts bzw. Abwärts

      Reihenfolge von Knoten verändern über das Menü.
      Reihenfolge von Knoten verändern über das Menü.

      Abbildung 2.179. Reihenfolge von Knoten verändern über das Menü.

    • Öffnen des Kontextmenüs durch einen Klick mit der rechten Maustaste und Wahl des Menüeintrags Aufwärts bzw. Abwärts

      Reihenfolge von Knoten verändern über das Kontextmenü.
      Reihenfolge von Knoten verändern über das Kontextmenü.

      Abbildung 2.180. Reihenfolge von Knoten verändern über das Kontextmenü.

    • Betätigen der Tastenkombination Alt-Pfeil nach oben für ein Verschieben nach oben bzw. Alt-Pfeil nach unten für ein Verschieben nach unten

Der Knoten wird in der Folge um eine Position nach oben bzw. nach unten verschoben. Dabei werden Kindknoten ebenfalls mit dem Knoten bewegt. Durch Ausführung mehrere Verschiebe-Operationen lässt sich die Reihenfolge der Knoten einer gesamten Typ-Gruppe verändern.

[Anmerkung] Anmerkung

Wenn die Möglichkeiten zum Verschieben eines Knotens (Symbolleiste, Menü, Kontextmenü) deaktiviert sind und die Betätigung der Tastenkombination keine Wirkung zeigt, so ist dieser Knotentyp eventuell nicht verschiebbar, er hat keinen Knoten, gegen den er verschoben werden könnte oder er befindet sich am Rand der Typ-Gruppe.


2.7.4.5. Knoten in die Zwischenablage ausschneiden

Zum Verschieben von Knoten zwischen Teilen der Manifeststruktur müssen diese in die Zwischenablage ausgeschnitten und später wieder eingefügt werden (siehe Abschnitt 2.7.4.7, „Knoten aus der Zwischenablage einfügen“). Hierbei können nur Knoten ausgeschnitten werden, bei denen das Metadaten-Schema nicht erzwingt, dass sie vorhanden sind.

Um einen Knoten in die Zwischenablage auszuschneiden müssen Sie folgende Aktionen durchführen:

  1. Wählen Sie in der Metadatenstruktur den Knoten, den Sie in die Zwischenablage ausschneiden möchten, mit einem Mausklick auf dessen Namen bzw. Symbol.

  2. Starten Sie die Ausschneiden-Operation. Dies kann auf viererlei Arten geschehen:

    • Betätigen der Schaltfläche Ausschneiden in der Symbolleiste

      Knoten in die Zwischenablage ausschneiden über die Symbolleiste.

      Abbildung 2.181. Knoten in die Zwischenablage ausschneiden über die Symbolleiste.

    • Öffnen des Menüs Bearbeiten und Wahl des Menüeintrags Ausschneiden

      Knoten in die Zwischenablage ausschneiden über das Menü.

      Abbildung 2.182. Knoten in die Zwischenablage ausschneiden über das Menü.

    • Öffnen des Kontextmenüs durch einen Klick mit der rechten Maustaste und Wahl des Menüeintrags Ausschneiden

      Knoten in die Zwischenablage ausschneiden über das Kontextmenü.

      Abbildung 2.183. Knoten in die Zwischenablage ausschneiden über das Kontextmenü.

    • Betätigen der Tastenkombination Strg-X

Der Knoten wird in der Folge samt eventuell vorhandenen Kindknoten in die Zwischenablage ausgeschnitten. Von dort kann er an anderer geeigneter Stelle später wieder eingefügt werden (siehe Abschnitt 2.7.4.7, „Knoten aus der Zwischenablage einfügen“).

[Anmerkung] Anmerkung

Wenn die Möglichkeiten zum Ausschneiden eines Knotens (Symbolleiste, Menü, Kontextmenü) deaktiviert sind und die Betätigung der Tastenkombination keine Wirkung zeigt, so ist dieser Knotentyp eventuell nicht ausschneidbar, weil er beispielsweise in den Metadaten nicht fehlen darf.


2.7.4.6. Knoten in die Zwischenablage kopieren

Zum Kopieren von Knoten zwischen Teilen der Manifeststruktur müssen diese in die Zwischenablage ausgeschnitten und später wieder eingefügt werden (siehe Abschnitt 2.7.4.7, „Knoten aus der Zwischenablage einfügen“). Es können nur Knoten kopiert werden, bei denen es auch Sinn macht, dass sie wieder eingefügt werden.

Um einen Knoten in die Zwischenablage zu kopieren müssen Sie folgende Aktionen durchführen:

  1. Wählen Sie in der Metadatenstruktur den Knoten, den Sie in die Zwischenablage zu kopieren möchten, mit einem Mausklick auf dessen Namen bzw. Symbol.

  2. Starten Sie die Kopieren-Operation. Dies kann auf viererlei Arten geschehen:

    • Betätigen der Schaltfläche Kopieren in der Symbolleiste

      Knoten in die Zwischenablage kopieren über die Symbolleiste.

      Abbildung 2.184. Knoten in die Zwischenablage kopieren über die Symbolleiste.

    • Öffnen des Menüs Bearbeiten und Wahl des Menüeintrags Kopieren

      Knoten in die Zwischenablage kopieren über das Menü.

      Abbildung 2.185. Knoten in die Zwischenablage kopieren über das Menü.

    • Öffnen des Kontextmenüs durch einen Klick mit der rechten Maustaste und Wahl des Menüeintrags Kopieren

      Knoten in die Zwischenablage kopieren über das Kontextmenü.

      Abbildung 2.186. Knoten in die Zwischenablage kopieren über das Kontextmenü.

    • Betätigen der Tastenkombination Strg-C

Der Knoten wird in der Folge samt eventuell vorhandenen Kindknoten in die Zwischenablage kopiert. Von dort kann er an anderer geeigneter Stelle später wieder eingefügt werden (siehe Abschnitt 2.7.4.7, „Knoten aus der Zwischenablage einfügen“).

[Anmerkung] Anmerkung

Wenn die Möglichkeiten zum Kopieren eines Knotens (Symbolleiste, Menü, Kontextmenü) deaktiviert sind und die Betätigung der Tastenkombination keine Wirkung zeigt, so ist dieser Knotentyp eventuell nicht kopierbar, weil er beispielsweise nur ein Mal in den Metadaten vorkommen darf (z.B. Wurzel-Knoten).


2.7.4.7. Knoten aus der Zwischenablage einfügen

In die Zwischenablage ausgeschnittene bzw. kopierte Knoten können an geeigneter Stelle aus dieser wieder eingefügt werden. So können Teile der Metadatenstruktur über die Zwischenablage in dieser verschoben bzw. kopiert werden. Damit ein Knoten aus der Zwischenablage eingefügt werden kann, müssen einige Voraussetzungen erfüllt sein:

  • es muss erlaubt sein, dass an der Einfügestelle ein Knoten vom Typ des in der Zwischenablage befindlichen existiert

  • die Höchstzahl an erlaubten Knoten dieses Typs an der Einfügestelle darf nicht überschritten werden

Um einen Knoten aus der Zwischenablage einzufügen müssen Sie folgende Aktionen durchführen:

  1. Wählen Sie in der Metadatenstruktur den Knoten, als dessen Kind Sie den in die Zwischenablage liegenden einfügen möchten, mit einem Mausklick auf dessen Namen bzw. Symbol.

  2. Starten Sie die Einfügen-Operation. Dies kann auf viererlei Arten geschehen:

    • Betätigen der Schaltfläche Einfügen in der Symbolleiste

      Knoten aus der Zwischenablage einfügen über die Symbolleiste.

      Abbildung 2.187. Knoten aus der Zwischenablage einfügen über die Symbolleiste.

    • Öffnen des Menüs Bearbeiten und Wahl des Menüeintrags Einfügen

      Knoten aus der Zwischenablage einfügen über das Menü.

      Abbildung 2.188. Knoten aus der Zwischenablage einfügen über das Menü.

    • Öffnen des Kontextmenüs durch einen Klick mit der rechten Maustaste und Wahl des Menüeintrags Einfügen

      Knoten aus der Zwischenablage einfügen über das Kontextmenü.

      Abbildung 2.189. Knoten aus der Zwischenablage einfügen über das Kontextmenü.

    • Betätigen der Tastenkombination Strg-V

Der Knoten in die Zwischenablage wird in der Folge samt seinen eventuell vorhandenen Kindknoten als Kindknoten des gewählten Knotens eingefügt. Besitzt dieser Knoten schon Kindknoten vom selben Typ wie der einzufügende, so wird der Knoten aus der Zwischenablage nach diesen Kindknoten eingefügt.

[Anmerkung] Anmerkung

Wenn die Möglichkeiten zum Einfügen eines Knotens (Symbolleiste, Menü, Kontextmenü) deaktiviert sind und die Betätigung der Tastenkombination keine Wirkung zeigt, so kann der Knoten nicht eingefügt werden, weil er beispielsweise an dieser Stelle nur ein Mal vorkommen darf (z.B. Titel-Knoten).


2.7.4.8. Knoten löschen

Erstellte Knoten können in der Metadatenstruktur auch wieder gelöscht werden. Abhängig vom Metadaten-Schema können gewisse Knoten in ihrem Kontext nicht gelöscht werden, weil sie verpflichtend vorkommen müssen.

[Anmerkung] Anmerkung

Wenn die Möglichkeiten zum Löschen eines Knotens (Symbolleiste, Menü, Kontextmenü) deaktiviert sind und die Betätigung der Tastenkombination keine Wirkung zeigt, so ist dieser Knotentyp eventuell nicht löschbar, weil er beispielsweise in der Metadatenstruktur an dieser Stelle nicht fehlen darf.

Um einen Knoten zu löschen müssen Sie folgende Aktionen durchführen:

  1. Wählen Sie in der Metadatenstruktur den Knoten, den Sie löschen möchten, mit einem Mausklick auf dessen Namen bzw. Symbol.

  2. Starten Sie die Löschen-Operation. Dies kann auf viererlei Arten geschehen:

    • Betätigen der Schaltfläche Löschen in der Symbolleiste

      Knoten löschen über die Symbolleiste.

      Abbildung 2.190. Knoten löschen über die Symbolleiste.

    • Öffnen des Menüs Bearbeiten und Wahl des Menüeintrags Löschen

      Knoten löschen über das Menü.

      Abbildung 2.191. Knoten löschen über das Menü.

    • Öffnen des Kontextmenüs durch einen Klick mit der rechten Maustaste und Wahl des Menüeintrags Löschen

      Knoten löschen über das Kontextmenü.

      Abbildung 2.192. Knoten löschen über das Kontextmenü.

    • Betätigen der Entf-Taste

Der Knoten wird in der Folge samt eventuell vorhandenen Kindknoten gelöscht.


2.7.5. Metadaten extrahieren

Metadaten spielen eine wichtige Rolle für die Verwaltung von Lernpaketen. Nur duch sie können Lernpakete gefunden und in ihrer Eignung für einen bestimmten Anwendungsfall bewertet werden. Ein Problem ist jedoch die mangelnde Auszeichnung von Lernpaketen mit Metadaten. Oft fehlen jedwede Metadaten bzw. sind nur lückenhaft und in zweifelhafter Qualität vorhanden.

Eine Abhilfe hofft hier die automatische Bestimmung von Metadaten zu schaffen. Mit ihr sollen Standardfelder mit maschinell auffindbaren Werten gefüllt werden. Eine Möglichkeit ist hier, auf schon vorhandene Metadaten in den Ressourcen zurückzugreifen und diese zu extrahieren.

jCAPT unterstützt die Extraktion gewisser Metadaten aus Ressourcen. Hierbei werden folgende Dateitypen (mit Endung) und ihr jeweiliger Inhalt unterstützt:

  • HTML-Dateien (.html, .htm):

    • Sprache der Ressource: aus der im HTML-Metadatensatz gespeicherten Sprache. Im Metadatensatz werden zwei Arten der Angabe unterstützt:

      • HTML-spezifisches Feld:

        z.B. <meta http-equiv="content-language" content="de">

      • Dublin Core-Feld

        z.B. <meta name="DC.language" content="de">

      Falls kein Metadatensatz vorhanden ist bzw. dieser nicht gelesen werden kann, so wird eine Wortanalyse des Texts zur Unterscheidung zwischen Englisch und Deutsch vorgenommen.

    • Titel: aus dem title-Element der HTML-Datei

    • Schlüsselwörter: aus den im HTML-Metadatensatz gespeicherten Schlüsselwörtern. Im Metadatensatz werden zwei Arten der Angabe unterstützt:

      • HTML-spezifisches Feld:

        z.B. <meta name="keywords" content="Wort1, Wort2">

      • Dublin Core-Feld:

        z.B. <meta name="DC.subject" content="Wort1, Wort2">

  • PDF-Dateien (.pdf):

    • Sprache der Ressource: mittels Wortanalyse des Texts und Unterscheidung zwischen Englisch und Deutsch

    • Titel: aus dem im PDF-Metadatensatz gespeicherten Titel

    • Schlüsselwörter: aus den im PDF-Metadatensatz gespeicherten Schlüsselwörtern

  • Microsoft Office Dateien (.doc, .xls, .ppt):

    • Titel: aus dem im Metadatensatz der Ressource gespeicherten Titel

    • Schlüsselwörter: aus den im Metadatensatz der Ressource gespeicherten Schlüsselwörtern

Metadaten werden in jCAPT aus Ressourcen, auf die ein Ressource-Referenz-Knoten verweist, extrahiert. Anschließend werden Sie in einem entsprechenden Metadatensatz zum jeweiligen Ressource-Referenz-Knoten hinzugefügt. Verwendet wird hierzu das IMS LRM Schema in den Versionen 1.1.1, 1.1.2 oder 1.1.3. Falls ein Metadatensatz in einem derartigen Schema vorhanden ist, so wird er um die Metadaten aus der Extraktion ergänzt. Ist keiner vorhanden, wird ein neuer mit den extrahierten Metadaten erstellt.

Das Starten der Metadatenextraktion kann auf zweierlei Arten erledigt werden:

  • Betätigen der Schaltfläche Metadaten extrahieren der Manifestansicht

    Metadaten extrahieren über die Symbolleiste.

    Abbildung 2.193. Metadaten extrahieren über die Symbolleiste.

  • Öffnen des Menüs Bearbeiten und Wahl des Menüeintrags Metadaten extrahieren...

    Metadaten extrahieren über das Menü.

    Abbildung 2.194. Metadaten extrahieren über das Menü.

In beiden Fällen wird der Extraktionsprozes gestartet. Der Verlauf des Extraktionsvorganges wird über eine Fortschrittsanzeige visualisiert. Über die Schaltfläche Abbrechen kann die Extraktion abgebrochen werden.

Fortschrittsanzeige beim Extrahieren von Metadaten.

Abbildung 2.195. Fortschrittsanzeige beim Extrahieren von Metadaten.

Am Ende des Extraktionsprozesses wird das aktuelle CPS-Paket aus technischen Gründen automatisch geschlossen und wieder geöffnet. Anschließend erscheint eine Meldung, welche die erfolgreiche Extraktion bestätigt. Im Statusfenster können Sie bei der Extraktion eventuell aufgetretene Fehler sehen.

Metadaten erfolgreich extrahiert.

Abbildung 2.196. Metadaten erfolgreich extrahiert.

Unterhalb der Ressource-Referenz-Knoten können Sie im Anschluss die extrahierten Metadaten finden. Falls bei einem (oder mehreren) Ressource-Referenz-Knoten der Metadatensatz fehlt, so wurden entweder keine gefunden oder der Dateityp der Ressource wird nicht unterstützt.


2.8. Lernpaketexport

2.8.1. CPS-Paket als ZIP-Archiv exportieren
2.8.2. CPS-Paket als Offline-Version exportieren

Um ein erstelltes CPS-Paket anderen Entwicklern und den Lernenden zur Verfügung stellen zu können, kann es aus jCAPT heraus exportiert werden. Hierbei werden zwei Ausgabeformate unterstützt:

  • ZIP-Archiv: zur Verwendung in einem Learning Management System (LMS) und zum bequemen Transport des CPS-Pakets

  • Offline-Version: als im Browser darstellbare Sicht auf die Struktur (zur Navigation im Paket) und die Metadaten.


2.8.1. CPS-Paket als ZIP-Archiv exportieren

Um das CPS-Paket in ein Learning Management System (LMS) hochzuladen, muss es zuerst in ein Package Interchange File gepackt werden. jCAPT unterstützt zu diesem Zweck das Packen des Pakets in ein ZIP-Archiv. Dies ermöglicht es, ein gesamtes CPS-Paket, sowohl das Manifest als auch die Ressourcen, bequem und platzsparend zu transportieren.

[Anmerkung] Anmerkung

Es werden die gesamten Ressourcen, welche sich im Basisordner oder darunter befinden, in das ZIP-Archiv gepackt. Dies geschieht unabhängig davon, ob diese Ressourcen im Manifest referenziert werden oder nicht.

Zum Anstoßen des Exportierens des aktuellen CPS-Pakets als ZIP-Archiv gibt es zwei Möglichkeiten:

  • Betätigen der Schaltfläche Zippen in der Symbolleiste

    CPS-Paket als ZIP-Archiv exportieren über die Symbolleiste.

    Abbildung 2.197. CPS-Paket als ZIP-Archiv exportieren über die Symbolleiste.

  • Öffnen des Menüs Datei und Wahl des Menüeintrags CPS-Paket zippen...

    CPS-Paket als ZIP-Archiv exportieren über das Menü.

    Abbildung 2.198. CPS-Paket als ZIP-Archiv exportieren über das Menü.

Wurde das CPS-Paket seit der letzten Speicherung verändert, so erscheint eine Abfrage, ob es gespeichert werden soll. Wählen Sie Ja um das CPS-Paket zu speichern und mit dem Export fortzufahren. Wenn Sie Nein wählen, so wird das CPS-Paket nicht gespeichert und ebenfalls fortgesetzt. Die ZIP-Datei wird das Manifest dann in seinem letzten gespeicherten Zustand enthalten. Wenn Sie Abbrechen wählen, so wird der Exportvorgang abgebrochen ohne eine Änderung am CPS-Paket vorzunehmen.

Speichern vor dem Exportieren.

Abbildung 2.199. Speichern vor dem Exportieren.

Anschließend öffnet sich ein Dialog, in welchem Sie den Pfad und Dateinamen des zu erstellenden ZIP-Archivs festlegen können. Wählen Sie den Zielpfad, vergeben Sie einen Dateinamen und betätigen Sie die Schaltfläche Speichern.

Name und Pfad des zu erstellenden ZIP-Archivs festlegen.

Abbildung 2.200. Name und Pfad des zu erstellenden ZIP-Archivs festlegen.

Der Zippen-Vorgang wird gestartet und es erscheint eine Anzeige, welche den Fortgang des Exportiervorgangs anzeigt und die Möglichkeit gibt, diesen abzubrechen.

Fortschrittsanzeige beim Erstellen des ZIP-Archivs.

Abbildung 2.201. Fortschrittsanzeige beim Erstellen des ZIP-Archivs.

Eine abschließende Meldung informiert über das erfolgreiche Abschließen des Exportiervorgangs.

Exportieren als ZIP-Archiv erfolgreich abgeschlossen.

Abbildung 2.202. Exportieren als ZIP-Archiv erfolgreich abgeschlossen.

Zur Illustration finden Sie im Folgenden eine Animation der zu tätigenden Aktionen.

Abbildung 2.203. Animation: CPS-Paket als ZIP-Archiv exportieren.


2.8.2. CPS-Paket als Offline-Version exportieren

Damit das CPS-Paket ohne spezielle Software nur mit einem Browser betrachtet werden kann, muss es als Offline-Version exportiert werden. Diese eignet sich besonders zum Erstellen von Lern-CDs.

Zum Anstoßen des Exportierens des aktuellen CPS-Pakets als Offline-Version gibt es zwei Möglichkeiten:

  • Betätigen der Schaltfläche CPS Paket exportieren in der Symbolleiste

    CPS-Paket als Offline-Version exportieren über die Symbolleiste.

    Abbildung 2.204. CPS-Paket als Offline-Version exportieren über die Symbolleiste.

  • Öffnen des Menüs Datei und Wahl des Menüeintrags CPS-Paket exportieren...

    CPS-Paket als Offline-Version exportieren über das Menü.

    Abbildung 2.205. CPS-Paket als Offline-Version exportieren über das Menü.

Wurde das CPS-Paket seit der letzten Speicherung verändert, so erscheint eine Abfrage, ob es gespeichert werden soll. Wählen Sie Ja um das CPS-Paket zu speichern und mit dem Export fortzufahren. Wenn Sie Nein wählen, so wird das CPS-Paket nicht gespeichert und ebenfalls fortgesetzt. Die Offline-Version wird dann die Struktur des Manifests in seinem letzten gespeicherten Zustand enthalten. Wenn Sie Abbrechen wählen, so wird der Exportvorgang abgebrochen ohne eine Änderung am CPS-Paket vorzunehmen.

Speichern vor dem Exportieren.

Abbildung 2.206. Speichern vor dem Exportieren.

Anschließend öffnet sich ein Dialog, in welchem Sie eine Vielzahl von Einstellungen für den Export tätigen können.


2.8.2.1. Grundlegende Export-Einstellungen vornehmen

Für den Export des CPS-Pakets als Offline-Version können viele Einstellungen getätigt werden. Die wichtigsten sind im Export-Dialog zusammengefasst:

  • Titel: dieser wird später oberhalb des Inhalts angezeigt.

  • Organisation exportieren: zur Wahl der zu exportierenden Organisation, wenn mehr als eine existieren.

  • Vorlagenordner: Ordner, in dem die Vorlagen für die zu erstellenden HTML-Dateien liegen. Mit ihnen kann das Aussehen der Offline-Version angepasst werden.

  • Ausgabeordner: der Ordner, in welchem die Offline-Version gespeichert wird.

  • Übersichtsseite: diese HTML-Seite wird beim Anzeigen der Organisation in der Offline-Version dargestellt.

  • Auf Dateien außerhalb des Ausgabeordners prüfen: prüft, ob auch tatsächlich alle referenzierten Dateien in den Ausgabeordner kopiert wurden.

  • Nach Export zippen: veranlasst die Erstellung eines ZIP-Archivs nach erfolgtem Export.

[Tipp] Tipp

Der Vorlagen- und der Ausgabeordner sowie die Übersichtsseite können durch Betätigen der Schaltfläche rechts neben ihrem Eingabefeld über eine Dateiwahl-Dialog ausgewählt werden.

Einstellungen für Export als Offline-Version vornehmen.

Abbildung 2.207. Einstellungen für Export als Offline-Version vornehmen.


2.8.2.2. Erweiterte Export-Einstellungen vornehmen

Neben den Basiseinstellungen kann man den Export als Offline-Version noch mit einer Reihe erweiterter Einstellungen anpassen. Um den Dialog zum Bearbeiten der erweiterten Export-Einstellungen aufzurufen müssen Sie die Schaltfläche Erweitert... im Export-Dialog betätigen.

Erweiterte Export-Einstellungen vornehmen.

Abbildung 2.208. Erweiterte Export-Einstellungen vornehmen.

Es öffnet sich ein Dialog mit mehreren Registerkarten, welche alle einen Aspekt des Offline-Exports behandeln. In der ersten Registerkarte Konverter lassen sich folgende Einstellungen tätigen:

  • Automatisch letzten Zustand laden (Normaleinstellung: Nicht ausgewählt): diese Einstellung hat keinen Einfluss auf das Verhalten von jCAPT und ist aus Gründen der Kompatiblität zu einem externen Produkt enthalten.

  • Auf Dateien außerhalb des Ausgabeverzeichnisses prüfen (Normaleinstellung: Ausgewählt): Ist das Kästchen angehakt, wird beim Export geprüft, ob eine der referenzierten Dateien sich außerhalb des Ausgabeverzeichnisses befindet. Beim Verarbeiten einer derartigen Datei wird dann beim Export eine Warnung angezeigt.

  • Alle Dateien im Ausgabeverzeichnis zippen (Normaleinstellung: Nicht ausgewählt): Wird dieses Kästchen aktiviert, so wird beim Packen in ein ZIP-Archiv das gesamte Ausgabeverzeichnis rekursiv eingepackt unabhängig davon, ob die Dateien auch tatsächlich referenziert werden. Ansonsten werden alle Dateien aus dem Manifest sowie alle, die aus diesen Inhalten extrahiert werden konnten, eingepackt.

    Dies betrifft insbesondere Webseiten, welche andere Webseiten über JavaScript öffnen: Derartige Links können nicht erkannt werden. Die Idealversion ist jedoch die Integration derartiger Dateien in das Manifest als Abhängigkeit (Datei/URL)-Knoten der Ressource-Referenz, zu welcher sie gehören.

  • Standard Sprachcode (Normaleinstellung: x-none): Mit diesem Feld kann der Standard-Sprachcode spezifiziert werden. Dieser wird verwendet um multilingual vorhandene Überschriften oder Metadaten auszuwählen. Bleibt dieses Feld leer, wird der Standardwert aus der Vorlage verwendet.

    Die Angabe sollte nicht zu genau sein: Ein Sprachcode de-AT passt nicht zu Metadaten der Sprache de, sondern nur auf de-AT. Umgelehrt passt ein Sprachcode von de zu de, de-AT wie auch de-GE. x-none passt auf alle Sprachen, d.h. alle Sprachversionen werden angezeigt.

    Wenn mehrere mögliche Elemente auf den Sprachcode passen, so werden alle durch Beistriche getrennt angezeigt. Bitte beachten Sie, daß bei der Anzeige von Metadaten die Überschriften auch dann angezeigt werden, wenn aufgrund des Sprachcodes alle Detailinformationen unterdrückt werden!

Erweiterte Export-Einstellungen "Konverter".

Abbildung 2.209. Erweiterte Export-Einstellungen "Konverter".

In der ersten Registerkarte Kompatibilität lassen sich folgende Einstellungen tätigen:

  • Submanifeste mit einem einzigen Item komprimieren (Normaleinstellung: Ausgewählt): da in der aktuellen Version von jCAPT noch keine Submanifeste unterstützt werden, hat diese Einstellung vorerst keine Auswirkung auf den Export.

  • Unsichtbarkeit vererben (Normaleinstellung: ausgewählt): Nach der IMS CPS-Spezifikation wird ein unsichtbarer Inhalt-Knoten nicht angezeigt, aber seine sichtbaren Kind-Knoten rücken an seine Stelle. Um daher einen gesamten Unterbaum unsichtbar zu machen, muss jeder einzelne Knoten als unsichtbar markiert werden. Dies kann auch zu "seltsamen" Ergebnissen führen: Ein einzelner Knoten könnte durch eine große Anzahl von Kindern (aber auch seiner Ur-Ur-Enkel) ersetzt werden.

    Diese Option erlaubt es daher, Unsichtbarkeit zu vererben: Ist ein Knoten als unsichtbar markiert, so wird sowohl dieser Knoten als auch alle seine Nachkommen unterdrückt und nicht angezeigt. Unmarkierte Knoten sind standardmäßig sichtbar und daher von dieser Option nicht betroffen.

Erweiterte Export-Einstellungen "Kompatibilität".

Abbildung 2.210. Erweiterte Export-Einstellungen "Kompatibilität".

In der ersten Registerkarte Anpassung lassen sich folgende Einstellungen tätigen:

  • In dem Bereich Startseiten Inhalt können einige Felder spezifiziert werden, welche auf der Startseite der Offline-Version angezeigt werden. Die Felder Titel, Untertitel, Text und Bild können beliebig gesetzt werden. Das Bild wird in das Ausgabeverzeichnis kopiert.

  • Das Feld Kopfzeilen Bild spezifiziert das Bild in der linken oberen Ecke jeder Rahmenseite (bzw. wo es sonst in der Vorlage platziert wird). Das Bild wird in das Ausgabeverzeichnis kopiert.

Erweiterte Export-Einstellungen "Anpassung".

Abbildung 2.211. Erweiterte Export-Einstellungen "Anpassung".

In der ersten Registerkarte Taxonomie lassen sich folgende Einstellungen tätigen:

  • Nach Taxonomie filtern (Normaleinstellung: Nicht ausgewählt): Wenn dieses Feld angehakt ist, wird eine zusätzliche Filterung der anzuzeigenden Inhalt-Knoten vorgenommen. Die taxonomy-Felder des LOM Standards werden zusätzlich (zum Parameter visible) verwendet um zu entscheiden, ob ein Inhalt-Knoten bei der Erzeugung der Navigationsstruktur dargestellt werden soll oder nicht.

    Im Feld Quelle kann die Quelle der Taxonomie für die Filterung angegeben werden. Ist dieses Feld leer, so wird jeweils die erste angetroffene (welche bei den Metadaten jedes Inhalt-Knotens unterschiedlich sein kann) verwendet.

    Im Feld Taxon Werte ist der zu vergleichende Wert einzugeben (dies bezieht sich auf den Wert id des Taxons; der Pfad kann mit Schrägstrichen spezifiziert werden, z.B. 12.1/12.1.3). Taxon Werte können am Anfang oder am Ende einen Stern (*) beinhalten: Dort können beliebige Werte stehen.

Erweiterte Export-Einstellungen "Taxonomie".

Abbildung 2.212. Erweiterte Export-Einstellungen "Taxonomie".

In der ersten Registerkarte Roadmap lassen sich folgende Einstellungen tätigen:

  • Roadmap zeigt Aggregations-Stufe (Normaleinstellung: 2): Hiermit kann die Aggregationsstufe eingestellt werden, welche bei der Darstellung der graphischen Roadmap als Punkt dargestellt wird. Es kann entweder Alle (Elemente jeglicher Stufe werden dargestellt) oder die Werte von 1 (einzelnes Element, z. B. Bild) über 2 (Lerneinheit, z. B. Webseite) und 3 (Kurs, z. B. mehrere Textdateien) bis hin zu 4 (Studiengang, z. B. mehrere Kurse) ausgewählt werden. Dies hat auf die Darstellung in der Navigationsansicht keine Auswirkung.

  • Passende Stufe ist endgültig (Normaleinstellung: Ausgewählt): Wenn dieser Punkt aktiviert ist, erfolgt keine Suche nach weiteren Kind-Elementen mehr, sobald ein Element mit der gewünschten oder niedrigeren Stufe gefunden wurde. Beispiel: Wenn aktiviert und als Stufe wurde 2 gewählt, so wird die Struktur 3/2/3/1 als 3/2 dargestellt, wenn deaktiviert als 3/2/3.

  • Vertikale Darstellung (Normaleinstellung: Ausgewählt): Ist dieses Feld angekreuzt, wird die Roadmap vertikal dargestellt (von oben nach unten). Bleibt das Feld leer, so erfolgt die Darstellung von links nach rechts.

Erweiterte Export-Einstellungen "Roadmap".

Abbildung 2.213. Erweiterte Export-Einstellungen "Roadmap".

In der ersten Registerkarte Indizierung lassen sich folgende Einstellungen tätigen:

  • Index erzeugen (Normaleinstellung: Ausgewählt): Ist dieser Punk aktiviert, so wird ein Index aus allen Stichwörtern, welche in den Metadaten des Manifests eingetragen sind, erstellt. Der zugehörige Link wird in der Offline-Version unter der Navigation angezeigt. Klicks auf der Index-Seite führen direkt zu den entsprechenden Seiten.

Erweiterte Export-Einstellungen "Indizierung".

Abbildung 2.214. Erweiterte Export-Einstellungen "Indizierung".


2.8.2.3. Export-Einstellungen speichern/laden

Damit nicht immer die gleichen Dinge eingestellt werden müssen kann man die getätigten Export-Einstellungen für einen späteren Durchlauf speichern. Betätigen Sie dazu die Schaltfläche Einstellungen speichern.... Es öffnet sich ein Dateiwahl-Dialog, in welchem Sie den Namen und Pfad der zu erstellenden Datei festlegen können.

Abbildung 2.215. Export-Einstellungen speichern.

Gespeicherte Einstellungen können auch wieder geladen werden. Betätigen Sie dazu die Schaltfläche Einstellungen laden.... Es öffnet sich ein Dateiwahl-Dialog, in welchem Sie die zu ladende Einstellungen-Datei festlegen können.

Abbildung 2.216. Export-Einstellungen laden.

[Achtung] Achtung

Wenn Sie Einstellungen laden, so werden die im Dialog bisher getätigten Einstellungen überschrieben. Um dies zu verhindern können Sie sie zuvor speichern.


2.8.2.4. Export als Offline-Version starten

Wenn Sie alle nötigen Einstellungen getätigt haben können Sie den Exportvorgang durch Betätigen der Schaltfläche Exportieren... starten.

Export als Offline-Version starten.

Abbildung 2.217. Export als Offline-Version starten.

Es erscheint ein Fenster, welches Statusmeldungen zum Export anzeigt, und bei Paketen mit vielen bzw. großen Ressourcen informiert eine Fortschrittsanzeige über den Verlauf des Kopierens der Ressourcen in den Ausgabeordner.

Statusmeldungen beim Export als Offline-Version.

Abbildung 2.218. Statusmeldungen beim Export als Offline-Version.

Nachdem der Export abgeschlossen ist, werden die drei Schaltflächen am unteren Rand des Dialogs akktiviert. Betätigen Sie die Schaltfläche Speichern, wenn Sie die Meldungen speichern möchten, bzw. Drucken, wenn Sie sie drucken möchten. Betätigen der Schaltfläche Schließen schließt den Dialog und kehrt zum Export-Dialog zurück.


2.8.2.5. Exportierte Offline-Version betrachten

Solange Sie keinen Export gestartet haben, ist die Schaltfläche Letztes Ergebnis anzeigen... am unteren Rand des Export-Dialogs deaktiviert. Nach einem Export wird sie aktiviert und ermöglicht das Betrachten des Ergebnisses des Exports im standardmäßig im System eingestellten Browser (z.B. Internet Explorer, Mozilla Firefox, Opera, ...).

Exportierte Offline-Version betrachten.

Abbildung 2.219. Exportierte Offline-Version betrachten.

[Anmerkung] Anmerkung

Wenn Sie erneut einen Export starten, ohne den Export-Dialog zu schließen, so werden die selben Einstellungen wieder verwendet. Ein nachfolgendes Betrachten der Offline-Version zeigt jeweils die zuletzt exportierte.


Teil II. Referenz

jCAPT Java Content Assembling and Packaging Tools

Referenz

Inhaltsverzeichnis

1. Programmkonfiguration
1.1. Einstellungen-Dialog öffnen
1.2. Allgemeine Einstellungen
1.3. Einstellungen zu CPS-Paketen
1.4. Einstellungen für die Metadatenbearbeitung
2. Berechnung der Speicherposition von Ressourcen
3. Bestimmung der Abhängigkeiten von Ressourcen


Kapitel 1. Programmkonfiguration

Inhaltsverzeichnis

1.1. Einstellungen-Dialog öffnen
1.2. Allgemeine Einstellungen
1.3. Einstellungen zu CPS-Paketen
1.4. Einstellungen für die Metadatenbearbeitung

Für eine bessere Anpassung an den/die jeweilige Benutzer/in kann man gewisse Aspekte von jCAPT konfigurieren. Diese Konfiguration wird beim Beenden von jCAPT im Einstellungen-Verzeichnis des/der am Betriebssystems angemeldeten Benutzers/in in der Datei jCAPT-Prefs.xml gespeichert. Die meisten Einstellungen wirken sofort nach Schließen des Einstellen-Dialogs, für manche muss man jCAPT neu starten.


1.1. Einstellungen-Dialog öffnen

Sämtliche Einstellungen für jCAPT werden im Einstellungen-Dialog vorgenommen. Um diesen zu öffnen müssen Sie das Menü Extras öffnen und dort den Menüeintrag Einstellungen... wählen.

Abbildung 1.1. Einstellungen-Dialog öffnen.


1.2. Allgemeine Einstellungen

Die allgemeinen Einstellungen beziehen sich auf grundlegende Aspekte in der Bedienung von jCAPT. Folgende Einstellungen können getätigt werden:

  • Standardordner zum Öffnen: Dialogezum Wählen von zu öffnenden CPS-Paketen bzw. zu importierenden Dateien zeigen standardmäßig diesen Ordner. Der Ordner kann durch Betätigen der Schatlfläche rechts neben dem Eingabefeld in einem Dateiwahl-Dialog gewählt werden.

  • Sprache: in der Oberfläche von jCAPT verwendete Sprache. Damit diese Einstellung wirksam wird, muss jCAPT neu gestartet werden.

Abbildung 1.2. Allgemeine Einstellungen.


1.3. Einstellungen zu CPS-Paketen

In den Einstellungen zu CPS-Paketen können Aspekte zur Bearbeitung von Lernpaketen konfiguriert werden. Folgende Einstellmöglichkeiten sind vorhanden:

  • Standard CPS Schema: hier kann das Schema gewählt werden, nach welchem das Manifest in einem neuen CPS-Paket erstellt wird.

  • Nach Schema beim Erstellen eines neuen CPS-Pakets fragen: wenn diese Einstellung aktiviert ist, so wird beim Erstellen eines neuen CPS-Pakets nach dem Schema gefragt, nach welchem das Manifest erstellt werden soll.

  • Vorschau für Dateien mit Endung: diese mit Kommata getrennte Liste von Dateiendungen bezeichnet jeden Dateitypen, welche von der Vorschau angezeigt werden.

  • Ressource-Referenzen ausblenden: wenn diese Einstellung aktiviert ist, so werden in der Manifest-Struktur die Ressource-Referenz-Knoten ausgeblendet. Dies kann hilfreich sein, wenn man nur ein einfaches CPS-Paket erstellt und keine erweiterten Einstellungen vornimmt. Die Einstellung wird erst beim nächsten Laden eines CPS-Pakets wirksam.

Einstellungen zu CPS-Paketen.

Abbildung 1.3. Einstellungen zu CPS-Paketen.


1.4. Einstellungen für die Metadatenbearbeitung

In diesem Teil des Dialogs können Einstellungen betreffend die Metadatenbearbeitung vorgenommen werden. Folgende Einstellmöglichkeiten sind vorhanden:

  • Standard Schema: hier kann das Schema gewählt werden, nach welchem neue Metadaten standardmäßig erstellt werden.

  • Standard Profil: hier kann das Profil gewählt werden, welches beim Start der Bearbeitung der Metadaten des Standard Schemas verwendet werden soll.

  • Nach Schema beim Erstellen von neuen Metadaten fragen: wenn diese Einstellung aktiviert ist, so wird beim Erstellen neuer Metadaten nach deren Schema gefragt.

Einstellungen für die Metadatenbearbeitung.

Abbildung 1.4. Einstellungen für die Metadatenbearbeitung.


Kapitel 2. Berechnung der Speicherposition von Ressourcen

Für eine(n) festgelegte(n) Basispfad/-URL (im Manifest-, Ressource-Referenzen- oder einem Ressource-Referenz-Knoten) und eine gegebene Speicherposition (in einem Ressource-Referenz- oder Abhängigkeit (Datei/URL)-Knoten) wird die reale Speicherposition der Ressource wie in folgendem Beispiel berechnet:

Basispfad/-URL | Speicherposition | Resultat | Erklärung
content/ | sinus.html | content/sinus.html | Zwei relative Positionsangaben ergeben wiederum eine relative Positionsangabe.
file:/D:/Pakete/ | Elemente/Eisen.html | file:/D:/Pakete/Elemente/Eisen.html | Der absolute Basispfad ergibt zusammen mit der relativen Positionsangabe einen absoluten Pfad.
http://www.lernen.at/ | images/logo.gif | http://www.lernen.at/images/logo.gif | Die absolute Basis-URL ergibt zusammen mit der relativen Positionsangabe eine absolute URL.
content/ | file:/D:/Pakete/Italien/Rom.jpg | file:/D:/Pakete/Italien/Rom.jpg | Ein absoluter Pfad wird durch einen Basis-Pfad nicht verändert.
http://www.lernen.at/ | ftp://www.mathsym.org/alpha.gif | ftp://www.mathsym.org/alpha.gif | Eine absolute URL wird durch eine Basis-URL nicht verändert.


Kapitel 3. Bestimmung der Abhängigkeiten von Ressourcen

Um die Abhängigkeiten von Ressourcen zu bestimmen werden diese nach URLs und anderen Angaben von Speicherpositionen durchsucht. Dies funktioniert allerdings nur bei Dateien, für welche ein Parser verfügbar ist. Es sind dies (mit den Dateiendungen):

  • Statische Webseiten: .htm, .html, .shtm, .shtml

  • PHP-Seiten: .php, .php3, .php4

  • ASP-Seiten: .asp, .aspx, .asa

  • ColdFusion-Seiten: .cfm

  • Stylesheets: .css

  • JavaScript-Dateien: .js

Bei Stylesheets wird nach Angaben von Speicherpositionen innerhalb eines umschließenden url() gesucht.

Bei allen restlichen Dateien wird in HTML-Tags nach Angaben von Speicherpositionen innerhalb der folgenden Attribute gesucht:

  • href: für Hyperlinks

  • background: unter anderem verwendet in Tabellen und im body

  • src: unter anderem verwendet in object und embed

  • code: verwendet bei Applets

  • action: verwendet zum Übertragen von Formularen

Zusätzlich werden auch die folgenden JavaScript-Event-Attribute auf Speicherpositionen innerhalb von Hochkommata durchsucht:

  • onclick

  • ondblclick

  • onkeydown

  • onkeypress

  • onkeyup

  • onmousedown

  • onmouseover

  • onmouseout

Handelt es sich bei einer gefundenen Speicherposition um einen Verweis auf eine lokale Datei, so wird diese zur Menge der Abhängigkeiten hinzugefügt.


Bedienungsanleitung

jCAPT Java Content Assembling and Packaging Tools

Abbildungsverzeichnis

1.1. Start von jCAPT über das Startmenü.
1.2. Hauptfenster nach dem Start.
1.3. Animation: Starten von jCAPT.
1.4. Neues CPS-Paket erstellen.
1.5. Basisordner für neues CPS-Paket wählen.
1.6. Arbeitsfläche zum Bearbeiten der Ressourcen und des Manifests.
1.7. Animation: Neues CPS-Paket erstellen.
1.8. Importieren von Ressourcen.
1.9. Auswahl von zu importierenden Ressourcen.
1.10. Fortschrittsanzeige beim Importieren.
1.11. Importierte Ressourcen in der Ressourcensammlung.
1.12. Animation: Ressourcen importieren.
1.13. Organisation-Knoten hinzufügen.
1.14. Neue Organisation benennen.
1.15. Neu erstellter Organisation-Knoten.
1.16. Ressource in Manifest einbinden.
1.17. Ressource als Kindknoten in Manifest einbinden.
1.18. Schaltflächen zum Ändern der Reihenfolge von Inhalt-Knoten.
1.19. Speichern des CPS-Pakets.
1.20. Animation: Manifest aufbauen.
1.21. Dateivorschau aktivieren.
1.22. Dateivorschau für Ressource.
1.23. Dateivorschau für Inhalt-Knoten
1.24. Animation: Dateivorschau benutzen.
1.25. Paketvorschau aktivieren.
1.26. Fortschrittsanzeige beim Erstellen der Paketvorschau.
1.27. Vorschau für CPS-Paket.
1.28. Animation: Paketvorschau benutzen.
1.29. Metadaten für Manifest/Organisation/Inhalt-Knoten hinzufügen.
1.30. Auswahl des Metadatenschemas.
1.31. Registerkarten im Metadaten-Dialog.
1.32. Formular-Ansicht im Metadaten-Dialog.
1.33. Baum-Ansicht im Metadaten-Dialog.
1.34. Metadaten-Knoten in der Baum-Ansicht hinzufügen.
1.35. Eingabemöglichkeiten für den Wert von Metadaten-Knoten.
1.36. Speichern der Metadaten.
1.37. Metadaten-Knoten in der Manifeststruktur.
1.38. Animation: Metadaten hinzufügen.
1.39. CPS-Paket als ZIP-Archiv exportieren.
1.40. Name und Pfad des zu erstellenden ZIP-Archivs festlegen.
1.41. Fortschrittsanzeige beim Erstellen des ZIP-Archivs.
1.42. Exportieren als ZIP-Archiv erfolgreich abgeschlossen.
1.43. Animation: CPS-Paket als ZIP-Archiv exportieren.
1.44. CPS-Paket als Offline-Version exportieren.
1.45. Einstellungen für Export als Offline-Version vornehmen.
1.46. Statusmeldungen beim Export als Offline-Version.
1.47. Ergebnis des Exports als Offline-Version betrachten.
1.48. Animation: CPS-Paket als Offline-Version exportieren.
2.1. Start von jCAPT über das Startmenü.
2.2. Hauptfenster nach dem Start.
2.3. Animation: Starten von jCAPT.
2.4. Tip des Tages
2.5. Schaltfläche zum Anzeigen des nächsten Tip des Tages.
2.6. Animation: Nächsten Tip des Tages anzeigen.
2.7. Benutzerhilfe anzeigen über den Schnellstartbereich.
2.8. Benutzerhilfe anzeigen über das Menü.
2.9. Programminformationen anzeigen.
2.10. Dialog mit Programminformationen.
2.11. Animation: Programminformationen anzeigen.
2.12. Statusfenster anzeigen.
2.13. Statusfenster mit Startmeldungen.
2.14. Operationen im Statusfenster.
2.15. Animation: Statusfenster anzeigen/bedienen/schließen.
2.16. Programmeinstellungen ändern über den Schnellstartbereich.
2.17. Benutzerhilfe anzeigen über das Menü.
2.18. Konfigurationsdialog für die Programmeinstellungen.
2.19. Beenden von jCAPT über die Standard-Schaltfläche zum Schließen.
2.20. Beenden von jCAPT über das Menü.
2.21. Ungespeicherte Änderungen speichern.
2.22. Neues CPS-Paket erstellen über den Schnellstartbereich.
2.23. Neues CPS-Paket erstellen über die Symbolleiste.
2.24. Neues CPS-Paket erstellen über das Menü.
2.25. Basisordner für neues CPS-Paket wählen.
2.26. Arbeitsfläche zum Bearbeiten der Ressourcen und des Manifests.
2.27. Animation: Neues CPS-Paket erstellen.
2.28. Vorhandenes CPS-Paket öffnen über den Schnellstartbereich.
2.29. Vorhandenes CPS-Paket öffnen über die Symbolleiste.
2.30. Vorhandenes CPS-Paket öffnen über das Menü.
2.31. Wahl des vorhandenen CPS-Pakets zum Öffnen.
2.32. Ordner zum Entpacken des gezippten CPS-Pakets.
2.33. Vorhandenes CPS-Paket geöffnet.
2.34. Pfad des Basisordners des geöffneten CPS-Pakets.
2.35. Animation: Vorhandenes CPS-Paket öffnen.
2.36. Kürzlich bearbeitetes CPS-Paket öffnen über den Schnellstartbereich.
2.37. Kürzlich bearbeitetes CPS-Paket öffnen über das Menü.
2.38. Animation: Kürzlich bearbeitetes CPS-Paket öffnen.
2.39. Liste der geöffneten CPS-Pakete.
2.40. Animation: Zwischen geöffneten CPS-Paketen wechseln.
2.41. CPS-Paket speichern über die Symbolleiste.
2.42. CPS-Paket speichern über das Menü.
2.43. Verändert-Anzeige
2.44. Animation: CPS-Paket speichern.
2.45. Schaltfläche zum Schließen eines CPS-Pakets.
2.46. Speichern ungespeicherter Änderungen.
2.47. Animation: CPS-Paket schließen.
2.48. Fortschrittsanzeige beim Importieren.
2.49. Vorhandene Ressource(n) beim Import überschreiben.
2.50. Importierte Ressourcen in der Ressourcensammlung.
2.51. Import-Dialog aufrufen über die Symbolleiste der Ressourcensammlung.
2.52. Import-Dialog aufrufen über das Menü.
2.53. Import-Dialog mit Auswahl von zu importierenden Ressourcen.
2.54. Animation: Dateien/Ordner über den Import-Dialog importieren.
2.55. Dateien/Ordner mittels Drag-and-Drop importieren.
2.56. Animation: Dateien/Ordner mittels Drag-and-Drop importieren.
2.57. Abhängigkeiten beim Importieren berücksichtigen.
2.58. Animation: Abhängigkeiten beim Importieren berücksichtigen.
2.59. Neuen Ordner in der Ressourcensammlung erstellen über die Symbolleiste.
2.60. Neuen Ordner in der Ressourcensammlung erstellen über das Kontextmenü.
2.61. Wahl des Namens für den neu zu erstellenden Ordner.
2.62. Animation: Neuen Ordner in der Ressourcensammlung anlegen.
2.63. Ressourcen löschen über die Symbolleiste.
2.64. Ressourcen löschen über das Kontextmenü.
2.65. Sicherheitsabfrage beim Löschen einer Datei.
2.66. Sicherheitsabfrage beim Löschen eines Ordners.
2.67. Animation: Ressourcen löschen.
2.68. Ansicht in der Ressourcensammlung aktualisieren
2.69. Animation: Ansicht in der Ressourcensammlung aktualisieren.
2.70. Ressourcen verschieben.
2.71. Vorhandene Ressource(n) beim Verschieben überschreiben.
2.72. Animation: Ressourcen verschieben.
2.73. Ressourcen kopieren.
2.74. Vorhandene Ressource(n) beim Kopieren überschreiben.
2.75. Animation: Ressourcen kopieren.
2.76. Aktion(en) rückgängig machen über die Symbolleiste.
2.77. Aktion(en) rückgängig machen über das Menü.
2.78. Animation: Aktion(en) rückgängig machen.
2.79. Aktion(en) wiederholen über die Symbolleiste.
2.80. Aktion(en) wiederholen über das Menü.
2.81. Animation: Aktion(en) wiederholen.
2.82. Reihenfolge von Knoten verändern über die Symbolleiste.
2.83. Reihenfolge von Knoten verändern über das Menü.
2.84. Reihenfolge von Knoten verändern über das Kontextmenü.
2.85. Knoten verschieben.
2.86. Knoten kopieren.
2.87. Knoten in die Zwischenablage ausschneiden über die Symbolleiste.
2.88. Knoten in die Zwischenablage ausschneiden über das Menü.
2.89. Knoten in die Zwischenablage ausschneiden über das Kontextmenü.
2.90. Knoten in die Zwischenablage kopieren über die Symbolleiste.
2.91. Knoten in die Zwischenablage kopieren über das Menü.
2.92. Knoten in die Zwischenablage kopieren über das Kontextmenü.
2.93. Knoten aus der Zwischenablage einfügen über die Symbolleiste.
2.94. Knoten aus der Zwischenablage einfügen über das Menü.
2.95. Knoten aus der Zwischenablage einfügen über das Kontextmenü.
2.96. Knoten löschen über die Symbolleiste.
2.97. Knoten löschen über das Menü.
2.98. Knoten löschen über das Kontextmenü.
2.99. Manifest-Knoten.
2.100. Basispfad/-URL für relative Speicherpositionen für das gesamte Manifest festlegen.
2.101. Manifestversion angeben.
2.102. Ressource-Referenzen-Knoten.
2.103. Basispfad/-URL für relative Speicherpositionen für alle Ressource-Referenzen festlegen.
2.104. Verweise innerhalb eines CPS-Pakets.
2.105. Ressource-Referenz-Knoten.
2.106. Ressource-Referenz-Knoten mittels Drag-and-Drop erstellen.
2.107. Ressource-Referenz-Knoten manuell erstellen.
2.108. Typ der referenzierten Ressource angeben.
2.109. Basispfad/-URL für relative Speicherpositionen für eine Ressource-Referenz festlegen.
2.110. Speicherposition der Ressource festlegen.
2.111. Abhängigkeit (Datei/URL)-Knoten.
2.112. Abhängigkeit (Datei/URL)-Knoten mittels Drag-and-Drop erstellen.
2.113. Abhängigkeit (Datei/URL)-Knoten manuell erstellen.
2.114. Speicherposition der abhängigen Datei/URL festlegen.
2.115. Abhängigkeit (Ressource-Referenz)-Knoten.
2.116. Abhängigkeit (Ressource-Referenz)-Knoten mittels Drag-and-Drop erstellen.
2.117. Abhängigkeit (Ressource-Referenz)-Knoten manuell erstellen.
2.118. Verweis auf abhängige Ressource-Referenz legen.
2.119. Auswahl der abhängigen Ressource-Referenz.
2.120. Ressource-Referenz-Knoten anzeigen
2.121. Organisationen-Knoten.
2.122. Standard-Organisation festlegen.
2.123. Auswahl der Standard-Organisation.
2.124. Organisation-Knoten.
2.125. Organisation-Knoten manuell erstellen.
2.126. Neuen Organisation-Knoten benennen.
2.127. Organisation-Knoten umbenennen.
2.128. Inhaltsstrukturierung einer Organisation festlegen.
2.129. Inhalt-Knoten.
2.130. Inhalt-Knoten mittels Drag-and-Drop einer Ressource erstellen.
2.131. Inhalt-Knoten mittels Drag-and-Drop einer Ressource-Referenz erstellen.
2.132. Inhalt-Knoten als Kindknoten mittels Drag-and-Drop erstellen.
2.133. Organisation-Knoten indirekt erstellen.
2.134. Inhalt-Knoten manuell erstellen.
2.135. Neuen Inhalt-Knoten benennen.
2.136. Inhalt-Knoten umbenennen.
2.137. Sichtbarkeit eines Inhalt-Knotens festlegen.
2.138. Verweis auf Ressource-Referenz legen.
2.139. Auswahl der Ressource-Referenz.
2.140. Ressource-Referenz-Knoten anzeigen
2.141. Parameter für Laden der Ressource angeben.
2.142. Dateivorschau-Fenster anzeigen über die Symbolleiste im Arbeitsbereich.
2.143. Dateivorschau-Fenster anzeigen über das Menü.
2.144. Ressourcen der Ressourcensammlung in der Dateivorschau anzeigen.
2.145. Referenzierte Ressource des Manifests in der Dateivorschau anzeigen.
2.146. Dateivorschau-Fenster verbergen über die Symbolleiste im Arbeitsbereich.
2.147. Dateivorschau-Fenster verbergen über das Menü.
2.148. Dateivorschau-Fenster verbergen über die Standardschaltfläche.
2.149. Paketvorschau aktivieren.
2.150. Fortschrittsanzeige beim Erstellen der Paketvorschau.
2.151. Vorschau für CPS-Paket.
2.152. Paketvorschau-Fenster schließen über die Standardschaltfläche.
2.153. Sicherheitsabfrage bei vorhandenen Dateien eines Offline-Exports.
2.154. Animation: Paketvorschau benutzen.
2.155. Metadaten im Manifest hinzufügen.
2.156. Auswahl des Metadatenschemas.
2.157. Metadaten-Knoten in der Manifeststruktur.
2.158. Metadaten-Dialog.
2.159. Metadaten-Dialog öffnen über das Menü.
2.160. Metadaten-Dialog öffnen über das Kontextmenü.
2.161. Registerkarten zum Wechsel der Ansicht im Metadaten-Dialog.
2.162. Aktion(en) rückgängig machen über die Symbolleiste.
2.163. Aktion(en) rückgängig machen über das Menü.
2.164. Aktion(en) wiederholen über die Symbolleiste.
2.165. Aktion(en) wiederholen über das Menü.
2.166. Profil für Metadaten-Schema wählen.
2.167. Metadaten-Dialog schließen.
2.168. Formular-Ansicht im Metadaten-Dialog.
2.169. Kontextsensitive Hilfe.
2.170. Kontextsensitive Hilfe für Gruppierung aufrufen.
2.171. Kontextsensitive Hilfe für Metadatenfeld aufrufen.
2.172. Wert in Metadatenfeld eingeben.
2.173. Wert aus Liste von gültigen Werten wählen.
2.174. Baum-Ansicht im Metadaten-Dialog.
2.175. Metadaten-Knoten in der Baum-Ansicht hinzufügen.
2.176. Eingabemöglichkeiten für den Wert von Metadaten-Knoten.
2.177. Eingabemöglichkeiten für den Wert von Attributen.
2.178. Reihenfolge von Knoten verändern über die Symbolleiste.
2.179. Reihenfolge von Knoten verändern über das Menü.
2.180. Reihenfolge von Knoten verändern über das Kontextmenü.
2.181. Knoten in die Zwischenablage ausschneiden über die Symbolleiste.
2.182. Knoten in die Zwischenablage ausschneiden über das Menü.
2.183. Knoten in die Zwischenablage ausschneiden über das Kontextmenü.
2.184. Knoten in die Zwischenablage kopieren über die Symbolleiste.
2.185. Knoten in die Zwischenablage kopieren über das Menü.
2.186. Knoten in die Zwischenablage kopieren über das Kontextmenü.
2.187. Knoten aus der Zwischenablage einfügen über die Symbolleiste.
2.188. Knoten aus der Zwischenablage einfügen über das Menü.
2.189. Knoten aus der Zwischenablage einfügen über das Kontextmenü.
2.190. Knoten löschen über die Symbolleiste.
2.191. Knoten löschen über das Menü.
2.192. Knoten löschen über das Kontextmenü.
2.193. Metadaten extrahieren über die Symbolleiste.
2.194. Metadaten extrahieren über das Menü.
2.195. Fortschrittsanzeige beim Extrahieren von Metadaten.
2.196. Metadaten erfolgreich extrahiert.
2.197. CPS-Paket als ZIP-Archiv exportieren über die Symbolleiste.
2.198. CPS-Paket als ZIP-Archiv exportieren über das Menü.
2.199. Speichern vor dem Exportieren.
2.200. Name und Pfad des zu erstellenden ZIP-Archivs festlegen.
2.201. Fortschrittsanzeige beim Erstellen des ZIP-Archivs.
2.202. Exportieren als ZIP-Archiv erfolgreich abgeschlossen.
2.203. Animation: CPS-Paket als ZIP-Archiv exportieren.
2.204. CPS-Paket als Offline-Version exportieren über die Symbolleiste.
2.205. CPS-Paket als Offline-Version exportieren über das Menü.
2.206. Speichern vor dem Exportieren.
2.207. Einstellungen für Export als Offline-Version vornehmen.
2.208. Erweiterte Export-Einstellungen vornehmen.
2.209. Erweiterte Export-Einstellungen "Konverter".
2.210. Erweiterte Export-Einstellungen "Kompatibilität".
2.211. Erweiterte Export-Einstellungen "Anpassung".
2.212. Erweiterte Export-Einstellungen "Taxonomie".
2.213. Erweiterte Export-Einstellungen "Roadmap".
2.214. Erweiterte Export-Einstellungen "Indizierung".
2.215. Export-Einstellungen speichern.
2.216. Export-Einstellungen laden.
2.217. Export als Offline-Version starten.
2.218. Statusmeldungen beim Export als Offline-Version.
2.219. Exportierte Offline-Version betrachten.
1.1. Einstellungen-Dialog öffnen.
1.2. Allgemeine Einstellungen.
1.3. Einstellungen zu CPS-Paketen.
1.4. Einstellungen für die Metadatenbearbeitung.